cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

196
Views
0
Helpful
3
Replies
Highlighted
Beginner

VLANS across multiple switches

Hi there, please move if in wrong forum

I have a single switch (Switch1 10.10.6.10) with three VLANS (VLAN200, VLAN300 and VLAN400)

I want to add two switches for more ports (Switch2 10.10.6.20 and Switch3 10.10.6.30) so all three switches have all three VLANS.

What are the commands I need to add to each switch to do this?

I have seen several examples on this forum, but not sure of the correct syntax

Thanks!

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Advisor

Re: VLANS across multiple switches

Hello

I assume your switch 1 is the L3 switch performing the inter-vlan routing as such below is a basic config to the successful connection 

Switch1

int x/x
description link to switch 2
switchport mode trunk
no shut

exit

int x/x
description link to switch 3
switchport mode trunk
no shut

exit



Switch2
int vlan 200
Description MGT ip address for switch
ip address 10.10.6.20 255.255.255.0
no shut

no ip routing
ip default-gateway 10.10.6.10 

int x/x
description link to switch 1
switchport mode trunk
no shut

exit

vlan 200,300,400
exit

 

int x/x
description access-port for vlan 200
switchport host
switchport access vlan 200
no shut

exit

int x/x
description access-port for vlan 300
switchport host
switchport access vlan 300
no shut

exit

etc....

 

 

 

 

Switch3
int vlan 200
Description MGT ip address for switch
ip address 10.10.6.30 255.255.255.0
no shut

no ip routing
ip default-gateway 10.10.6.10 

int x/x
description link to switch 1
switchport mode trunk
no shut

exit

vlan 200,300,400
exit

int x/x
description access-port for vlan 200
switchport host
switchport access vlan 200
no shut

exit

int x/x
description access-port for vlan 300
switchport host
switchport access vlan 300
no shut

exit

etc....

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
3 REPLIES 3
Advocate

Re: VLANS across multiple switches

Hi @14101R14944A ,

 

The links that connect the switches must be configured in trunk mode:

 

S(config)# interface f0/x

S(config-if)# switchport mode trunk 

 

To create the vlan:

 

S(config)#  vlan 200

S(config-vlan)# name <vlan name>

 

Regards

 

 

VIP Advisor

Re: VLANS across multiple switches

Hello

I assume your switch 1 is the L3 switch performing the inter-vlan routing as such below is a basic config to the successful connection 

Switch1

int x/x
description link to switch 2
switchport mode trunk
no shut

exit

int x/x
description link to switch 3
switchport mode trunk
no shut

exit



Switch2
int vlan 200
Description MGT ip address for switch
ip address 10.10.6.20 255.255.255.0
no shut

no ip routing
ip default-gateway 10.10.6.10 

int x/x
description link to switch 1
switchport mode trunk
no shut

exit

vlan 200,300,400
exit

 

int x/x
description access-port for vlan 200
switchport host
switchport access vlan 200
no shut

exit

int x/x
description access-port for vlan 300
switchport host
switchport access vlan 300
no shut

exit

etc....

 

 

 

 

Switch3
int vlan 200
Description MGT ip address for switch
ip address 10.10.6.30 255.255.255.0
no shut

no ip routing
ip default-gateway 10.10.6.10 

int x/x
description link to switch 1
switchport mode trunk
no shut

exit

vlan 200,300,400
exit

int x/x
description access-port for vlan 200
switchport host
switchport access vlan 200
no shut

exit

int x/x
description access-port for vlan 300
switchport host
switchport access vlan 300
no shut

exit

etc....

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Re: VLANS across multiple switches

Thank you Paul!

 

 

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards