cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2039
Views
9
Helpful
11
Replies

Vocera Badge Multicast between subnets

jgorman1977
Beginner
Beginner

Here's my situation.  Have Vocera badges that I need to broadcast between subnets over WAN.  Main office has a 6509 with Meraki APs and Vocera server.  Other side of WAN is 3750 with Meraki APs. If someone can take a look at my setup and let me know how far off i am, i would appreciate it.  Attached are sh igmp commands.

Main office 6509

VLAN 52-Vocera Server

interface Vlan52
 description MDF IS
 ip address 10.52.52.52 255.255.0.0
 ip helper-address 10.90.50.15
ip pim sparse-mode

WAN Link

interface Vlan354
 description Point-to-point route to Anson
 ip address 10.70.70.5 255.255.255.252
 ip pim sparse-mode

Meraki Badge Wifi

interface Vlan105
 ip address 10.105.48.1 255.255.252.0
 ip helper-address 10.90.50.46
 ip pim sparse-mode

ip pim rp-address 10.105.48.1

Remote Office 3750:

Meraki Badge Wifi

interface Vlan83
 ip address 10.80.15.1 255.255.255.0
 ip pim sparse-mode
interface Vlan354
 description Point-to-point route to Anson
 ip address 10.70.70.6 255.255.255.252
 ip pim sparse-mode
11 Replies 11

chrihussey
VIP Alumni
VIP Alumni

Do you have the RP configured on the 3750?

Yes, I do. 

Looks like you are not establishing PIM neighbors across the point to point. What type of connection is it?

I'll ask the obvious question, can you ping across the link?

Can you provide the configuration of the physical interfaces associated with the link?

I can ping across the link.  It's a dark fiber circuit currently in layer 3 mode....I may change it to layer 2 if this doesn't work. 

Here are the physical interface connections:

6509:

interface GigabitEthernet3/47
 description Single-mode Fiber connection to Zayo for Anson
 switchport
 switchport access vlan 354
 switchport mode access
 speed nonegotiate

3750:

ip multicast-routing distributed
no ip igmp snooping vlan 83

interface GigabitEthernet1/0/12
 description Single-mode Fiber connection to Zayo equipment
 switchport access vlan 354
 switchport mode access
 speed nonegotiate

If you are using an SVI and is not working

Can you try it on routed port for each site

example:

6509

config t

int g3/47

no switchport

ip adress 10.10.10.1 255.255.255.252

ip pim spar

3750

config t

int g1/0/12

no switchport

ip adress 10.10.10.2 255.255.255.252

ip pim spar

Test with ping and check pim neighbor

HTH

Agree with Reza as that is something to try. The interesting thing is that you don't have PIM neighbors across the point to point and the 3750 Vlan354 interface does not show up on the output with "show ip igmp int". So whatever issue you are having, it appears to be with the 3750, specifically across the point to point.

Is the 3750 running an IP Base or IP Services image?

Can you provide the output for "sh ip pim interface"?

Are you running a routing protocol across the link, if so what (EIGRP/RIP/OSPF) and are neighbors established or are you just doing static routing?

Does the 3750 have a route to the RPs address (10.105.48.1)?

This might help in determining what's happening.

The 3750 is running ip services and the network runs EIGRP.  Here are the outputs for sh ip pim interface:

6509

show ip igmp interface
Vlan105 is up, line protocol is up
Internet address is 10.105.48.1/22
IGMP is enabled on interface
Current IGMP host version is 2
Current IGMP router version is 2
IGMP query interval is 60 seconds
IGMP querier timeout is 120 seconds
IGMP max query response time is 10 seconds
Last member query count is 2
Last member query response interval is 1000 ms
Inbound IGMP access group is not set
IGMP activity: 1001 joins, 1000 leaves
Multicast routing is enabled on interface
Multicast TTL threshold is 0
Multicast designated router (DR) is 10.105.48.1 (this system)
IGMP querying router is 10.105.48.1 (this system)
Multicast groups joined by this system (number of users):
224.0.1.40(1)
IGMP snooping is globally enabled
IGMP snooping CGMP-AutoDetect is globally enabled
IGMP snooping is enabled on this interface
IGMP snooping fast-leave (for v2) is disabled and querier is disabled
IGMP snooping explicit-tracking is enabled
IGMP snooping last member query response interval is 1000 ms
IGMP snooping report-suppression is enabled
Vlan354 is up, line protocol is up
Internet address is 10.70.70.5/30
IGMP is enabled on interface
Current IGMP host version is 2
Current IGMP router version is 2
IGMP query interval is 60 seconds
IGMP querier timeout is 120 seconds
IGMP max query response time is 10 seconds
Last member query count is 2
Last member query response interval is 1000 ms
Inbound IGMP access group is not set
IGMP activity: 0 joins, 0 leaves
Multicast routing is enabled on interface
Multicast TTL threshold is 0
Multicast designated router (DR) is 10.70.70.5 (this system)
IGMP querying router is 10.70.70.5 (this system)
No multicast groups joined by this system
IGMP snooping is globally enabled
IGMP snooping CGMP-AutoDetect is globally enabled
IGMP snooping is enabled on this interface
IGMP snooping fast-leave (for v2) is disabled and querier is disabled
IGMP snooping explicit-tracking is enabled
IGMP snooping last member query response interval is 1000 ms
IGMP snooping report-suppression is enabled
Vlan52 is up, line protocol is up
Internet address is 10.52.52.52/16
IGMP is enabled on interface
Current IGMP host version is 2
Current IGMP router version is 2
IGMP query interval is 60 seconds
IGMP querier timeout is 120 seconds
IGMP max query response time is 10 seconds
Last member query count is 2
Last member query response interval is 1000 ms
Inbound IGMP access group is not set
IGMP activity: 7 joins, 0 leaves
Multicast routing is enabled on interface
Multicast TTL threshold is 0
Multicast designated router (DR) is 10.52.52.52 (this system)
IGMP querying router is 10.52.52.52 (this system)
No multicast groups joined by this system
IGMP snooping is globally enabled
IGMP snooping CGMP-AutoDetect is globally enabled
IGMP snooping is enabled on this interface
IGMP snooping fast-leave (for v2) is disabled and querier is disabled
IGMP snooping explicit-tracking is enabled
IGMP snooping last member query response interval is 1000 ms
IGMP snooping report-suppression is enabled

Anson-3750G-12#sh ip igmp interface
Vlan83 is up, line protocol is up
Internet address is 10.80.15.1/24
IGMP is enabled on interface
Current IGMP host version is 2
Current IGMP router version is 2
IGMP query interval is 60 seconds
IGMP configured query interval is 60 seconds
IGMP querier timeout is 120 seconds
IGMP configured querier timeout is 120 seconds
IGMP max query response time is 10 seconds
Last member query count is 2
Last member query response interval is 1000 ms
Inbound IGMP access group is not set
IGMP activity: 2 joins, 1 leaves
Multicast routing is enabled on interface
Multicast TTL threshold is 0
Multicast designated router (DR) is 10.80.15.1 (this system)
IGMP querying router is 10.80.15.1 (this system)
Multicast groups joined by this system (number of users):
224.0.1.40(1)

IP services support full routing protocols. So, it is just a matter of changing it to routed ports, advertise the subnet to EIGRP and test PIM neighbor connectivity.

HTH

Ended up I didn't have pim on the 3750 WAN interface. Working fine now.  Thanks for all your suggestions and assistance.

So if you are establishing EIGRP neighbors across the point to point multicast works in that regard.

You mistakenly sent me the outputs of "sh ip igmp int" and not "sh ip pim int" so if you could resend it may help.

Aside from the anomalies, it looks like it is set up correctly, so you may have a bug or something is just stuck. You could try:

1- Removing the ip pim from the 3750 VLAN354 interface and putting it back (easy and quick)

2- Reza's suggestion

3- Simply reload the switch.

Reza Sharifi
Hall of Fame
Hall of Fame

Looking at the output you posted, there is no PIM peering between the 6509 and the 3750.

Can you verify?

show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: