cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
168
Views
0
Helpful
1
Replies
Highlighted
Beginner

VPN L2

Dear,

I need to establish connectivity (Layer 2) between two routers: 10.154.4.69 and 10.154.4.71

the connection path would be like in the attached diagram:

-> Among the 2 routers in 2800 there is a GRE tunnel and an L2TP tunnel

-> The router 2900 (10.154.4.69) will get the router IP 3900 (10.154.4.71) and must pass through the Layer 2 VPN

Note 1: The GRE tunnel was built on an MPLS link

Note 2: from the Router 2800 udia ping ip 40.40.10.2 works (ping ip 2.2.2.2 too)

Note 3: from the Router 2800 BARUERI ping ip 40.40.10.1 works (ping ip 2.2.2.1 too)

The following configuration below and the diagram is attached.

--Router 2900 (UDIA - ENVIRONMENT CT-3)

interface GigabitEthernet0/2
ip address 10.154.4.69 255.255.255.192
duplex auto
speed auto
end

=================================================

--Router 2800


ip cef
ip domain name cedrofinances.com.br


interface FastEthernet0/1.200
encapsulation dot1Q 200
xconnect 2.2.2.2 102 encapsulation l2tpv3 manual pw-class cedro
l2tp id 2 1
end

interface Loopback1
ip address 2.2.2.1 255.255.255.252
end

interface Tunnel1
description TUNNEL UDIA <> DIVEO
ip address 40.40.10.1 255.255.255.252
tunnel source 192.168.33.1
tunnel destination 10.154.4.73
tunnel vrf vpnflex
end


l2tp-class cedro
hostname rtcedro-001
password 7 121A0C041104

pseudowire-class cedro
encapsulation l2tpv3
protocol none
ip local interface Loopback1

=================================================

--Router 2800


ip cef
ip domain name cedrofinances.com.br


interface FastEthernet0/0
no ip address
duplex auto
speed auto
no cdp enable
xconnect 2.2.2.1 102 encapsulation l2tpv3 manual pw-class cedro
l2tp id 1 2
end

interface Loopback1
ip address 2.2.2.2 255.255.255.252
end

interface Tunnel1
description TUNNEL DIVEO <> UDIA
ip address 40.40.10.2 255.255.255.252
tunnel source 10.154.4.73
tunnel destination 192.168.33.1
end

l2tp-class cedro
hostname CEDRO_AES_M
password 7 045802150C2E


pseudowire-class cedro
encapsulation l2tpv3
protocol none
ip local interface Loopback1

=================================================

--Router 3900 (BARUERI - ENVIRONMENT CT-2)

interface GigabitEthernet0/2
ip address 10.154.4.71 255.255.255.192
duplex auto
speed auto
end

1 REPLY 1
Highlighted
Beginner

Could anyone help me? I need much work it

Content for Community-Ad