03-17-2016 04:23 AM - edited 03-08-2019 05:00 AM
Hi all! Based on this configuration/topology i want to advertise the BGP route on the default route and vice versa. Can somebody help me?
Regards
Michele
Building configuration...
Current configuration : 2747 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname AS-SWCORE
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip vrf a
rd 1:1
route-target export 1:1
route-target import 1:1
route-target import 2:2
route-target import 3:3
!
ip vrf b
rd 2:2
route-target export 2:2
route-target import 2:2
route-target import 1:1
route-target import 3:3
!
ip vrf c
rd 3:3
route-target export 3:3
route-target import 3:3
route-target import 1:1
route-target import 2:2
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
switchport access vlan 2
!
interface FastEthernet1/1
switchport access vlan 3
!
interface FastEthernet1/2
switchport access vlan 4
!
interface FastEthernet1/3
switchport access vlan 5
switchport mode trunk
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
no ip address
!
interface Vlan2
ip vrf forwarding a
ip address 172.17.128.100 255.255.248.0
!
interface Vlan3
ip vrf forwarding b
ip address 172.17.4.100 255.255.252.0
!
interface Vlan4
ip vrf forwarding c
ip address 10.28.7.100 255.255.255.0
!
interface Vlan5
ip address 192.168.56.100 255.255.255.0
!
interface Vlan6
ip address 192.168.94.100 255.255.255.0
!
router bgp 1
bgp router-id 172.17.128.100
bgp log-neighbor-changes
no auto-summary
!
address-family ipv4 vrf c
redistribute connected
redistribute static
no synchronization
exit-address-family
!
address-family ipv4 vrf b
redistribute connected
redistribute static
no synchronization
exit-address-family
!
address-family ipv4 vrf a
redistribute connected
redistribute static
no synchronization
exit-address-family
!
no ip http server
no ip http secure-server
ip forward-protocol nd
ip route vrf a 0.0.0.0 0.0.0.0 172.17.4.43
ip route vrf a 172.17.128.0 255.255.248.0 Null0
ip route vrf b 172.17.4.0 255.255.252.0 Null0
ip route vrf c 10.28.7.0 255.255.255.0 Null0
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end
AS-SWCORE#
03-17-2016 06:33 AM
You have no BGP neighbours. Who do you want to advertise a default route to?
03-17-2016 06:42 AM
Hi, thanks for reply! If you see my topology i want to be able to reach a host that it was in vlan to a host in vlan (in vrf). From now i see:
AS-SWCORE#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.56.0/24 is directly connected, Vlan5
C 192.168.94.0/24 is directly connected, Vlan6
Now if the host that have a 192.168.56.1 want to contact a host in VRF it's not possible now.
I want to make it possible in both way!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide