cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
813
Views
10
Helpful
21
Replies

VTP won't update on one switch

Good morning. We are having trouble getting VTP to update on one switch. To date I have tried the following:

 

  1. Confirmed that the domain name was consistent.
    1. Even changed the name and changed it back
  2. Confirmed that VTP passwords are not the problem.
  3. Added a new VLAN to prompt an update, it updated other switches but not this one.
  4. Confirmed that the trunking is set up the same as other switches.
  5. Changed the VTP mode from client to transparent and back.

Slightly redacted information from the switches below:

 

From switch not receiving updates:

sho vtp sta
VTP Version capable : 1 to 3
VTP version running : 2
VTP Domain Name : ???
VTP Pruning Mode : Disabled
VTP Traps Generation : Enabled
Device ID : 
Configuration last modified by 

Feature VLAN:
--------------
VTP Operating Mode : Client
Maximum VLANs supported locally : 256
Number of existing VLANs : 67
Configuration Revision : 0
MD5 digest : 

 

sho int tru

Port Mode Encapsulation Status Native vlan
Gi1/0/1 on 802.1q trunking 1
Gi1/0/2 on 802.1q trunking 1
Gi1/0/34 on 802.1q trunking 1
Gi2/0/1 on 802.1q trunking 1
Gi2/0/2 on 802.1q trunking 1
Gi2/0/7 on 802.1q trunking 1
Po1 on 802.1q trunking 1

 

From a switch that is receiving updates:

sho vtp s
VTP Version capable : 1 to 3
VTP version running : 2
VTP Domain Name : xxx
VTP Pruning Mode : Disabled
VTP Traps Generation : Enabled
Device ID : 
Configuration last modified by 

Feature VLAN:
--------------
VTP Operating Mode : Client
Maximum VLANs supported locally : 1005
Number of existing VLANs : 70
Configuration Revision : 190
MD5 digest : 

 

sho int tru

Port Mode Encapsulation Status Native vlan
Gi1/0/40 on 802.1q trunking 1
Gi1/0/42 on 802.1q trunking 1
Gi1/0/43 on 802.1q trunking 1
Gi1/0/46 on 802.1q trunking 1
Gi2/0/43 on 802.1q trunking 1
Po1 on 802.1q trunking 1
Po30 on 802.1q trunking 1
Po40 on 802.1q trunking 1

 

Any suggestions appreciated!

 

Terry

1 ACCEPTED SOLUTION

Accepted Solutions
paul driver
VIP Expert

Hello

On the switch that isn't working delete the vtp database  then reload switch

Delete flash:vlan.dat

reload


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

View solution in original post

21 REPLIES 21
balaji.bandi
VIP Guru

Post the interface config VTP Service running on switch, also post the switch port config connected to that switch(which is not working)

 

is the VTP Server swiitch and not working switch connected directly ?

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

We have a number of switches and this is the only one not getting updates.

 

This is from the client switch not getting updates.

 

sho int p01
Port-channel1 is up, line protocol is up (connected)
Hardware is EtherChannel, address is 10f9.20f3.a631 (bia 10f9.20f3.a631)
Description: TO Switch 2
MTU 1500 bytes, BW 2000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, link type is auto, media type is unknown
input flow-control is off, output flow-control is unsupported
Members in this channel: Gi1/0/49 Gi2/0/49
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 62486
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 6445000 bits/sec, 963 packets/sec
5 minute output rate 14749000 bits/sec, 1702 packets/sec
356045309 packets input, 367394697 bytes, 0 no buffer
Received 3592250013 broadcasts (2506224767 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 2506224767 multicast, 0 pause input
0 input packets with dribble condition detected
1078720857 packets output, 1340564366 bytes, 0 underruns
0 output errors, 0 collisions, 2 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out

I am looking configuraiton not interface output

 

From both the switches :

 

show run interface port-channel 1

show ethchannel 1 summary

show run interace x/x (part of port-channel)

 

by the way interface has lot of drops (other issue you need to look that later)

 

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 62486

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

From non working switch:

Port-channel1
description TO SWITCH2
switchport trunk allowed vlan 1,101,102,107,108,111,300,301,404,515,800-802
switchport trunk allowed vlan add 807
switchport mode trunk
switchport nonegotiate

1 sum
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use N - not in use, no aggregation
f - failed to allocate aggregator

M - not in use, minimum links not met
m - not in use, port not aggregated due to minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port

A - formed by Auto LAG


Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) - Gi1/0/49(P) Gi2/0/49(P)

 

 

sho run int gi1/0/49
Building configuration...

Current configuration : 261 bytes
!
interface GigabitEthernet1/0/49
description TO SWITCH2 GI1/1/1
switchport trunk allowed vlan 1,101,102,107,108,111,300,301,404,515,800-802
switchport trunk allowed vlan add 807
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on

 

From Switch that works, and is directly upstream:

 

#show run interface port-channel 25
Building configuration...

Current configuration : 218 bytes
!
interface Port-channel25
description SWITCH1
switchport trunk allowed vlan 1,101,102,107,108,111,300,301,404,515,800-802
switchport trunk allowed vlan add 807
switchport mode trunk
switchport nonegotiate

 

show etherchannel 25 summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator

M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port

A - formed by Auto LAG


Number of channel-groups in use: 6
Number of aggregators: 6

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
25 Po25(SU) - Gi1/1/1(P) Gi2/1/1(P)

 

#sho run int gi1/1/1
Building configuration...

Current configuration : 292 bytes
!
interface GigabitEthernet1/1/1
description SWITCH1 GI1/0/49
switchport trunk allowed vlan 1,101,102,107,108,111,300,301,404,515,800-802
switchport trunk allowed vlan add 807
switchport mode trunk
switchport nonegotiate
channel-group 25 mode on
service-policy output QOSBYPASS
end

As i understand

 

your setup as below :

 

VTP Server Switch ----VTP Client Switch--VTP Client(switch this is not working ?)

 

or

 

VTP Server Switch -----VTP Client(switch this is not working ?)

 

Which one correct ?

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

More like:

 

VTP Server ---- VTP Client (working) ---- VTP Client (not working)

 

Can you post "sh vtp statistics" (or could be "sh vtp counters"). 

 

Jon

I have looked but cannot see a difference between this switch and anything upstream (or any that are working).

 

sho vtp sta
VTP Version capable : 1 to 3
VTP version running : 2
VTP Domain Name : ???
VTP Pruning Mode : Disabled
VTP Traps Generation : Enabled
Device ID : 
Configuration last modified by 

Feature VLAN:
--------------
VTP Operating Mode : Client
Maximum VLANs supported locally : 256
Number of existing VLANs : 67
Configuration Revision : 0
MD5 digest : 

 

That is a "sh vtp status". 

 

Is there a "sh vtp counters" available ? 

 

Jon

Oh! Apologies. I did look at this and compare to a known working switch and they look fundamentally the same.

 

sho vtp counter
VTP statistics:
Summary advertisements received : 97203
Subset advertisements received : 58232
Request advertisements received : 0
Summary advertisements transmitted : 302413
Subset advertisements transmitted : 36
Request advertisements transmitted : 58463
Number of config revision errors : 0
Number of config digest errors : 0
Number of V1 summary errors : 0


VTP pruning statistics:

Trunk Join Transmitted Join Received Summary advts received from
non-pruning-capable device
---------------- ---------------- ---------------- ---------------------------
Po1 0 0 0
Gi1/0/1 0 0 0
Gi1/0/2 0 0 0
Gi1/0/34 0 0 0
Gi2/0/1 0 0 0
Gi2/0/2 0 0 0
Gi2/0/7 0 0 0

 

No problem, just wanted to check the errors but as you say looks fine. 

 

Jon

I appreciate the look! I have been looking at this for days and can't see anything different from any other switch. Going to try a reload in our change window and see if that helps.

my next touch is  - show vtp password  (issue both the side)

 

Also, try configuring the domain name :

VTP Domain Name : ???

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Thank you for the quick reply and assistance. Turned out I needed to delete the vlan.dat (actually had to use Force) and reload the switch. 

 

On another note, thanks for noticing the output drops. I cleared the counters and there haven't been any more, but I will keep an eye on it.

 

Please keep providing great assistance like this and I hope you have a great day!

 

Terry