cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

2075
Views
0
Helpful
2
Replies
Highlighted
Beginner

WCCP issues when working with ASR 1002F

I am working with an ASR1002F and a WAE running ACNS.  My problem is that I cannot get all of the defined WCCP services to work on the ASR, the only service that is functioning is the web-cache service.  I am hoping someone here has had experience enabling WCCP on the ASR as I am almost at my wits end.

A few key notes:

- WCCP is hardware switched on the ASR eliminating support for Hash Assignment.

- I am currently using l2-redirect with mask-assignment, all wccp services indicate they are usuable w/ rediction using L2 and Packet retrun negotiated at GRE

WCCP Client information:
        WCCP Client ID:          10.x.x.5
        Protocol Version:        2.0
        State:                   Usable
        Redirection:             L2
        Packet Return:           GRE
        Packets Redirected:    0
        Connect Time:          04:15:04
        Assignment:            MASK

- I am not using the ip wccp redirect exclude in command on the WAE interface as instructed by TAC

- wccp web-cache service is working, packets that match the acl 148 are being redirected to the WAE without issue

- all other services 80-83 are not redirecting to the WAE, they are going through to the origin server

ASR1002F: asr1000rp1-ipbasek9.02.06.02.122-33.XNF2.bin

WAE674: ACNS 5.5.15

WAE:

wccp router-list 1 10.x.x.1
wccp web-cache router-list-num 1 l2-redirect mask-assign
wccp rtsp router-list-num 1 l2-redirect mask-assign
wccp wmt router-list-num 1 l2-redirect mask-assign
wccp wmt-rtspu router-list-num 1 l2-redirect mask-assign

Router:

access-list 148 remark WCCP acl

access-list 148 permit ip any 10.x.x.x 0.0.0.31
access-list 148 deny   ip any any

ip wccp web-cache redirect-list 148
ip wccp 80 redirect-list 148
ip wccp 81 redirect-list 148
ip wccp 82 redirect-list 148
ip wccp 83 redirect-list 148

interface GigabitEthernet0/0/1
description LAN
ip address 10.x.x.x 255.255.255.248
ip wccp web-cache redirect in
ip wccp 80 redirect in
ip wccp 81 redirect in
ip wccp 82 redirect in
ip wccp 83 redirect in
ip pim sparse-mode
ip ospf priority 5
negotiation auto

interface GigabitEthernet0/0/2
description ACNS/WAE network
ip address 10.x.x.x 255.255.255.240
ip pim sparse-mode
negotiation auto

asr1002-a#sh platform software wccp web-cache counters
Service Group (0, 0) counters
        Unassigned count = 0
        Dropped due to closed service count = 0
        Bypass count = 75052
        Bypass failed count = 0
        Denied count = 2169780642
        Redirect count = 1385074
  CE = 10.x.x.5, obj_id = 32, Redirect Packets = 117178       <------ I do not see this entry for the other services, any ideas why?
asr1002-a#sh platform software wccp 80 counters
Service Group (1, 80) counters
        Unassigned count = 0
        Dropped due to closed service count = 0
        Bypass count = 0
        Bypass failed count = 0
        Denied count = 0
        Redirect count = 0
asr1002-a#sh platform software wccp 81 counters
Service Group (1, 81) counters
        Unassigned count = 0
        Dropped due to closed service count = 0
        Bypass count = 0
        Bypass failed count = 0
        Denied count = 61816
        Redirect count = 0
asr1002-a#sh platform software wccp 82 counters
Service Group (1, 82) counters
        Unassigned count = 0
        Dropped due to closed service count = 0
        Bypass count = 0
        Bypass failed count = 0
        Denied count = 0
        Redirect count = 0

Everyone's tags (2)
2 REPLIES 2
Beginner

Re: WCCP issues when working with ASR 1002F

For anyone that comes across this thread I was able to solve this issue after an exhausting bout with TAC.

To get all of the WCCP services too function with the ASR I needed to issue the following commands.  I have never had to use these before in any implementation so I was very surprised that they resolved my issue.

ip wccp check services all

no ip wccp variable-timers

Now all is well Hope this helps someone

Beginner

WCCP issues when working with ASR 1002F

We have been trying to get this running for days now. This info in your post really helped. Thank you.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards