cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1936
Views
5
Helpful
39
Replies
Highlighted
Beginner

webui question

Working on configuring new C9300 switches.  In the getting started guide for configuration it indicates I can plug PC into any unmanaged network port on the switch and use the WEBUI site at 192.168.1.1 to configure the switch.  The PC must be configured for DHCP and it should get an IP from the switch.  

This is not working and looking to see if there is a service to start on the switch.  

I can connect to the switch console port and access the cli.  Limited CLI experience and would prefer the GUI to configure the switch.

2 ACCEPTED SOLUTIONS

Accepted Solutions
Participant

Re: webui question

It should be the S/N of the device, did you get the S/N from a sticker on the switch?

 

Did you try both upper case and lower case version of the letters? I am guessing it is case-sensitive. 

 

Optionally you could boot it up again and log in via CLI and issue the show inventory command to confirm the S/N is correct, then just run the write erase again and reboot. 

Beginner

Re: webui question

Serial number is correct but it turns out the user name is no longer webui but cisco.  Cisco TAC found the information not update for version 16.8.1

39 REPLIES 39
Participant

Re: webui question

Did you already access the CLI and say "No" to the initial configuration message?

 

It may have stopped the day 0 configuration and just left you with a blank config. 

 

Have you tried rebooting it and then connecting only to a network port with your computer? You may also have to log in to the switch via CLI and issue the "write erase" command and reboot it without saving the config to get it back to the day 0 prompt.

 

Otherwise have you tried giving your PC a static IP in the 192.168.1.x range and then try accessing the webUI?

 

 

Beginner

Re: webui question

Using the write erase option then rebooting the switch worked.  I can now open the Webui interface but cannot logon.  I'm using username webui and the serial number of the switch as the password but not able to logon.  

Anyone know what the default password is?

Beginner

Re: webui question

Hey Bobby, I'm having the same issue.  When you did a write erase did you save the config before reloading the switch?  Aslo, can you tell me which port you plugged into (I just tried port 1) on the switch and did it automatically assign you an ip or did you have to manually configure it on your nic card?  Thanks.

VIP Mentor

Re: webui question

the switch comes set as 192.168.1.1 by default , use any switchport try see if it pucks up DHCP , if not set your pc to 192,168.1.2 if the dhcp doesnt work and try and ping 192.168.1.1 , then try http to it
Beginner

Re: webui question

Hi Mark, I tried manually setting my IP to 192.168.1.100 but couldn't ping to 192.168.1.1 or https to it.  Any other ideas?  Thanks.

VIP Mentor

Re: webui question

Hi
did you wait 3 minutes for the DHCP ?
From the official guide to Webgui 9300 below

https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst9300/hardware/install/b_c9300_hig/b_c9300_hig_chapter_01000.html


Procedure
Step 1

Make sure that no devices are connected to the switch
Step 2

Connect one end of an ethernet cable to one of the uplink (non-management) ports on the active supervisor and the other end of the ethernet cable to the host (PC).
Step 3

Set up your PC as a DHCP client, to obtain the IP address of the switch automatically.

It may take up to three mins. You must complete the Day0 setup through the WebUI before using the device terminal.
Step 4

Launch a Web browser on the PC and enter the device IP address (https://192.168.1.1) in the address bar.
Beginner

Re: webui question

Hi Mark, I waited more than 3 minutes and still nothing.  I guess I'll try the write erase without saving the configuration (as someone else suggested) and then reload to see if it makes any difference and report back.  Thanks.

VIP Mentor

Re: webui question

ok if you do that you may wipe any of the config on it , is the switch currently blank , have you consoled in, take a look at the setup there may be something missing , post it here we can check

theres not much in setting up the webgui via console
Beginner

Re: webui question

Mark, it's a brand new switch out of the box so it has no config on it whatsoever.  It seems like it should be pretty straight forward but not sure why it's not.  Still working on it and will update you.  Thanks again for the quick replies.

VIP Mentor

Re: webui question

ok i wouldnt wipe it then , id console in and get the config post it here we can see if therEs something up with the DHCP setup
Beginner

Re: webui question

Yeah, still no joy.  After the write erase, it's back to the default "Would you like to enter the initial configuration dialog? [yes/no]".  I still don't get any IP and even when I manually enter an IP I can't ping 192.168.1.1 or access it via browser.  So should I enter "no" on the config dialog and then do a "show run" so I can copy the config here?  Thanks.

VIP Mentor

Re: webui question

you can but it may have now wiped any config off that was on it for http access , as it was erased , post it anyway , can always build the webgui from scratch in cli

an yes NO is what you pick
Beginner

Re: webui question

Hi Mark, so the switch finally assigned my pc an IP of 192.168.1.2 however when I try to connect via a browser to https://192.168.1.1 it gives me the following errors:

 

In Chrome
This site can't provide a secure connection

192.168.1.1 uses an unsupported protocol.

 

In IE

Can't connect securely to this page

This might be because the site uses outdated or unsafe TLS security settings....

 

Does this mean we have to "build the webgui from scratch in cli"?  If so, how would I go about doing so?  Thanks.

 

VIP Mentor

Re: webui question

no it prob doesnt like https which is secure http , try IE or firefox first
the try http://192.168.1.1
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards