Showing results for 
Search instead for 
Did you mean: 

what is the most effective way to get ospf to function and what is the basic command structure

I am doing a project of ospf and need to know if I am on the right tract somehow these commands are not working and wondering if I am doing something wrong.

Rising star

Which commands are not working? Basic OSPF is only a few commands to setup and I don't see why your commands would not work. Are you using real equipment or a simulator/emulator?

Daniel Dib
CCIE #37149

Daniel Dib
CCIE #37149
CCDE #20160011

Please rate helpful posts.

in my home i run cisco 800's which are new but they don't will not run ospf my other router which is a 2500 and accuiring a 2611 in a few days. my project is running from what I can sumise are 6 1700's connected to 2 2950 switches but that's just a guess.



I would say the basic configuration for OSPF should be:

1. router ospf  1

         2.   Router-id ( if you want to hardcode the router-id else you can go with the default which would be the highest interface on your router)

         3.  Network area 0 (telling the router * I care about the 192.168.0 part of my ip and the last part can be anything thus the 255)

    4.      Net area 0 (telling the router * I care about the 192.168.2 part of my ip and the last part can be anything thus the 255)

OR for the and you could just have meaning I only care about 192.168 and 0.0 can be anything.

The four lines above would be my basic config for ospf. Also have a look at these links, they provide some insight into ospf and how it should be configured.

I have also experienced that I cannot configure all OSPF commands on PT but prob GNS3 allow all configs.




I feel honored that I am not the only person on this planet, I find that ospf is not as easy as it looks and it does not work on all routers the way you would like, thanks this makes my day.



I'm pretty sure we can solve you problem within minutes but you have to tell us, what exactly doesn't work. You don't take your car to a garage and tell the mechanic that "something's not working" and expect him to fix it, do you?

You've already been told that you have to change the router-id on R2 or R3 because the RIDs have to be unique.

router ospf  1 dr

I guess, "dr" is just a description; IOS won't accept it when you copy and paste this line completely.

Very useful troubleshooting commands to begin with:

show ip ospf interface brief

show ip ospf neighbor

show ip ospf interface []

Link: Troubleshooting OSPF

If you tried to enable OSPF on your 800, there may be hardware limitations:



Content for Community-Ad