cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
252
Views
5
Helpful
7
Replies

why LLDP showing for subinterface

jigojar
Beginner
Beginner

Hi Team,

 We are finding that lldp neighbor entry is visible for the subinterface(vlan interface). how to avoid the lldp neighbor for the subinterface alone?

 

 

GE0/0/26 TN-RMD-RSM-T3-ST-SBE-... Gi0/0/0.198 104
GE0/0/26 TN-RMD-RSM-T3-ST-SBE-... Gi0/0/0.145 104
GE0/0/26 TN-RMD-RSM-T3-ST-SBE-... Gi0/0/0.719 104
GE0/0/26 TN-RMD-RSM-T3-ST-SBE-... Gi0/0/0.455 104
GE0/0/26 TN-RMD-RSM-T3-ST-SBE-... Gi0/0/0.626 104
GE0/0/26 TN-RMD-RSM-T3-ST-SBE-... Gi0/0/0.708 105
GE0/0/26 TN-RMD-RSM-T3-ST-SBE-... Gi0/0/0.722 105
GE0/0/26 TN-RMD-RSM-T3-ST-SBE-... Gi0/0/0.712 106
GE0/0/26 TN-RMD-RSM-T3-ST-SBE-... Gi0/0/0.267 106
GE0/0/26 TN-RMD-RSM-T3-ST-SBE-... Gi0/0/0.166 107
GE0/0/26 TN-RMD-RSM-T3-ST-SBE-... Gi0/0/0.158 107
GE0/0/26 TN-RMD-RSM-T3-ST-SBE-... Gi0/0/0.650 107
GE0/0/26 TN-RMD-RSM-T3-ST-SBE-... Gi0/0/0.610 107

7 Replies 7

Instead of config lldp in global mode config it under one subinterface, 

Or 

Disable the lldp on all subinterface except one.

jigojar
Beginner
Beginner

is it possible to enable the lldp only for the global interface. need solution to enable the lldp only on main interface. 

try same disble the LLDP under all sub interface and enable it under main interface

@MHM Cisco World Out of curiosity, since I did not get this to work: on what device and IOS is this working fro you ?

Hi @Georg Pauwen 
I ask him try myself not try it. 

is this can done in Main interface Yes it can, 
the CDP and I think same is LLDP using special behave for subinterface, 
the cisco Doc. mention that if the router does not have VLAN1 config and any of the subinterface is config w/wo native keyword the packet traverse over the main interface

for more detail please check this doc. 
https://www.cisco.com/c/en/us/support/docs/network-management/discovery-protocol-cdp/118736-technote-cdp-00.html


jkkjkjkjkj.png

paul driver
VIP Expert VIP Expert
VIP Expert

Hello
LLDP is enable globally, so you need to turn it off at an interface level


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Georg Pauwen
VIP Master VIP Master
VIP Master

Hello,

as far as I recall, you cannot disable LLDP on subinterfaces only. If you disable it on one subinterface, it will be disabled altogether, for all subinterfaces, as well as for the physical interface. I just tested this on a 16.x IOS, not sure what the behaviour is in higher versions...

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers