cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4104
Views
0
Helpful
6
Replies

BFCP issues with TelePresence endpoints and Expressway C/E

seanscott83
Level 1
Level 1

I'm in the process of setting up Expressway E & C at my company. Right now, we're only using using Expressway to make outbound SIP calls to BlueJeans. Here is the call flow:

User dials 62777 > Translation pattern on CUCM forwards to Expressway C SIP trunk > Expressway C performs a transform on 63888 to make an outbound SIP call to meet@sip.bjn.vc > Call from Expressway C is forwarded to Expressway E and the call is connected

My issue is with BFCP content. Right now calls from Jabber and Polycom HDX units work as expected when receiving content: the content is the main source no matter who is speaking. When a Cisco codec (I tried with:TX/CTS/SX/EX/DX) is in the call and content should be received, BlueJeans shows the notification that content is being sent but the codec acts like nothing is coming through (once in a while you'll see content for a few milliseconds and it will disappear). The video window containing the video participants that would normally be sent to the corner while content is displayed, is shown full screen.

If one of these Cisco endpoints sends content, it's sent in the regular video channel, so, as expected, other endpoints don't know they're receiving content. This means when a non-presenter speaks and the active presence switching happens, the content window is sent to the bottom.

Any ideas what could be happening here? I assume I'm just missing a check box somewhere on my CUCM trunk configuration.

(I am using the pre-configured "Standard SIP Profile for Cisco VCS," but I was wondering if I should edit the profile to check, "Early Offer support for voice and video calls (insert MTP if needed)")

Thanks,

Sean

 

6 Replies 6

Hi Sean,

What is the current version of your CUCM, VCSc, VCSe?

Is there a MCU involved during the call?

Where is your Cisco endpoint registered, CUCM or VCS?

Verify on your CUCM the SIP profile for your VCS if "Allow Presentation Sharing using BFCP" is enabled.

Also are the calls encrypted? Try to disable encryption on your endpoint.

 

regards,

Ace

Ace, thanks for the follow up. See responses below:

What is the current version of your CUCM, VCSc, VCSe?

CUCM: 9.1.2.12901-3

EXPc: X8.5.2

EXPe: X8.5.2

Is there a MCU involved during the call?

No

Where is your Cisco endpoint registered, CUCM or VCS?

All endpoints are registered to CUCM

Verify on your CUCM the SIP profile for your VCS if "Allow Presentation Sharing using BFCP" is enabled.

I'm using the built-in to CUCM, pre-configured, "Standard SIP Profile for Cisco VCS," which by default has the Allow Presentation Sharing using BFCP setting enabled

Also are the calls encrypted? Try to disable encryption on your endpoint.

The calls are not encrypted

 

Thanks,

Sean

Hi Sean,

 

How is your VCS neighbor zone configured with CUCM? 

In the VCS did you modify the Advanced Zone Profile from CUCM to Custom and modify the parameters?

This may help:

http://www.cisco.com/c/en/us/td/docs/telepresence/cucm_cts/cucm_cts_admin_book/guide/cucm_cts_admin/cucm_cts_admin_midletsfeat.html#pgfId-1100172

 see "Configuring the BFCP over UDP Collaboration Feature"

 

regards,

Ace

It definitely seems like a neighbor zone issue. I went back and double checked the setup document and changed the zone to "Custom" as configured as described. Basically changing the, "call signaling routed mode" from auto to always made the difference.

Now all of my endpoints (Cisco/Polycom) will send content in the separate channel, but most still don't honor the receive content. Now even the Polycoms are flaky in that regard. The only connection that works every time is Jabber.

Thanks again for helping get this far. I have a TAC open and they haven't been helpful at all.

-Sean

Hi Sean,

 

That's good news for having some progress in resolving your issue and you're very much welcome. I hope TAC support will resolve your issue. 

 

regards,

Ace

 

Sean,

Did you ever solve this issue?

Thanks,

Justin

Thanks,
Justin Ferello