Showing results for 
Search instead for 
Did you mean: 

C20 Camera Issue - Remote controls camera while navigating menus, no camera detected on codec.

Craig Upton
Level 1
Level 1

Hello everyone,

We've installed two C20 systems with stock camera and cables.

Camera image comes up, and camera control works however when you're navigating the C20 menus (up down left right) the camera moves.

They are both using TC6.1.1 software, I have upgraded one of the two units to TC6.2.0 - the same symptoms happening.

The xstatus for the camera is ;

*s Camera 1 Connected: False

*s Camera 1 HardwareID: ""

*s Camera 1 Manufacturer: ""

*s Camera 1 Model: ""

*s Camera 1 SoftwareID: ""

*s Camera 1 SerialNumber: ""

*s Camera 1 IpAddress: ""

*s Camera 1 MacAddress: ""

*s Camera 1 Position Pan: 0

*s Camera 1 Position Tilt: 0

*s Camera 1 Position Zoom: 16

*s Camera 1 Position Focus: 4000

*s Camera 1 Capabilities Options: ""

*s Camera 1 Flip: "Off"

Does this mean I have to do a Serial Recovery on each camera?  Or is there something else I should try?

I am not sure as the symptoms are different to what I have experienced.

Thanks, Craig

9 Replies 9

Chad Patterson
Cisco Employee
Cisco Employee

Hey Craig,

I have seen this before and the last time this happened the user realized that the camera was actually connected to the wrong port. However since you stated you are using a C20 there is only 1 port available for the camera control cable. Are you actually using a C20?

You could try to run the camera rescue from the admin shell of the codec. I do not think that this is present in TC6.1.1 software, so you may need to try this on the TC6.2 or upgrade to TC6.2.1 which was just released. To run the camera rescue you need to ssh into the C20 as admin. Once you have logged in issue the following command:

>systemtools camerarescue

This will run a script that will check for an active camera connection and then run a recovery script on the camera and reboot the codec. Do this and then check the xstatus to see if the camera is now showing up as connected to the codec.

Yes they are definately C20 codecs.

I'm going back to the city these systems are installed in soon. Unfortunately this job is not local!

I noticed in TC6.2.1 the camera rescue was put back in so I will try that on site.

Thanks, Craig

Hi Craig ,

What camera is installed 4x or 12x, C 20 can support both cameras .

If you are using 12x camera then troubleshooting would be diffrent . 12 x camera is having in built IR and can move wit out connectivity of coec . problem you are facing is same .

+ Swap camera cable with known working one this should fix issue ( Cable is providing power to camera but issue with control ).


Kind regards,


Hello Dharmesh,

Supplied with 4x cameras (CTS-PHD1080P4XS1)

With either camera connected it should be showing up in the xstatus?

I will double check when I return back to site.

Thanks for your input, Craig

Craig Upton
Level 1
Level 1

Guys, I am on site now and can confirm these cameras are the 4x models. I have tried replacement camera control cables and powering the camera on it's on CAM PSU.

Appears the C20 is not recognising the camera, the C20 built in IR controls everything but the camera. When I point the IR from the remote at the camera is controls itself and not the C20 (stand alone - even not connected on a PSU)

I have tried the systemtools camerarescue with no change.

This is happening on two systems.

Any more ideas or things I should be trying?

HI Craig,

please make sure you are not using both external power supply as well camera control cable to power camera.

remove external power supply from camera if connected and only use camera control cable ( RJ45-DB9) to connect camera to codec.

try and let me us know.

Camera not being recognised by the system still. 

We have recieved on site a total of four C20 systems with 4x Cameras now and they're all doing the same thing. 

I am raising a TAC case today to resolve this. I will let you all know the results.

Thanks, Craig

I actually had one where the camera controles worked but there was no picture. Factory reset of the codec took care of the problem.

Sent from Cisco Technical Support iPad App

Craig Upton
Level 1
Level 1

Cisco TAC have replaced the cameras and the systems are working now.

Unknown what is wrong with the cameras but hopefully they'll let me know.

Thanks for everyones input and attempts to help.