cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1329
Views
0
Helpful
4
Replies

Can port speed on E20 be manually set?

Andrew Vasel
Level 1
Level 1

I have an E20 (TE4.0.0.246968) with noticeable video quality issues. I have the port set to 100 full duplex, however both TMS and CLI from the E20 itself report back that the unit is at half duplex. Is there a way to change this on the E20?

I can see that 'xstatus network 1 ethernet speed: 100half'   ...

but there is no 'xconfiguration network 1 ethernet speed: 100full' command

Thoughts?

1 Accepted Solution

Accepted Solutions

Martin Koch
VIP Alumni
VIP Alumni

Hi!

Good question, I would say it might not be possible for a user/admin.

Did you try to connect the e20 to a switch with enabled autonegotiation/configure your switch to 100/auto instead of a static setting? This is what I would prefer.

An other attempt can be to set the switchport to 100/half, then both sides should use 100/half,

even if you see collisions, if you only use the e20 on the port without other traffic it shall be ok.

What kind of switch do you connect it to? Maybe enabling/disabling CDP on the E20/switch

cuases a different behavior.

The admin guide also show not much besides some text in the apendix: (page 31)

http://www.cisco.com/en/US/docs/telepresence/endpoint/ip-video-phone-e20/te4/administration_guide/cisco_ip_video_phone_e20_administrator_guide_te40.pdf

To debug a bit more if its really the duplex setting which add the noticeable video problems you could

also look at the error counters of the switch port. If you login as root to the e20 you can do an: ifconfig eth0

but I am not 100% sure if you would see errors there as I could picture this interface is behind the internal

switch, I see something in the sys file system (/sys/class/ext_switch/) but thats not really self explaining, ...

Please remember to rate helpful responses and identify

View solution in original post

4 Replies 4

Martin Koch
VIP Alumni
VIP Alumni

Hi!

Good question, I would say it might not be possible for a user/admin.

Did you try to connect the e20 to a switch with enabled autonegotiation/configure your switch to 100/auto instead of a static setting? This is what I would prefer.

An other attempt can be to set the switchport to 100/half, then both sides should use 100/half,

even if you see collisions, if you only use the e20 on the port without other traffic it shall be ok.

What kind of switch do you connect it to? Maybe enabling/disabling CDP on the E20/switch

cuases a different behavior.

The admin guide also show not much besides some text in the apendix: (page 31)

http://www.cisco.com/en/US/docs/telepresence/endpoint/ip-video-phone-e20/te4/administration_guide/cisco_ip_video_phone_e20_administrator_guide_te40.pdf

To debug a bit more if its really the duplex setting which add the noticeable video problems you could

also look at the error counters of the switch port. If you login as root to the e20 you can do an: ifconfig eth0

but I am not 100% sure if you would see errors there as I could picture this interface is behind the internal

switch, I see something in the sys file system (/sys/class/ext_switch/) but thats not really self explaining, ...

Please remember to rate helpful responses and identify

Hi Martin,

That is what I am going to try first - changing the port to auto negotiate instead of a hard set value. I'll let you know the result.

Hi Martin,

I have now tested with 2 E20's, and both that were set to auto auto-negotiated to 1000full so it appears that worked - I marked your response as the correct answer.

Hi Andrew!

Great to hear and thank you for the points.

Have a great weekend!

Martin

Please remember to rate helpful responses and identify