Showing results for 
Search instead for 
Did you mean: 

xCommand UserInterface Extensions Panel command problem



I am having issues with a Webex Codec Pro, it's to do with the touch panel, and the ability to remove and save ( restore? ) a panel. In this case, the panel is called "panel-tech".

The command xCommand UserInterface Extensions Panel Remove PanelId: "panel-tech" works perfectly well and removes the requested panel, however the command xCommand UserInterface Extensions Panel Save PanelId: "panel-tech" does not restore the panel it kills the serial connection in strange way; the serial port continues but just echoes back the command sent ( if echo is on ), so where I would send my keep-alive message "xStatus SystemUnit ProductId" and get back the name etc all I get back is the command if echo is on or nothing if echo is off.

The software versions is ce 9.9.0 46f7ea38fda 2019-10-10. Is this an issue that has been resolved in later software versions?




7 Replies 7

Bobby McGonigle

Hello @MJW041156 


The xCommand UserInterface Extensions Panel Save expects a multiline command to follow it, which needs to include the XML for your Panel.


You can get the XML of the panel you designed by following these steps

  • Log into the Room Device as Admin or Integrator
  • Navigate to UI Extensions Editor
  • Select the current panel you want the XML for
    • Or create a panel at this time
  • Select the Editor Menu, three dash button , in the top right hand corner of the editor
  • Select "Export Current Panel to File"

This will give you the XML for your panel.


Using the Macro Editor, you can now load in your panel with the following notation. just be sure to update your Panel ID and your XML


    PanelId: 'panel_1'
}, `<Extensions>
    <Name>Test Panel</Name>
      <Name>My Test Page</Name>
        <Name>Row Name</Name>
          <WidgetId>Text button</WidgetId>


Your can even take the of this a step further and create more Dynamic Layouts using this command.

Check out this TicTacToe example I contributed to the Cisco Devnet repo


Bobby McGonigle
(He, Him, His, Himself)
Video Services Engineer, EU Svcs Communication & Collaboration Services


Thanks for the reply. My issue is I only have a serial connection; are you saying I can save the whole thing as a macro within the codec, and call the macro from a serial command?

I've just found the command for running the macro  -  "xCommand Macros Macro Activate" so the answer is yes, so all I need to do now is load the macro(s) and test it. I'll post back when I've tried it. Thanks for the clue.

Yes... that works. Had to strip all unnecessary eol and spaces before pasting in the xml, but it works. Thanks very much for the tip.

I have an issue with the xCommand calls, hopefully you can help. If I run the macros from the WebUI then the TC10 layout changes, all good. If I call the macro from xCommand then although the WebUI shows the macros as running, the TC10 layout does not change, any ideas?

Would advise you to post your question in your own post as it’s off topic to the OP.

Response Signature

I AM  the original OP.

Oh my bad, sorry.

Response Signature

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers