cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1129
Views
0
Helpful
9
Replies

Call Recording issue

mightyking
Frequent Contributor
Frequent Contributor

Hi There,
We have CUCM 8.6 and Verint Call Recording 10. We use CUCM silent monitoring through the BIB (Built-In Bridge). What I understand is that the monitoring party should automatically placed on hold when the agent places the customer on hold and the monitoring session automatically resumes when the agent resumes the call. I believe when the agent places the customer on hold, recording calls are torn down. When the call is resumed, two new recording calls are established. Is this assumtion valid?
 

Our issue is that the recording stops as soon as the agent retrievs the call from hold. Anybody got into a similar situation. Any solution/recommandation would be greately appreciated.

Thanks,

MK
 

 

9 Replies 9

Manish Gogna
Cisco Employee
Cisco Employee

Hi MK,

Recording Calls Do Not Survive Agent Hold

Recording calls get torn down when the agent puts the call on hold, and they get reestablished when the agent resumes the call.

The Start Recording Request from an application persists throughout the call.

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/admin/8_5_1/ccmfeat/fsgd-851-cm/fsmr.html#wp1058289

HTH

Manish

 

HI Manish,

Thank you for replying.

What you're saying is exactly what my understanding is and this is what I wrote in my description when I posted this question. Would you happen to have a solution for why the recording doesn't pick up when the agent resumes the call?

 

Thanks,

 

MK

mightyking
Frequent Contributor
Frequent Contributor

Anybody with any idea?

 

Thanks,

 

MK

Hi MK,

Yes, in a normal scenario recording should resume after hold/resume. There were a couple of bugs related to call recording on cucm 8.6 version, one of them is given below

https://tools.cisco.com/bugsearch/bug/CSCug24286

Symptom:
Intermittently calls are not being recorded from BiB.

Conditions:
An active call to an agent will go on hold even before recording call start ( with a CTI application initiating the hold immediately after the media cut thru; it is hard to hit this issue via manual hold). However, upon resume of the call; we would expect recording to start automatically; however it does not. It is a race condition between the hold and the recording.The fix is to handle this race condition and let the recording resume upon the call resume.

Workaround:
Delay the hold from the application for a few milliseconds to let the recording start before going on hold.

 

 

Although it is not the exact match as yours but you can check if your cucm 8.6.2 is running one of the fixed or higher versions listed in it.

HTH

Manish

 

Hi Manish,

Thank you for taking the time and replying.

I don`t understand the workaround. Could you please explain how to "Delay the hold from the application for a few milliseconds "?

Our current version is 8.6.2.22900-9

Soon, we are upgrading to 9.1.2SU2a, would the bug be fixed in that version?

 

Thanks,

 

MK

Hi MK,

In your case the hold / resume is manual, so the above workaround can not be tried. I would need to check how it is applied though. This bug applies to 8.x version so an upgrade to 9.x version will take care of the same.

HTH

Manish

Our upgrade is scheduled in  6 months. We can't wait until the upgrade resolves the issue. What would you need to be able to check how it applies? Please let me know.

 

Thanks,

 

MK

mightyking
Frequent Contributor
Frequent Contributor

Anybody with any ideas for this issue?

 

Thanks,

 

MK

Hello @mightyking 

How did you solve this problem (if you solved before the upgrade)?

 

Thanks!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: