Showing results for 
Search instead for 
Did you mean: 

Cisco Phone Control and Presence with IBM Lotus Notes 8.5.2 (Integrated Sametime Client 8.0.2) - No presence status visible

Igor Lukic

Hi community,

I am trying to integrate Cisco Unified Presence with IBM Lotus Notes 8.5.2 with the integrated Sametime Client version 8.0.2 via the Cisco Plugins

Phone control is working fine, whereas the presence status is not shown (= no handset symbol next to the Sametime user). When I look in the preferences of the plugin, I can see that the plugin has connected successfully to the CUCM (,whereas the connection to the CUPS has not been established.

The user id as well as the password are all the same on all systems. Here is a description of what I have configured via the ciscocfg.exe tool:

Feature Control:

- Enable Phone Status -> checked

- Enable Dial Using Cisco IP Communicator -> unchecked (not required)

- Enable Control Desk Phone -> checked

- Default Mode -> Control Desk Phone

Control Desk Phone Settings:

- Voicemail Pilot Number -> left blank (no voicemail)

- Cisco Unified Communications Manager

     - Servers -> IP address of CUCM

     - Read Only -> unchecked

     - Use as Default CUCM -> checked

     - Synchronize Credentials -> checked

          - Use Sametime Credentials -> checked

Use Secure Connection: -> not required

LDAP Phone Attributes: -> not required

Phone Status Settings:

- Cisco Unified Presence Servers -> IP address of CUPS

- Read Only -> unchecked

- Synchronize Credentials -> checked

     - Use Sametime Credentials -> checked

- Sametime User ID Mapping

     - Use Business Card Attribute -> MailAddress

     - Remove Domain -> checked

- Display Off-Hook Status Only -> unchecked

At the moment I don't see an error in the configuration, but maybe I am wrong. Could anyone please tell me what the error could be?

Thanks a lot in advance!

Kind regards,


7 Replies 7

Igor Lukic

Hi all,

here are some additions to my above post:

Servers and clients used:



1x IBM Lotus Domino Messaging Express Server 8.5.2

1x Sametime Entry Server 8.5.2 (on top of the Domino server)

2x IBM Lotus Notes 8.5.2 with integrated Sametime 8.0.2

2x Cisco Phone Control and Presence with Lotus Sametime (PCAP)

2x Cisco Unified Personal Communicator


- CUCM, CUPS and CUPC are working fine, i.e. Desk Phone control via CUPC, as well as availability and presence status are working without issues

- IBM Lotus Domino server is the LDAP Directory, the Sametime Entry Server is installed on top of the Domino server and uses the Domino Directory

- User ID and password on CUCM/CUPS match the ShortName field and password in Domino

- The PCAP plug-in has been manually deployed to both Notes clients with the following configuration:

     - Enable Phone Status -> active

     - Desk Phone Control -> active

     - no credential synchronization for CUCM and CUPS, i.e. every user must fill the user details himself

     - Sametime User ID Mapping is implemented via the LDAP Attribute uid (which is equal to the user id in CUCM)

     - LDAP configuration filled in with details of the Domino server

Phone Control is working fine, also the connection to the LDAP server (Domino) is fine. However, when I type in the credentials for the CUPS server login, I can see (in Troubleshooting pane) that the user (pparker) is connected to the CUPS server for a short period of time and then gets disconnected. After that no connection is possible to the CUPS server, i.e. status is always disconnected.

I have collected the Tomcat (EPASSoap00010.log and security00010.log) logs via RTMT and compared them to the logs from the PCAP plugin. The relevant time period is from 15:14 to 15:17. In the Tomcat logs I can see that the authentication is successful (see attached files), however in the log of PCAP plugin I can see the following messages:

2012/02/03 15:14:35.281 WARNUNG Credential is rejected. Nothing to retry ::thread=CT_CALLBACK.1

2012/02/03 15:14:35.281 WARNUNG #### Connection rejected presence server ::thread=CT_CALLBACK.1

2012/02/03 15:14:35.281 WARNUNG Credential is rejected. Nothing to retry ::thread=CT_CALLBACK.2

2012/02/03 15:14:35.281 WARNUNG #### Connection rejected presence server ::thread=CT_CALLBACK.2

I don't understand why the connection is rejected although the Sametime Internal ID and CUPS User ID match. Does anyone know what the issue could be?

All posts are very much appreciated!

Thanks a lot in advance!

Kind regards,


Are you able to see phone presence from CUPC (for testing purpose)?


Hi Michael,

thanks for your reply!

Yes, I have successfully deployed the CUPC. Phone presence, as well as desk phone control are working fine. I am assuming that the mapping between Sametime and CUPS isn't somehow working correctly. I've followed all steps in your book, but still no success.


Hi Igor,

Sounds like your assumption is correct, the user ID mapping is incorrect.

Presence status is not known and the phone icon is missing because the credentials in Sametime and CUP user is not matching. When it matches, you get the phone icon.

To test this, what you can do is populate a free business card attribute. eg. "Company" with the userid used in CUPS for that user. Then from the Cisco Configuration tool, configure "Company" in the field "Use Business Card Attribute". When the userid is matching, then the phone icon will appear showing presence status.

Hung To

Hi Igor,

Does the userid or password contain any special characters? if yes, would suggest you to use a simple password. And does the presence-login section on the server settings under preferences tab show as "login failed" or " disconnected"? The current pwd or userid might work with CUPC fine. However let's try with a different one for sametime.

Sent from Cisco Technical Support iPad App

Hi altogether,

thanks a lot for helping me!

Currently I am working on another project, so at the moment I won't be able to try the above suggestions. As soon as I am back on this project, I will let you hear from me.


I have already tried that, however not with the 'Company' attribute, but with 'InternetAddress', where the user part of the e-mail address is the same as the CUPS user id. Unfortunetly I get the same result, i.e. I get a quick connect and then the user is disconnected.

@Gangabhavani Sankar Voleti:

The user id does not contain any special characters. It consists out of letters and numbers (eight digits in total). When I start Lotus Notes with the integrated Sametime plugin, I can see that the user is connected for short period of time and then gets disconnected. After that "disconnected" is being displayed all the time.

Is there a possibility that the Sametime Entry Server is not supported by the PCAP plugin?

Thanks for all helpful posts in advance!

HI Igor,

I encountered the same issues as well were my CUPS is disconneting after a few second. Infact our issues are almost the same, its just that im running in CUPS in version 8.5.1. Phone status doesnt shows on the Sametime user contact.

To fix the disconnecting issue,  I just create Incoming and Outgoing ACL to accept all Adress Pattern to ALL and it will by pass the Digest Authentication Credential per user account in CUCM.  Be default Incoming  and outgoing request are Deny.

As of now, I'm  still stuck on Displaying the  Phone status/availability per user in Sametine. Still no luck to  make this work. Hope this is helpful to you. Thanks