cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
458
Views
0
Helpful
2
Replies

CUCM 8.6 to 12.5 config only

lonmc1977
Level 1
Level 1

Hey, hoping someone can in-confuse us on how to upgrade an 8.6 VM setup to a 12.5 VM setup. Our 8.6 CM is running in production at the moment, the 12.5 install in brand new. Both on the same network, each as publishers. I'm simply just trying to transfer the 8.6 configuration to 12.5.

1. I'm trying to do this via migration on Prime, my stopping point is when its asking for an ISO. I don't know why an ISO image would be involved if its just a configuration transfer, I don't need to install 12.5, it already is.

2. I've tried importing/exporting the config via bulk administration import/export. No matter how I try it on the new 12.5 server, it sits in pending forever. I've tried importing the entire TAR file or just specific CSV files. I've even left it overnight, still stuck. From what I've read this isn't the best idea anyway do to the version mismatches etc.

Not sure it matters either but the licenses have yet to be installed, we're going back and forth with Cisco on that.

Whats the best way?

2 Replies 2

Jaime Valencia
Cisco Employee
Cisco Employee

1. I'm trying to do this via migration on Prime, my stopping point is when its asking for an ISO. I don't know why an ISO image would be involved if its just a configuration transfer, I don't need to install 12.5, it already is.

Because that's NOT how it works, a PCD migration will perform the WHOLE install, it doesn't work just by extracting the data and then pushing it into an already installed CUCM. If you want to use PCD migration, you need the bootable for 12.5 and let PCD do the whole procedure. No way around that.

2. I've tried importing/exporting the config via bulk administration import/export. No matter how I try it on the new 12.5 server, it sits in pending forever. I've tried importing the entire TAR file or just specific CSV files. I've even left it overnight, still stuck. From what I've read this isn't the best idea anyway do to the version mismatches etc.

BAT, pretty much as DRS, only works on the EXACT same release from which it was taken (might work across SUs if no settings are added/removed/modified). There are plenty of new things on 12.5 your 8.6 file doesn't have, if you want to do that, you will have to get a 12.5 export to look at, and then manually adjust your 8.6 files to match. Even if this is an option, almost no one uses it due to the manual labor involved, and is only used when you are exporting/importing in the same release.

 

Either option works, but you need to use them properly so they do the job. Licenses would be a problem if you go past the 90 days limit for BAT as MACDs are locked after that time. PCD would do a fresh install and the counter would reset on it.

 

I suggest you sort out your smart account/virtual account problems before that, then licensing should be able to assist in migrating the licenses (assuming a valid support contract is there, or your SE/Partner would tell you what to buy)

HTH

java

if this helps, please rate

Thanks, so its probably just easier to manually set it up at this point.  Our user base isn't very large anyway.