cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
699
Views
0
Helpful
3
Replies

Jabber for Windows LDAP problems

eemge
Beginner
Beginner

I have been modifying the jabber-config.xml file to get the results I need without a lot of success.

  1. Our Business phone number is derived from the ipPhone field
  2. We have many disabled users that continue to show up in searches
  3. Even though I have confirmed that users have their phone number in AD, only 50 persent of users in Jabber show the number

This is what I have thus far:

    <BusinessPhone>ipPhone</BusinessPhone>

    <CommonName>cn</CommonName>

    <DisplayName>displayName</DisplayName>

    <FirstName>givenName</FirstName>

    <LastName>sn</LastName>

    <EmailAddress>mail</EmailAddress>

    <Title>title</Title>

    <UserAccountName>sAMAccountName</UserAccountName>

    <DomainName>userPrincipalName</DomainName>

    <Location>co</Location>

    <State>st</State>

    <StreetAddress>streetAddress</StreetAddress>

    <BaseFilter>(&(ipPhone=*)(userAccountControl:1.2.840.113556.1.4.803:=2))</BaseFilter>

    <PredictiveSearchFilter>anr=</PredictiveSearchFilter>

    <DisableSecondaryNumberLookups>1</DisableSecondaryNumberLookups>

This is not the entire Directory section as I have removed server info. I tried several different Base Filters with really no luck.

Also, in the documentation it shows that I need to add "amp;"after the "&" but this does not work. I don't see any user information. If I remove the trailing ")" Same thing.

Thanks.

3 Replies 3

Tommer Catlin
Advocate
Advocate

Yes, I have used it. It does not help you with the problems I have above with disabled users showing up and some users not showing a phone number when the ipPhone field is populated.

Hi eemge,

the following line contains wrong statements:

(&(ipPhone=*)(userAccountControl:1.2.840.113556.1.4.803:=2))

from my point of view it should be:

(&(ipPhone=*)(userAccountControl:1.2.840.113556.1.4.803:=2)

There is no way to use & (as and) or | (as or) as a statement caused by incompatibility to the UTF-8 Standard.

For & you have to use &

and for | it´s |

Another trap is the last bracket that you have to leave out.

I hope it will work for you.

Stefan

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers