cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4797
Views
0
Helpful
14
Replies

Unable to get phones registered in CUCM

aaron-saz
Level 1
Level 1

I’m running CUCM 10.5 in my lab and I have 3 phones I’m testing with 7960, 7940, also tried 9971. Neither of the 3 register (registered: unknown) in call manager, but I can change line numbers and display settings in CUCM, and see the updates on each of the phones.


On both the 7900's I can pick up the hand set and initially get a dial-tone, but when the phrase “your current options” flashes (constant flashing across bottom of display panel) the dial tone stops, it’s like the phone is being reset. The 9971 just says Unregistered..

I have a couple IP communicator phones that both register, and can call each other…

SIP trunk in CUCM shows as active and functional. Parts of the VG and SW config that relate to the VoIP are listed below.

- VG: 2801

c2801-ipvoice_ivs-mz.150-1.M10.bin

- Switch: 3750

c3750-ipservicesk9-mz.122-25.SEC2.bin

I have another thread at the below link..

https://supportforums.cisco.com/discussion/13094851/cisco-ios-feature-set-question

Any advice would be greatly appreciated.

ip dhcp excluded-address 192.168.10.1 192.168.10.30
ip dhcp excluded-address 192.168.20.1 192.168.20.30
!
ip dhcp pool data
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
!
ip dhcp pool voice
network 192.168.20.0 255.255.255.0
default-router 192.168.20.1
option 150 ip 192.168.10.5
.
. ! - Ommited config
.
voice service voip
ip address trusted list
ipv4 192.168.10.0 255.255.255.0
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
signaling forward unconditional
h323
sip
min-se 5000 session-expires 5000
header-passing
registrar server expires max 600 min 60
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8
codec preference 3 g729br8
!
!
voice iec syslog
voice register global
!
.
. ! - Ommited config
.
sccp local FastEthernet0/1.10
sccp ccm 192.168.10.5 identifier 1 version 7.0
sccp ip precedence 3
!
sccp ccm group 1
associate ccm 1 priority 1
associate profile 40 register lnbch-mtp12
associate profile 30 register lnbch-mtp11
associate profile 10 register lnbch-conf1
associate profile 20 register lnbch-tc1
keepalive retries 5
switchover method immediate
switchback method immediate
switchback interval 15
!
dspfarm profile 40 mtp
codec g711ulaw
codec pass-through
maximum sessions software 50
associate application SCCP
shutdown
!
dial-peer voice 1 voip
session protocol sipv2
session transport tcp
incoming called-number .
voice-class codec 1
dtmf-relay rtp-nte
no vad
!
dial-peer voice 2 pots
trunkgroup PRI-GRP !-this config was copied for a starting point, just saw this. Is it correct
! - I do not have a trunkgroup identified in this config
description incoming pots
incoming called-number .
direct-inward-dial
!
dial-peer voice 1001 voip
description DID
preference 1
destination-pattern 10..
session protocol sipv2
session target ipv4:192.168.10.5
session transport tcp
voice-class codec 1
dtmf-relay rtp-nte
no vad
!
!
sip-ua
no remote-party-id
retry invite 10
registrar ipv4:192.168.10.5:5060 expires 3600

--------

SW# show int trunk

Port Mode Encapsulation Status Native vlan
Fa1/0/1 on 802.1q trunking 1

SW#show cdp neighbors

Device ID Local Intrfce Holdtme Capability Platform Port ID
VG Fas 1/0/1 156 R S I 2801 Fas 0/1.1
SIP001956242D63 Fas 1/0/31 143 H P IP Phone 7Port 1
SIP0019AA949035 Fas 1/0/25 131 H P IP Phone 7Port 1

SW#show run int fa1/0/25
Building configuration...
Current configuration : 137 bytes
!

interface FastEthernet1/0/25
switchport access vlan 10
switchport mode access
switchport voice vlan 20
spanning-tree portfast
end

SW#show run int fa1/0/31
Building configuration...
Current configuration : 137 bytes
!

interface FastEthernet1/0/31
switchport access vlan 10
switchport mode access
switchport voice vlan 20
spanning-tree portfast
end

SW#




1 Accepted Solution

Accepted Solutions

Hi Aaron,

Are you running Call Manager Cluster With PUB and SUB in the Lab setup ?

Regards

Inderpsi

View solution in original post

14 Replies 14

Nadeem Ahmed
Cisco Employee
Cisco Employee

What is the Firmware running on these phones ? did you check the compatibility matrix with CUCM 10.5.

Also can you please take a packet capture by spanning a switch port for one of the phone hooked up on switch or enable the PC port on phone and connect laptop or PC back to phone for taking packet capture.

Br, Nadeem Please rate all useful post.

Firmware info below. I guess I assumed they would work with a 10.5.. I’ve had them tested on a 11.xx CUCM in the past.  

From the Phone:

7960: P0S3-8-12-00
7940: P0S3-8-12-00
9931: sip9971.9-4-2-13

Can you perform one thing before get into the packet capture things..

Delete the CTL and ITL from phones  if phone status still unknown and you are getting dial-tone then run this command from CLI : show risdb query phone 

if phones are showing registered while running this command  please restart the below service on CUCM

"Restart the Cisco RIS Data Collector on all the servers"

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/uc_system/unified/communications/system/versions/IPTMtrix.html

Br, Nadeem Please rate all useful post.

I've reset the phones a couple times - does that delete the CTL and ITL from the phone?

I don't show a CTL File under settings -> security configuration.  Attached is a screenshot of the output from show risdb query phone

reset phone do not delete the CTL and ITL files from the phones.

#setting>Security Configuration>Trust List>CTL (Select and delete by unlocking phone by pressing **#) if there is no CTL file move on the ITL if there is

#setting>Security Configuration>Trust List>ITL (select and unlock phone erase )

Br, Nadeem Please rate all useful post.

I reset the phone and did not delete config file.  I do not see CTL or ITL files on the phone.  Below is the the navigation path to the CTL Location and what is listed

Settings -> Security Configuration -> 1SetCfgEncryptionKey

are you not able to see TRUST LIST

setting>Security Configuration>Trust List> ITL FILE.

Can you please confirm what is the state of the phone its showing on the phone screen. can you please pull CCM trace while resetting one of the phone or take pcap as suggested earlier to identified what exactly its causing this issue.

Please check attached file to validated the ITL file on the phone

Br, Nadeem Please rate all useful post.

Please see the attached pic and log (rename 2016-08-16--0927.jpg to 2016-08-16--0927.cap). Below is the tcpdump command I ran for reference.
CUCM
- IP: 192.168.10.5
- Version: 10.5
Phone
- IP: 192.168.10.31
- Model: 7960

tcpdump command:
sudo tcpdump -n -X -vvv -i en5 -w 2016-08-16--0927.cap

Hi Aaron,

Are you running Call Manager Cluster With PUB and SUB in the Lab setup ?

Regards

Inderpsi

This is just PUB config.   No SUB

Well embarrassingly enough, I just noticed that the one and only external phone I can get working in my Lab is registered as SCCP. Not sure how that happened as I was pretty certain I was loading all phones as SIP.. And the CIPC phones are registered/working as SIP… But never the less……

I did a trace on 7960 phone trying to register as SIP… I have highlights below and the trace attached..   Please rename 2016-08-18--0817_7960_SIP_Logon_Trace.cap.jpg to 2016-08-18--0817_7960_SIP_Logon_Trace.cap.pcapng

Anybody have some more thoughts on my issues?

Highlights:
CUCM: 192.168.10.5
7960: 192.168.20.31

- Request CTLSEP<MAC Address>.tlv
- Reply: File not found
- Request: SEP<MAC Address>.cnf.cml
- Reply: File not found
- Request: SIP<MAC Address>.cnf
- Reply: Downloads file
- Request: P0S3-8-12-00
- Reply: Downloads file

———Then loops ———

- Request: SIP<MAC Address>.cnf
- Reply: Downloads file

Just a bump to see if there were anymore ideas out there?

thanx

Resolved:

Some of the phones are SCCP only and some of my phones are SIP only..  I am able to get them connected and working using one of the protocols, but unable to get them working if I try to switch protocols for example SCCP to SIP.

UPDATE:

I am working with 3 different model phones 7960, 7940, 9971 (Added my bosses phone for testing) and CIPC running on 2 different physical devices.  All 3 of the physical phones work as expected on our company CUCM cluster.

In my Lab:

Both CIPC's and the 7940 are registered and can call each other.  The only change was Plugging in the 7940 to our Cluster.  The 7960 and 9971 were also plugged in to company Cluster, but still not working in lab.  

9971:  Still not registering - I replaced cables and swithports with the working 7940 - still no luck

7960:  Still flashing "your current options" across the bottom and not registering.

The regards to the working 7940:

 - Does not have a CTL file installed

 - Security Mode is set to Non Secure.  

 - Trust list is empty

And I can get to the web access page on the phone.  (Clicking on the phone IP in CUCM)

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: