cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5767
Views
3
Helpful
31
Replies

Unity Connection Temp Fail - Conversation Manager Crashing

shh5455
Participant
Participant

I'm using CUCM 8.0.2 and Unity Connection 7.1.3.  Whenever I call the voicemail pilot it answers fine and asks me to enter my PIN.  When I enter my PIN nothing else happens and after a few seconds I get a Temp Fail message on my phone.  I also see that at that point I stop receiving RTP packets on my phone (although I'm still sending).  It doesn't seem to be time related as I can back out to the CUC main menu and move around and it works fine.  It's just whenever I log into a mailbox I get this.  I have tried logging into other subscribers' mailboxes, but get the same thing.

Very basic setup.  Nothing unusual or fancy.

Any thoughts?

31 Replies 31

shh5455
Participant
Participant

Update: I tried this with CUCM 7.1.5 and the same thing occurs.

Update: Reinstalled CUC.  Problem still occuring.

Are your ports configured and registered properly with CUCM?  I would start by monitoring the ports on CUC to make sure they aren't flapping registration with CUCM.  Where is CUC relative to CUCM - same subnet, different subnet, same building, different building, etc???

Hailey

Scott Hills
Cisco Employee
Cisco Employee

Hello,

At times we see this when two Connection servers are fighting for registration. Not sure if you might have another Unity or Unity Connection Server on your network that might be causing issue.

The problem would most likely be if they are attempting to register with the same device prefix to the same Callmanager Cluster.

Thanks,

Scott

In similar fashion, I have seen this with a new CUC cluster that was configured properly (for integration with CUCM); however, the ports on the servers would show a registered status but with a private IP address (i.e., 169.259.x.x). The ports would receive calls and integrate but nothing past that. The cause for this is unknown but the ports would occasionally flap registration status as well. In the end, rebooting the cluster cleared things up - but either way, it sounds like you have an issue with your CUCM integration. If it's not as simple as that, I'd take a look at connectivity on the network to see if that is factoring into play here.

Hailey

Please rate helpful posts!

I have verified that as soon as the first digit of the PIN is pressed the CUC ports unregister from CUCM.  Not sure why.  I haven't tried to pull any logs yet.  After a few seconds they will reregister and then I can call again.  Strangely, when it tries to log me in, if I hit * then a mailbox ID, it works through that.  It's just as soon as I start to type the PIN the ports unregister.

Are you using a SIP or SCCP integration for CUCM to Unity Connection?

SCCP

I have spent some time looking at the logs, and it appears that Conversation Manager may be crashing whenever the PIN is entered.  In RTMT it generates a core dump each time (I tried to download this, but it didn't seem readable).  The Conversation Manager also reset.  I used Port Monitor to watch the ports and RTMT would lose connection with it and ask if Conversation Manager was still up.  Then the ports would reinitialize.

Looking at the Conversation Manager logs (i enabled macro traces), everything appears to be ok, but right after I enter the PIN the file says its attempting to authenticate, then the file ends.  A new file starts up (presumably after Conversation Manager restarts) and then the ports reregister.  There is also a gap in time between the files so that makes me think the service crashed.

I'm attaching those two log files if you want to see them.  If you know better how to determine what is happening, I'm all ears.

For completeness, I would like to ask if you've looked at anything from the CUCM side as well.  For instance, have you tried to register your ports to a different CUCM subscriber to see if that makes a difference in behavior?

Hailey

While I haven't looked at the CUCM logs, I have registered it to CUCM 7.1.5 and 8.0.2 and get the same behavior.  I have also tried rebuilding CUC from scratch. I'm going to try upgrading to the latest 7.1.3 release.

While version could be a factor, I would still test registration with a separate Subscriber. What is your CUCM and CUC architecture?

Sent from my iPhone

Both are on the same ESX server, same subnet.

Do you have separate CUCM VMs replicating a cluster model or one VM for each app only? Is this production or testing? I suspected this was a VMWare environment. Rebuilding that many physical servers would be a pain.

Sent from my iPhone

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: