cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

128
Views
0
Helpful
3
Replies

Calling number doesn't include 0 Prefix from Sip trunk in phone directory.

Hi Everyone

I have a sip trunk configured from CUCM to ISP.

For incoming calls I have configured Prefix "0" on Calling number for all calls on SIP Trunk configuration page. It is applying on the phone screen when a call is incoming, but it is recording without "0" on the phone directory.

I tried use CSS instead of prefix on SIP trunk configuration page. Also I configured a Calling transformation CSS on phone configuration page to prefix 0 but still the same. The calling number is not recording with prefix "0" on the phone.

The version is 10.5. I remember have configured this before and work. I don't know why now it is not working.

Thank you for the help.

Happy new year.

Best regards  

3 REPLIES 3
Vivek Batra
Engager

Since you don't want to localize the number again on phone (call logs), don't apply Calling/Remote Party Transformation CSS on phone.

 As you want to add prefix '0' to all numbers, simply create Calling Party Transformation Pattern as '!', add prefix '0' and keep it in separate partition and assign this partition to relevant CSS. Apply this CSS as Calling Party Transformation CSS on SIP Trunk page (Incoming Calling Party Settings). Uncheck device pool CSS.

- Vivek

Hi

Thank you for the answer.

Sincerely I think I didn't check that. I was only focus on the Prefix Section. The only thing I tried to workaround this was apply the CSS transformation on the Phone.

I will try and I will report the results.

thank you

Best regards

Hi

I think the problem is not CUCM, is Unity Connection.

Call comes through SIP Trunk, It point to UC IVR, after UC send the call to Attendant Console Operator.

If I use a DDI connected directly to DN works Ok the "0" is there, but when call goes to IVR and UC transfer to extension it remove or omit the prefix 0

Anyway to UC respect the prefix?

Thank you

Best Regards

Content for Community-Ad