cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
282
Views
0
Helpful
3
Replies
Highlighted
Beginner

CUE Script

Hello,

 

Has anybody managed to write an IVR script that will place outbound calls.

I have a CCME 10.0 with a CUE 8.6.11 integration and i need agents to call the IVR , dial customer's number, then  the IVR to place the call, play a message to customer and then connect them with the agent who made the initial call.

I have created a script that worked on my lab (CCME 8 with CUE 7.2) as expected. But for some reason, the same script (of course written on a 8.6 CUE editor), doesnt work with the above integration.

What is happening is that the call is placed towards the customer, but the script goes to unsuccesful branch and the line drops on both sides. 

 

From traces on the cue i can see the sip messages when it tries to place the call but no answer is coming from CCME. The call is then terminated due to timeout.

 

On the CCME ccsip debugs i can see requests from CUE, and also replies (trying, ringing etc) to CUE , but as i told before CUE doesnt receive them.

 

Apart from that, all other functionalities of the CUE (as voice mail, auto attendants, mwi's and of course IVR's call-in Number) can be called and are  working ok. 

 

A TAC cannot be opened in this case as it is a custom IVR script.

 

Any help appreciated.

 

Regards

 

 

3 REPLIES 3
Highlighted
Beginner

Hi,

Plz attach the SIP and CUE debugs and script to check it

thx

Highlighted

Hello Hamzeh,

Thank you for your reply and sorry for the delay  of my  answer.

Please find attached  the script and the debugs from CCME and CUE.

Just to help you, the calling party is the 9912 extension, that calls the 505 which is the IVR call in number.

IVR answers, asks for customers number, in this case is 92108067212. IVR makes the call. The call indeed is made to the called number. But from the script reactive debug the call goes to unsuccessful branch and the calling party hears the default message " I am sorry , we are currently experience system problems etc. On the called party there is no sound and the line drops after a few seconds.

 

One last think i want to mention which is the main difference on the script with the 7.0 script (that worked on my lab) and the 8.6 script is the Secondary callcontrolgroupid parameter on the place call step. On 7.0 edition i am allowed to leave it blank as instructed on the following link

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/unity_exp/rel3_1/administration/guide/script/ScriptEditor/stpref.html#wp1013910

On the 8.6 edition I am not allowed empty value so I have put 0.

 

Regards

Highlighted

Hello ,

I have checked the script, and I see that there is Terminate step before Call redirect step, and logically this is incorrect, as you need to terminate the call before it has been redirected to the intended destination.

 

so please try to move Terminate right before End step and re-upload the script and test again.

as well can you provide me with output of cmd: show license status application from CUE cli!

Content for Community-Ad