Showing results for 
Search instead for 
Did you mean: 

C220 M5SX cannot change pSATA to SWRAID


Background info:

Server BIOS  4.0(2b)C

UCSM FW 4.0(2b)A


Server storage setup:

OS boot from SAN

2 x 512GB NVMe,

2 x 3.8TB 6G SATA SSD disks on PSATA controller


Server OS: Centos 7.6.1810

I've been battling with couple of these servers for a while now. First I tried to get them to boot from NVMe disk with no result and I decided to go with SAN boot which was much easier to set up. After I got CentOS installed, the system only sees NVMe disks plus the boot LUN from SAN when checking with fdisk -l, lsblk or lshw.

I have been trying to get CentOS to recognize the PSATA disks and tried all sort of  Boot and Disk policies resulting that I managed to create virtual drive which I cannot remove and trying to change BIOS settings to LSI SW RAID mode results "sw raid configuration is not detected switching to ahci mode" in BIOS.


Can I somehow force delete the virtual drive via UCSM? I can't access the RAID configuration utility in KVM and I'm suspecting this is causing the PSATA mode change to fail -> OS cannot find the disks.

Is there some other configuration needed than changing Bios Policy -> Boot Options -> P-SATA mode to "LSI SW RAID"?


Thanks for your help!


1 Accepted Solution

Accepted Solutions