cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1526
Views
0
Helpful
8
Replies

ucs blade iscsi boot cannot install windows server

fdlprw5191
Beginner
Beginner

Hi all,

i have some problem when i try to install windows server 2008 in nexenta storage using iSCSI via ucs b-series, but its working fine when i install ESXi 5.5. i cannot find drive on windows server installation, and in ESXi i can see all LUN what im create before in nexenta storage and working when i install it.

this vnic iSCSI Configuration:
----------------------------
vnic_id: 13
          link_state: Up

       Initiator Cfg:
     initiator_state: ISCSI_INITIATOR_READY
initiator_error_code: ISCSI_BOOT_NIC_NO_ERROR
                vlan: 0
         dhcp status: false
                 IQN: test:iqn.2014-11.com.:8
             IP Addr: 192.168.1.59
         Subnet Mask: 255.255.255.0
             Gateway: 192.168.1.5

          Target Cfg:
          Target Idx: 0
               State: ISCSI_TARGET_READY
          Prev State: ISCSI_TARGET_DISABLED
        Target Error: ISCSI_TARGET_NO_ERROR
                 IQN: iqn.2010-08.org.illumos:02:windowsboot
             IP Addr: 192.168.1.49
                Port: 3260
            Boot Lun: 6
          Ping Stats: Success (986.646ms)

        Session Info:
          session_id: 0
         host_number: 0
          bus_number: 0
           target_id: 0

does anyone can help me to solve this issue?

thanks in advance - fadli

 

1 Accepted Solution

Accepted Solutions

Walter Dey
Advocate
Advocate

enic / fnic driver have to be installed; they are not part of any Windows OS.

they can be found in

 
Unified Computing System (UCS) Drivers-2.2(3)

ISO image of UCS-related drivers  Login Required
ucs-bxxx-drivers.2.2.3.iso

depending on the UCS version.

View solution in original post

8 Replies 8

Walter Dey
Advocate
Advocate

enic / fnic driver have to be installed; they are not part of any Windows OS.

they can be found in

 
Unified Computing System (UCS) Drivers-2.2(3)

ISO image of UCS-related drivers  Login Required
ucs-bxxx-drivers.2.2.3.iso

depending on the UCS version.

hi wdey,

thanks for you respon, and then where i must put the ucs-bxxx-drivers.2.2.3.iso? parallel with windows server iso in kvm console? with queue ucs.iso first and then windows.iso in second?

thanks.

It depends. If you install manually, you first mount the MSFT iso, then you are asked if you want to install additional drivers -> unmap MSFT iso and map UCS driver iso; install enic / fnic drivers -> unmap UCS driver iso and map again MSFT iso. Don't forget to refresh the screen.
 

oh ok, i understand, but im confused about ucs driver, i was download and map ucs-bxxx-drivers.2.2.3.iso and result no driver match, and my ucs version is 2.1.3(a), if in that condition i must use driver for ucs version 2.1.3(a) to? cannot use 2.2.3 driver or else?

thanks.

With UCS 2.1.3a you should use

ISO image of UCS-related drivers  Login Required
ucs-bxxx-drivers.2.1.3d.iso

hi wdey
i was tried to use ucs-bxxx-drivers.2.1.3d.iso and still not detected, i try for 2.2.3 and 2.1.3(d), no one success to detected the lun,i also try your instruction for put the iso. now i wants to try with 2.1.3(a), currently im downloading. whats do you mean of MSFT.iso? its mean my windows server iso?

Yes, Microsoft Windows OS iso !

Please also check the UCS Interop Tool

http://www.cisco.com/web/techdoc/ucs/interoperability/matrix/matrix.html

I assume a B200-M3, and see that only Windows 2008 R2 SP1 X64 is supported.

Adapter Driver   = 2.1.0.25 (FNIC) / 2.3.0.4 (ENIC) / 2.1.0.9 (NIC Teaming Driver)
Adapter Firmware = 2.1(3)
Boot Code / BIOS =

Note 12: iSCSI Boot is supported. Both Appliance and Uplink ports are supported unless otherwise noted

 

yes, i have all requirement, i was success for detected lun, but im still dont know why the lun is change, first setup in service profile i set lun 6 for the target iSCSI, and after i success detected lun (windows - network - cisco - M81KR - w2k8r2), the primary lun is change to lun 4, and all of free space lun is 0 (because format of hardisk is GPT, not NTFS ?) and my question : 

1. why the primary lun can changes from 6 to 4?

2. where can i changes hardisk format from GPT to NTFS? in ucs or nexenta storage (just info im using iSCSI, not FC)

thanks

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers