cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Booting SAN through FI-B does not work.

thantzinsoe87
Beginner
Beginner

Hello,
Now,I'm using UCS Min,NetApp Storage.
I tried to boot OS from NetApp.
The problem is I cannot install any OS on LUN booted through FI-B.
But CAN install OS on LUN booted through FI-A.
As far as I know, under normal situation, when booting wth NetApp LUN before installing any OS on it, it show "Fail to find bootable device,retrying". (pls refer my picture)

I found out that
In FI-B, it doesn't show above message and i cannot install OS.
In FI-A,it show above message and i can install OS.
I guess something wrong with FI-B device.
Please see my diagram.
I guess configuration is not wrong.
I also check firmware is the same.

I reset config and test again.result is the same. I also tested FI that has problem with SAN boot to another FI role (from FI-B to FI-A).Not work!
Could you please help me out what's the root cause of it?Thanks in advance.
Thanks & Best Regards,

 

7 REPLIES 7

ssumichrast
Beginner
Beginner

If you do an "igroup show" on the netapp do you see an entry for VHBA B? You didn't mention if the masking is set for the LUN correctly or if that was checked. 

You can also watch the console or check the log on the netapp to make sure it is seeing a login. 

Dear Steven,

        Thanks for your prompt help. masking is correct so that in UCS Server, it can see LUN of NetApp.Please see attached for login success of vHbaA.

When I install vmware ESXi through vHba B via fI B, it show error covered in enclosed file.

Installing ESXi through vHba A via fabric interconnect A is successful.

I suspect firmware.When I compared,fabric A and B is identical.
So,it can't be issue.

I'm just looking into it.

Thanks for your help.

Is there any thing I can check?

Thanks & Best Regards,

I can hardly believe that this is related to UCS Firmware ?

- is your Netapp active / stby for this lun ?

- it seems that you have 2 different igroups pointing to the same lun ? is this ok ?

- you see the lun on both sides, therefore zoning is ok !

Walter.

Dear Mr.Dey,

        NetApp is ALUA. I guess having different igroup mapping to one LUN is OK?

Thanks for your feedback.

Thanks & Best Regards,

Q. Is this Problem still not resolved ?

There are hundreds of working installations of this kind.

Something very Basic must be wrong, and I fear it's on the storage side.

The boot lun must be seen on fabric a and b; check zoning and boot policy !

Hello everyone,

               Issue is fixed now.One of the FI device is not working properly.When we replaced with another FI device by RMA, it is now OK.Thanks for your idea and suggestion.

Thanks & Best Regards,

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: