cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1244
Views
1
Helpful
2
Replies
Highlighted
Beginner

Cisco UCS - Running blades with multiple firmware versions.

Hi All,

Just double checking this.. I can't find any solid documentation.

But running a UCS domain with firmware version 2.0(4a).

The blades are for vSphere but we've got a request in to run Oracle VM and apparently Oracle have advised the blade version to be 2.0(4b).

I would assume I can run both firmware versions on the different sets of blades?

Nick.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Cisco Employee

Yes, for 2.0 - Major and Minor versions need to match so you could have 2.0(4a) on the infrastructure and 2.0(4b) on the blades. But I'd recommend bringing infrastructure to 2.1(1f) - then it's fully supported to have 2.0(5) and 2.0(4) on the blades. You also get all these new features in 2.1 -> http://www.cisco.com/en/US/docs/unified_computing/ucs/sw/gui/config/guide/2.1/b_UCSM_GUI_Configuration_Guide_2_1_chapter_01.html

Firmware autoinstall, Service Profile renaming, and enhanced FSM are nice to have.

View solution in original post

2 REPLIES 2
Highlighted
Cisco Employee

Prior to version 2.1 of UCSM, the versions of firmware needed to match on blades and infrastructure. Ideally Major, Minor, and bugfix versions match exactly, but Major and Minor matching are officially supported. However, the infrastructure needs to be at the highest level.

For UCSM the Major release is the first two numbers, the Minor is the first number in the parenthesis and the bugfix letter is the letter. For example, in 2.0(4a), 2.0 is the Major, 4 is the Minor, and "a" is the bugfix version.

Starting at version 2.1 we support the current version and two minor releases prior. So currently with version 2.1(1f) you can run blades with version 2.0(5) and 2.0(4).

Specifically in your case, I'm going to double check that the infrastructure would need to be at 2.0(4b) or if it could remain at 2.0(4a) and have the blades at 2.0(4b)

Highlighted
Cisco Employee

Yes, for 2.0 - Major and Minor versions need to match so you could have 2.0(4a) on the infrastructure and 2.0(4b) on the blades. But I'd recommend bringing infrastructure to 2.1(1f) - then it's fully supported to have 2.0(5) and 2.0(4) on the blades. You also get all these new features in 2.1 -> http://www.cisco.com/en/US/docs/unified_computing/ucs/sw/gui/config/guide/2.1/b_UCSM_GUI_Configuration_Guide_2_1_chapter_01.html

Firmware autoinstall, Service Profile renaming, and enhanced FSM are nice to have.

View solution in original post

Content for Community-Ad