cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
17959
Views
0
Helpful
6
Replies
Highlighted
Beginner

Force “SIP 180 Ringing” with SDP body

Hello,

After I have configured “progress_ind alert enable 1” ISDN ALERTING messages are always converted to “SIP 183 Session Progress”. It is possible to also send “SIP 180 Ringing” with SDP?

My problem is ISDN->SIP->ISDN interworking. My AS5300 is receiving an ISDN ALERTING converting to SIP 183 Session Progress”, the other gateway (non cisco) is receiving SIP 183 Session Progress” converting to ISDN PROGRESS and the PBX connected to this gateway doesn’t respond to PROGRESS only to ALERTING

Thanks,

David Costa

Everyone's tags (5)
6 REPLIES 6
Highlighted

Re: Force “SIP 180 Ringing” with SDP body

Hi David

Yes its possible.

This command provides the ability to enable or disable early media cut-through on Cisco IOS gateways for Session Initiation Protocol (SIP) 180 responses with SDP. Use the disable-early-media 180 command to configure the gateway to ignore the SDP message and provide local ringback. To restore the default treatment, early media cut-through, use the no disable-early-media 180 command.

Configure this in your Gateway.

Examples

The following example disables early media cut-through for SIP 180 responses with SDP:

Router(config-sip-ua)# disable-early-media 180

Refer this link for more details.
Pl rate if info is useful. thanks.
Highlighted
Beginner

Re: Force “SIP 180 Ringing” with SDP body

Hi,

In the first post I haven’t been clear, but I want early-media.

As I’m not receiving progress indicator from ISDN side, I have to configure “progress_ind alert enable 1” on my inbound pot dial-peer to get early-media. Doing this early-media works, but the ISDN ALERTING is converted to “SIP 183 Session Progress” with SDP body. What I want is somehow force ISDN ALERTING to be converted into “SIP 180 Ringing” with SDP body and also get early-media.

I want this because on the other side gateway is converting “SIP 183 Session Progress” into ISDN PROGRESS and the PBX attached to the TDM port of this gateway doesn’t enable voice path with ISDN PROGRESS only with ISDN ALERTING.

           +------------+                     +------+                    +-------+  
TDM---| AS5300 |-----VoIP-------| MG |------TDM----| PBX |
           +------------+                     +------+                    +-------+

I also tested your configuration and even with “disable-early-media 180” if I have “progress_ind alert enable 1” I get early-media with “SIP 183 Session Progress”.

Thanks,

David

Highlighted
Enthusiast

Force “SIP 180 Ringing” with SDP body

Hello.

I came accross an issue yesterday where we have ISDN -> SIP -> ISDN and ringback / early media was failing where the remote end was an older isdn system.

I fixed it with the global command: 'voice call send-alert' on the far end gateway which means the final isdn call leg gets progress indication with an alerting message rather than a progress.....

before command added:

SIP/2.0 183 Session Progress

Via: SIP/2.0/UDP109.111.211.172:5060;branch=z9hG4bK45716AD;rport=52649

Contact: <193.203.210.37:6060>

From: <>123456789@proxy.voip.co.uk>;tag=416F910-1139

To: <>01869222500@proxy.voip.co.uk>;tag=f4035cbee28c

Call-ID: C1054C14-104611E1-87FDB916-9EBD7D3C@109.111.211.172

CSeq: 102 INVITE

Content-Type: application/sdp

Content-Length: 214

v=0

o=CiscoSystemsSIP-GW-UserAgent 9207 1592 IN IP4 10.200.254.4

s=SIP Call

c=IN IP4 193.203.210.37

t=0 0

m=audio 25316 RTP/AVP 8 101

a=rtpmap:8 PCMA/8000

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-16

Nov 17 11:33:12.461: ISDN Se0/0/0:15 Q931: TX -> PROGRESS pd = 8  callref = 0x8117

        Progress Ind i = 0x8188 - In-band info or appropriate now available

and after

SIP/2.0 183 Session Progress

Via: SIP/2.0/UDP 109.111.211.172:5060;branch=z9hG4bK46B24F4;rport=57015

Contact: <193.203.210.37:6060>

From: <>123456789@proxy.voip.co.uk>;tag=8B9A538-134E

To: <>01869222500@proxy.voip.co.uk>;tag=16b3dce9914f

Call-ID: D4296A68-10FB11E1-881BB916-9EBD7D3C@109.111.211.172

CSeq: 102 INVITE

Content-Type: application/sdp

Content-Length: 214

v=0

o=CiscoSystemsSIP-GW-UserAgent 9138 3142 IN IP4 10.200.254.5

s=SIP Call

c=IN IP4 193.203.210.37

t=0 0

m=audio 40292 RTP/AVP 8 101

a=rtpmap:8 PCMA/8000

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-16

Nov 18 09:09:19.922: ISDN Se0/1/1:15 Q931: TX -> ALERTING pd = 8  callref = 0xB4B9

        Progress Ind i = 0x8188 - In-band info or appropriate now available

The originating gateway does have:

sip-ua

disable-early-media 180

Adam

Highlighted
Beginner

Force “SIP 180 Ringing” with SDP body

Hi Adam,

Thanks for your post, but my problem is that the PBX with problems isn’t attached to the cisco gateway and the other media gateway doesn’t have a similar function to 'voice call send-alert'

Regards,

David Costa

Highlighted
Enthusiast

Re: Force “SIP 180 Ringing” with SDP body

Oh OK.

Adam

Highlighted
Beginner

Re: Force “SIP 180 Ringing” with SDP body

i have a similar problem, did you find a solution to this problem ?

CreatePlease to create content
Content for Community-Ad

Cisco COVID-19 Survey