Showing results for 
Search instead for 
Did you mean: 

Cisco SPA502G IP Phone "SOS Phone In Recovery Mode"

Level 1
Level 1

Hello, I am a user of a Cisco SPA502G IP Phone. It is in "SOS Phone In Recovery  Mode". Could I recover the phone to "spa50x-30x-7-5-2.bin" version?

I try it with the version of recovery, but no works.




8 Replies 8

Level 5
Level 5


I would recommend to try using the recovery software bundled with the latest version of the firmware. You can download the file from here:

The recovery tool uses a TFTP server to allow for the firmware to be recovered. Please make sure to disable the firewall on the PC where you are running the recovery application from so that the TFTP server can communicate with the phone.

Please let us know if this works. 

I would recommend to try using the recovery software bundled with the latest version of the firmware.


The best advice is more complicated. Useable recovery firmware depends on bootstrap firmware version.

It's not possible to upgrade pre-7.5.2b firmware to post-7,5,2b version. It apply even to SOS Recovery procedure. So check bootstrap firmware version (it's disclosed by recovery firmware tool).

If it is older than 7.5.2b you need to use recovery firmware older than 7.5.2b. Otherwise use latest firmware as suggested.

Hello, sorry for my bad english!!

Could you to guide me how can I to do to connect to my phone?

I do this:

-first time I connect the phone to a router with POE power (appear SOS Phone In Recovery Mode)

-Later I connect my lan PC port to the PC port of the phone

-I run the Recovery firmware

-in Recovery Firmware I put the serial number of the phone

Result:  Cannot find the specific device


help me please!!!

....and thanks again!!!

Later I connect my lan PC port to the PC port of the phone

PC port is out of service during SOS Recovery mode. The PC needs to be connected to the same local network as phone itself (SW port of phone). Ask your's local network administrator for help.


Thanks, Dan!!

Now, I connect to the same local network (to a cisco switch connected to a router which provides the ip) but it does not work.

note: it's the same configuration (router, switch, phone) as when the first software upgrade is interrupted.


can i do something more?


thanks, again

OK. Recovery procedure needs to be started not so long past power on of phone. So power cycle the phone just before start of recovery utility.

Also, the recovery process require multicast communication between PC and phone. It must not be blocked by neither firewall nor cisco switch.

Capture packets sent and received on PC. Focus on UDP, ports 4810 & 4811. Do you see a packet send from PC to ? Do you see a response from phone ?


You may be interested to read S.O.S Firmware Recovery Protocol Specification. It describe the packets you should expect during procedure.


Thank you so so so so so so so so so so so so so so very much, God bless you, my friend, I have tried 1000 things to solve the issue but couldn't but your recommendation of switching off firewall saved the day, I uninstalled our company's anti-virus software and then ran the recovery tool and it worked like magic !!, Again Thank you a billion time and have a good day.




Mahmoud Fawzy

Explanations exist; they have existed for all time; there is always a well-known solution to every human problem — neat, plausible, and wrong. (H. L. Mencken)

Fortunately, the latest one has not been true here. Glad to hear you solved it.