06-12-2014 05:52 AM - edited 03-21-2019 08:16 AM
I am trying to setup voicemail to email notifications and it hasn't been working. Some have thought it was the firewall at the edge of the network but I didn't see any reason why this would be blocked.
I connected to the CUE via the CLI (service-module in0/0 session) and I tried to ping to google... no dice, couldn't resolve the address..
Okay so maybe it's DNS then. Set the DNS server via the ip name-server 8.8.8.8 and it gave me a warning saying that "Couldn't reach 8.8.8.8 using DNS". Okay, so maybe it is the firewall.. I try to ping the firewall from the CUE... nope. Try to ping a computer from the CUE... nope. The only thing I can ping is the router side of the UC540 at 10.1.10.2.
The router side has no troubles getting to any of the addresses listed above. It can resolve an IP address and ping without troubles.
So this leads me to believe there is an issue between the CUE and the router. The show ip route on the CUE seems normal to me... show all packets go to the 10.1.10.2 address, looks the same as other UC540 implementations that are having no issues at least.
Thoughts?
06-12-2014 01:12 PM
Hi,
do you've a default route in the router?
interface Integrated-Service-Engine0/0
service-module ip default-gateway <IP>
Can you post your complete configuration?
Chris
06-13-2014 06:57 AM
Below is the sanitized config. I've also removed some telephony stuff that really isn't part of the issue.
The network is very simple. We have a simple Comcast modem as the "router" (which I hate) and the UC540 is connected to it via one of it's ports. No NAT happening on the UC540, just connected to the local network. The Comcast modem has a static route setup on it to the CUE via the UC540's BVI1 IP address. I can access the CUE via 10.3.10.1 on a computer that is in the network fine. From the computer that can access the CUE server's web GUI I can also ping (obviously). The odd thing is that I cannot ping the computer from the service-module interface, it's like a one way issue. I can from the router's though. The service-module can ping the Comcast modem but not the computer on the LAN or anything outside of the network. Thought it might be something to do with the ACLs but I can't see what would be blocking in one direction. I am planning on doing a packet capture on the computer to see if the pings from the service module are getting there but just being blocked at the UC540 for some reason. Anyway, below is the config. Let me know if you see anything!
Thanks!!
ip cef
!
!
ip dhcp relay information trust-all
ip dhcp excluded-address 10.11.11.1 10.11.11.10
ip dhcp excluded-address 10.10.10.1 10.10.10.10
!
ip dhcp pool phone
network 10.11.11.0 255.255.255.0
default-router 10.11.11.1
option 150 ip 10.11.11.1
!
!
!
ip name-server 208.67.222.222
ip name-server 208.67.220.220
ip inspect WAAS flush-timeout 10
ip inspect name SDM_LOW dns
ip inspect name SDM_LOW ftp
ip inspect name SDM_LOW h323
ip inspect name SDM_LOW https
ip inspect name SDM_LOW icmp
ip inspect name SDM_LOW imap
ip inspect name SDM_LOW pop3
ip inspect name SDM_LOW netshow
ip inspect name SDM_LOW rcmd
ip inspect name SDM_LOW realaudio
ip inspect name SDM_LOW rtsp
ip inspect name SDM_LOW esmtp
ip inspect name SDM_LOW sqlnet
ip inspect name SDM_LOW streamworks
ip inspect name SDM_LOW tftp
ip inspect name SDM_LOW tcp
ip inspect name SDM_LOW udp router-traffic
ip inspect name SDM_LOW vdolive
no ipv6 cef
!
multilink bundle-name authenticated
!
!
stcapp ccm-group 1
stcapp
!
stcapp supplementary-services
port 0/0/0
fallback-dn 110
!
!
!
!
trunk group ALL_FXO
max-retry 5
voice-class cause-code 1
hunt-scheme sequential
!
!
trunk group FXObackup
max-retry 5
voice-class cause-code 1
hunt-scheme sequential
!
!
voice call send-alert
voice rtp send-recv
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
supplementary-service h450.12
sip
no update-callerid
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8
!
voice class custom-cptone CCAjointone
dualtone conference
frequency 600 900
cadence 300 150 300 100 300 50
!
voice class custom-cptone CCAleavetone
dualtone conference
frequency 400 800
cadence 400 50 200 50 200 50
!
!
voice class cause-code 1
no-circuit
!
!
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
fax interface-type fax-mail
!
!
license udi pid UC520W-8U-4FXO-K9 sn
archive
log config
logging enable
logging size 600
hidekeys
username service privilege 15 secret 4
!
!
ip tftp source-interface Loopback0
!
!
!
bridge irb
!
!
!
!
interface Loopback0
description $FW_INSIDE$
ip address 10.3.10.2 255.255.255.252
ip nat inside
ip virtual-reassembly in
!
interface FastEthernet0/0
description $FW_OUTSIDE$
ip address dhcp
ip nat outside
ip inspect SDM_LOW out
ip virtual-reassembly in
load-interval 30
duplex auto
speed auto
!
interface Integrated-Service-Engine0/0
description cue is initialized with default IMAP group
ip unnumbered Loopback0
ip nat inside
ip virtual-reassembly in
service-module ip address 10.3.10.1 255.255.255.252
service-module ip default-gateway 10.3.10.2
!
interface FastEthernet0/1/0
switchport voice vlan 100
no ip address
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/1
switchport voice vlan 100
no ip address
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/2
switchport voice vlan 100
no ip address
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/3
switchport voice vlan 100
no ip address
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/4
switchport voice vlan 100
no ip address
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/5
switchport voice vlan 100
no ip address
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/6
switchport voice vlan 100
no ip address
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/7
switchport voice vlan 100
no ip address
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/8
switchport mode trunk
switchport voice vlan 100
no ip address
macro description cisco-switch
!
interface Dot11Radio0/5/0
no ip address
!
ssid voice
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
antenna receive right
antenna transmit right
!
interface Dot11Radio0/5/0.1
encapsulation dot1Q 1 native
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio0/5/0.100
encapsulation dot1Q 100
bridge-group 100
bridge-group 100 subscriber-loop-control
bridge-group 100 spanning-disabled
bridge-group 100 block-unknown-source
no bridge-group 100 source-learning
no bridge-group 100 unicast-flooding
!
interface Vlan1
no ip address
bridge-group 1
bridge-group 1 spanning-disabled
!
interface Vlan20
no ip address
bridge-group 20
!
interface Vlan100
no ip address
bridge-group 100
bridge-group 100 spanning-disabled
!
interface BVI1
description $FW_INSIDE$
ip address 10.11.12.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface BVI20
no ip address
!
interface BVI100
description $FW_INSIDE$
ip address 10.11.11.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http path flash:/gui
!
ip dns server
ip route 0.0.0.0 0.0.0.0 10.11.12.1 permanent
ip route 10.3.10.1 255.255.255.255 Integrated-Service-Engine0/0
!
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 10.3.1.0 0.0.0.255
access-list 1 permit 192.168.10.0 0.0.0.255
access-list 1 permit 10.3.10.0 0.0.0.3
access-list 100 remark auto generated by SDM firewall configuration
access-list 100 remark SDM_ACL Category=1
access-list 100 deny ip 192.168.10.0 0.0.0.255 any
access-list 100 deny ip host 255.255.255.255 any
access-list 100 deny ip 127.0.0.0 0.255.255.255 any
access-list 100 permit ip any any
access-list 101 remark auto generated by SDM firewall configuration
access-list 101 remark SDM_ACL Category=1
access-list 101 permit tcp 10.3.1.0 0.0.0.255 eq 2000 any
access-list 101 permit udp 10.3.1.0 0.0.0.255 eq 2000 any
access-list 101 deny ip 192.168.10.0 0.0.0.255 any
access-list 101 deny ip 10.3.1.0 0.0.0.255 any
access-list 101 deny ip host 255.255.255.255 any
access-list 101 deny ip 127.0.0.0 0.255.255.255 any
access-list 101 permit ip any any
access-list 102 remark auto generated by SDM firewall configuration
access-list 102 remark SDM_ACL Category=1
access-list 102 deny ip 10.3.10.0 0.0.0.3 any
access-list 102 deny ip 10.3.1.0 0.0.0.255 any
access-list 102 deny ip host 255.255.255.255 any
access-list 102 deny ip 127.0.0.0 0.255.255.255 any
access-list 102 permit ip any any
access-list 103 remark auto generated by SDM firewall configuration
access-list 103 remark SDM_ACL Category=1
access-list 103 permit tcp 10.3.10.0 0.0.0.3 any eq 2000
access-list 103 permit udp 10.3.10.0 0.0.0.3 any eq 2000
access-list 103 permit udp any 10.3.10.0 0.0.0.3 range 16384 32767
access-list 103 permit udp 10.3.10.0 0.0.0.3 range 16384 32767 any
access-list 103 deny ip 192.168.10.0 0.0.0.255 any
access-list 103 deny ip host 255.255.255.255 any
access-list 103 deny ip 127.0.0.0 0.255.255.255 any
access-list 103 permit ip any any
access-list 104 remark auto generated by SDM firewall configuration
access-list 104 remark SDM_ACL Category=1
access-list 104 deny ip 10.3.10.0 0.0.0.3 any
access-list 104 deny ip 192.168.10.0 0.0.0.255 any
access-list 104 deny ip 10.3.1.0 0.0.0.255 any
access-list 104 permit udp any eq bootps any eq bootpc
access-list 104 permit icmp any any echo-reply
access-list 104 permit icmp any any time-exceeded
access-list 104 permit icmp any any unreachable
!
!
!
control-plane
!
bridge 1 route ip
bridge 20 protocol ieee
bridge 20 route ip
bridge 100 route ip
!
voice-port 0/0/0
timeouts ringing infinity
station-id name FAX
station-id number 110
caller-id enable
!
voice-port 0/0/1
timeouts ringing infinity
caller-id enable
!
voice-port 0/0/2
timeouts ringing infinity
caller-id enable
!
voice-port 0/0/3
timeouts ringing infinity
caller-id enable
!
voice-port 0/1/0
trunk-group ALL_FXO 64
translation-profile incoming INCOMING_CallerID_PROFILE
connection plar 511
description Configured by CCA 4 FXO-0/1/0-Custom-OP
caller-id enable
!
voice-port 0/1/1
trunk-group FXObackup 64
translation-profile incoming INCOMING_CallerID_PROFILE
connection plar opx 511
description Configured by CCA 4 FXO-0/1/1-Custom-OP
caller-id enable
!
voice-port 0/1/2
trunk-group FXObackup 63
translation-profile incoming INCOMING_CallerID_PROFILE
connection plar opx 511
description Configured by CCA 4 FXO-0/1/2-Custom-OP
caller-id enable
!
voice-port 0/1/3
translation-profile incoming INCOMING_CallerID_PROFILE
connection plar 110
description 970-855-0926 FAX
caller-id enable
!
voice-port 0/4/0
auto-cut-through
signal immediate
input gain auto-control -15
description Music On Hold Port
!
sccp local Loopback0
sccp ccm 10.11.11.1 identifier 1 version 4.0
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
associate profile 1 register confprof1
!
dspfarm profile 1 conference
description DO NOT MODIFY, active CCA conference profile - CCA2.0 codec711
codec g711alaw
codec g711ulaw
maximum conference-participants 32
maximum sessions 2
conference-join custom-cptone CCAjointone
conference-leave custom-cptone CCAleavetone
associate application SCCP
!
!
dial-peer voice 2000 voip
description ** cue voicemail pilot number **
translation-profile outgoing XFER_TO_VM_PROFILE
destination-pattern 100
b2bua
session protocol sipv2
session target ipv4:10.3.10.1
voice-class sip outbound-proxy ipv4:10.3.10.1
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 2012 voip
description ** cue prompt manager number **
translation-profile outgoing PSTN_CallForwarding
destination-pattern 201
b2bua
session protocol sipv2
session target ipv4:10.3.10.1
voice-class sip outbound-proxy ipv4:10.3.10.1
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 2002 voip
description ** cue auto attendant number **
translation-profile outgoing PSTN_CallForwarding
destination-pattern 202
b2bua
session protocol sipv2
session target ipv4:10.3.10.1
voice-class sip outbound-proxy ipv4:10.3.10.1
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 2001 voip
description ** cue auto attendant number **
translation-profile outgoing PSTN_CallForwarding
destination-pattern 200
b2bua
session protocol sipv2
session target ipv4:10.3.10.1
voice-class sip outbound-proxy ipv4:10.3.10.1
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 2003 voip
description ** AA directory menu **
translation-profile outgoing PSTN_CallForwarding
destination-pattern 203
b2bua
session protocol sipv2
session target ipv4:10.3.10.1
voice-class sip outbound-proxy ipv4:10.3.10.1
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 10 pots
translation-profile incoming ADD9
incoming called-number .
!
!
telephony-service
sdspfarm conference mute-on 111 mute-off 222
sdspfarm units 5
sdspfarm tag 1 confprof1
conference hardware
video
fxo hook-flash
max-ephones 14
max-dn 56
ip source-address 10.11.11.1 port 2000
auto assign 1 to 1 type bri
calling-number initiator
service phone videoCapability 1
service phone ehookenable 1
service dnis overlay
service dnis dir-lookup
service dss
timeouts interdigit 5
system message Creative Floors
url services http://10.3.10.1/voiceview/comon/login.do
load 7921 CP7921G-1.4.1SR1
load 7970 SCCP70.9-1-1SR1S
load 7971 SCCP70.9-1-1SR1S
load 521G-524G cp524g-8-1-17
time-zone 6
keepalive 30 auxiliary 4
voicemail 100
max-conferences 8 gain -6
call-forward pattern .T
call-forward system redirecting-expanded
moh flash:/media/music-on-hold.au
multicast moh 239.10.16.16 port 2000
web admin system name cisco secret 5 $1$bEfO$4Y0UxWdZ7jJxepFkR5CmF.
dn-webedit
time-webedit
transfer-system full-consult dss
transfer-pattern 9.T
transfer-pattern .T
transfer-pattern 6... blind
secondary-dialtone 9
night-service day Sun 17:00 09:00
night-service day Mon 17:00 09:00
night-service day Tue 17:00 09:00
night-service day Wed 17:00 09:00
night-service day Thu 17:00 09:00
night-service day Fri 17:00 09:00
night-service day Sat 17:00 09:00
night-service date Sep 2 00:00 23:59
night-service date Nov 28 00:00 23:59
night-service date Dec 25 00:00 23:59
fac standard
create cnf-files version-stamp 7960 Jun 13 2014 06:28:31
!
!
ephone-template 15
url services 1 http://10.3.10.1/voiceview/common/login.do VoiceviewExpress
softkeys remote-in-use Newcall
softkeys idle Redial Newcall Cfwdall Pickup Gpickup Dnd Login
softkeys seized Cfwdall Endcall Redial Pickup Meetme Gpickup Callback
softkeys connected Hold Endcall Trnsfer TrnsfVM Confrn ConfList RmLstC Acct Park Select Join
button-layout 7931 2
!
!
ephone-template 16
url services 1 http://10.3.10.1/voiceview/common/login.do VoiceviewExpress
softkeys remote-in-use Newcall
softkeys idle Redial Dnd Newcall Cfwdall Pickup Gpickup Login
softkeys seized Cfwdall Endcall Redial Pickup Meetme Gpickup Callback
softkeys connected Park Endcall Trnsfer TrnsfVM Confrn ConfList RmLstC Acct Select Join
!
!
ephone-template 17
url services 1 http://10.3.10.1/voiceview/common/login.do VoiceviewExpress
softkeys remote-in-use CBarge Newcall
softkeys idle Redial Newcall Cfwdall Pickup Gpickup Dnd Login
softkeys seized Cfwdall Endcall Redial Pickup Meetme Gpickup Callback
softkeys connected Hold Endcall Trnsfer TrnsfVM Confrn ConfList RmLstC Acct Park Select Join
!
!
ephone-template 18
url services 1 http://10.3.10.1/voiceview/common/login.do VoiceviewExpress
softkeys remote-in-use CBarge Newcall
softkeys idle Redial Newcall Cfwdall Pickup Gpickup Dnd Login
softkeys seized Cfwdall Endcall Redial Pickup Meetme Gpickup Callback
softkeys connected Hold Endcall Trnsfer TrnsfVM Confrn ConfList RmLstC Acct Park Select Join
button-layout 7931 2
!
!
line con 0
no modem enable
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
line vty 0 4
login authentication local
transport preferred telnet
transport input telnet ssh
transport output telnet ssh
line vty 5 15
login authentication local
transport preferred telnet
transport input telnet ssh
transport output telnet ssh
line vty 16 100
transport preferred none
transport input all
!
ntp master
end
07-30-2019 07:49 AM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide