Showing results for 
Search instead for 
Did you mean: 

How can I delete a fixed profile rule in a Linksys ATA?


I have a Linksys SPA2100 ATA that I used with a previous VoIP provider. I did a factory reset but their profile rule is still listed in the first Profile Rule section under the Provisioning tab. Profile Rule B, C and D are blank and I can enter a profile rule in there but I can't delete the main profile rule because it is fixed. I can't highlight it and delete it for some reason. There must be another way to delete this profile. This is what is listed there minus the name of the provider. I attached a screen shot too. Thanks.

Profile Rule:$PN/stub.bin

9 Replies 9


Hello Bill,

Do you need to use a different profile rule or are you just trying to get the address off of the device?

Going by your screenshot the provisioning is disabled so the device won't pull a configuration off of that address.  So even if it is there it won't have any effect unless provisioning is turned on.  You should still be able to go through and manually configure the device with the information from your new VOIP provider. 

Christopher Ebert

Network Support Engineer - Cisco Small Business Support Center

*Please rate helpful posts*

I just want to get that profile rule off the device because it does not pertain to my current provider. I have already configured it and it works fine. I put a user and admin password on my ATA. Do you think if I remove both passwords and turn on provisioning then I will be able to remove the main profile rule?

Well I tried turning on provisioning and another rule automatically was entered into the Profile Rule B section so I deleted it and turned off provisioning. I could still not delete the main profile rule. I guess I'll just have to leave it as is unless someone knows how I can delete this fixed profile rule.

Dan Lukes
I can't highlight it and delete it for some reason

The "some reason" seems to be "device is locked to provider". You may not be able to reset nor re-configure it in full according restrictions enforced by original provider.

There was no user or admin password until I entered my own. I was able to re-configure it to my new provider and it works fine. Do you think if I remove my user and admin passwords then that will allow me to remove the main profile rule?

It sound like very simple test. Just try it.

I did and I also turned on provisioning. It automatically entered a rule in Profile B and I was still unable to delete the main profile rule. I was able to delete the Profile B rule though. I turned off provisioning again. I guess I'll have to leave it like that unless someone knows how I can delete the fixed main profile rule.

Hi billcanada,

Take a look at your SPA2102's Voice tab > Info tab > Product Information > Customization:

It should contain "Open"


If not, you've got what is known as an "RC-unit" which is what we sell to many service providers allowing them to customize and lock the unit down. Given that you've got admin access, try the following [but don't be disappointed if it doesn't work]:

1. Enable debug on the SPA2102

2. Write a simple config file called spa2102.cfg whose contents include:





3. Save the spa2012.cfg file in the root of your TFTP server

4. Start the TFTP server

5. Start Wireshark on the subnet to which the ATA is connected

6. Power-cycle the ATA

7. Once it's booted, try and force a resync of your ATA using your browser: htttp://ataIPaddress/admin/resync?tftp://ipAddrOfTftpServer/spa2102.cfg

8. Verify with Wireshark that the ATA requested and received the /spa2102 file

9. Use a browser to determine if your config file overwrote the grayed-out Profile_Rule in the web-UI



My adapter is an SPA2100. I'm not sure if that makes any difference compared to the SPA2102. It says it's Customized so I am S.O.L. I don't know enough to do what you are suggesting so I'll just leave it as is because I don't want to take the chance and mess it up. I guess it's not really that big a deal. I would prefer there was no profile rule there but at least it works with my current VoIP provider and all other settings are changeable. I bought the adapter years ago from my VoIP provider at the time for $69.95 plus tax so for them to lock it is outrageous. I can understand them locking ATA's that customers rent every month but if you pay for it they should not make permanent changes to it that cannot easily be undone. At least mine did not have a user or admin password on it. I've read posts from people that can't get into their settings because their former VoIP provider had user and/or admin passwords on their ATA and they refused to tell them what they were. Anyway, thanks for your help. 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers