cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
814
Views
0
Helpful
3
Replies

No inbound call for SIP trunk connection

ywleung79
Level 1
Level 1

I got my uc540 successfully register with SIP service provider and making outbound call. However I was not able to received any inbound call to my DID number. I setup the inbound dial-peer (2008) and translation rule to one of my ephone but it seem the call never reach my inbound dial-peer.

Am I missing some configure??

 

This is my translation-rule:

voice translation-rule 1
 rule 1 /7185045765/ /601/
!
voice translation-rule 2
 rule 1 /^911$/ /911/
 rule 2 /^9\(.*\)/ /\1/
!        
voice translation-rule 3
 rule 1 /^.*/ /7185045765/
!
voice translation-rule 4
 rule 1 /601/ /7185045765/
 rule 2 /^9\(.*\)/ /\1/
!
voice translation-rule 1000
 rule 1 /.*/ //
!
!
voice translation-profile CUE_Voicemail/AutoAttendant
 translate called 1
!
voice translation-profile PSTN_CallForwarding
 translate redirect-target 4
 translate redirect-called 4
!
voice translation-profile PSTN_Outgoing
 translate calling 3
 translate called 2
 translate redirect-target 4

 

UC540#show run | section dial-peer
dial-peer voice 1 pots
 service stcapp
 port 0/0/0
dial-peer voice 2 pots
 service stcapp
 port 0/0/1
dial-peer voice 3 pots
 service stcapp
 port 0/0/2
dial-peer voice 4 pots
 service stcapp
 port 0/0/3
dial-peer voice 5 pots
 description ** MOH Port **
 destination-pattern ABC
 port 0/4/0
 no sip-register
dial-peer voice 6 pots
 description catch all dial peer for BRI/PRI^T
 translation-profile incoming nondialable
 incoming called-number .%
 direct-inward-dial
dial-peer voice 50 pots
 destination-pattern 9T
 port 0/1/0
 no sip-register
dial-peer voice 51 pots
 destination-pattern 9T
 port 0/1/1
 no sip-register
dial-peer voice 52 pots
 destination-pattern 9T
 port 0/1/2
 no sip-register
dial-peer voice 53 pots
 destination-pattern 9T
 port 0/1/3
 no sip-register
dial-peer voice 2002 voip
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9[2-9]..[2-9]......
 session protocol sipv2
 session target ipv4:107.6.67.238
 no voice-class sip early-offer forced
 dtmf-relay rtp-nte cisco-rtp sip-kpml sip-notify
 codec g711ulaw
 no vad  
dial-peer voice 2003 voip
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 91[2-9]..[2-9]......
 session protocol sipv2
 session target ipv4:107.6.67.238
 no voice-class sip early-offer forced
 dtmf-relay rtp-nte cisco-rtp sip-kpml sip-notify
 codec g711ulaw
 no vad
dial-peer voice 2004 voip
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 911
 session protocol sipv2
 session target ipv4:107.6.67.238
 no voice-class sip early-offer forced
 dtmf-relay rtp-nte cisco-rtp sip-kpml sip-notify
 codec g711ulaw
 no vad
dial-peer voice 2005 voip
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9911
 session protocol sipv2
 session target ipv4:107.6.67.238
 no voice-class sip early-offer forced
 dtmf-relay rtp-nte cisco-rtp sip-kpml sip-notify
 codec g711ulaw
 no vad
dial-peer voice 2006 voip
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9[2-9]11
 session protocol sipv2
 session target ipv4:107.6.67.238
 no voice-class sip early-offer forced
 dtmf-relay rtp-nte cisco-rtp sip-kpml sip-notify
 codec g711ulaw
 no vad
dial-peer voice 2007 voip
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9011T
 session protocol sipv2
 session target ipv4:107.6.67.238
 no voice-class sip early-offer forced
 dtmf-relay rtp-nte cisco-rtp sip-kpml sip-notify
 codec g711ulaw
 no vad
dial-peer voice 2008 voip
 translation-profile incoming CUE_Voicemail/AutoAttendant
 session protocol sipv2
 session target ipv4:107.6.67.238
 incoming called-number .%
 dtmf-relay cisco-rtp rtp-nte
 codec g711ulaw
no dial-peer outbound status-check pots

 

When I call my DID#7185045765 from outside telephone:
000126: Mar  2 04:07:11.547: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Calling Number=7185045765, Called Number=7185045765, Peer Info Type=DIALPEER_INFO_SPEECH
000127: Mar  2 04:07:11.547: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Match Rule=DP_MATCH_DEST; Called Number=7185045765
000128: Mar  2 04:07:11.547: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
   Dial String=7185045765, Expanded String=7185045765, Calling Number=7185045765T
   Timeout=TRUE, Is Incoming=FALSE, Peer Info Type=DIALPEER_INFO_SPEECH
000129: Mar  2 04:07:11.551: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
   Result=-1
000130: Mar  2 04:07:11.551: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)
000131: Mar  2 04:07:11.551: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
   dialstring=7185045765, saf_enabled=1, saf_dndb_lookup=1, dp_result=-1
000132: Mar  2 04:07:11.551: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
   Result=NO_MATCH(-1)

3 Replies 3

Albert Wilhelm
Level 1
Level 1

Hello,

Can you tell me you have a firewall or router in front of your UC540? If you are, make sure SIP (port 5060) is getting forwarded to your UC540 external interface (fa0/0).

If you have that configured or your UC540 is the firewall, can you send me the following sections in your running config?

voice source-group CCA_SIP_SOURCE_GROUP_CUE_CME
 access-list 2
 translation-profile incoming SIP_Incoming
!
voice source-group CCA_SIP_SOURCE_GROUP_EXTERNAL

 

I have had this before when using NexVortex SIP trunk and I had to delete an access-list under the EXTERNAL section to allow SIP calls to come through.

Send me your section or post the whole config and I will take a look.

Thanks,

Bert

 

Thanks Albert, My uc540 outside is connected to Verizon Fios router and it does have FW function. I've already forwarded udp 5060 to uc540 outside but I still can't receive incoming call (only outgoing work). Here is my whole config,

 


UC540#show run
Building configuration...


Current configuration : 28340 bytes
!
! Last configuration change at 22:19:54 PST Mon Mar 2 2015 by cisco
!
version 15.1
parser config cache interface
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
service compress-config
service sequence-numbers
!
hostname UC540
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$ZB30$iiLdqYqzZ8xp6WGEdmBTr/
!
aaa new-model
!
!
aaa authentication login default local
!
!
!
!
!
aaa session-id common
!
clock timezone PST -8 0
clock summer-time PST recurring
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-4131793064
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-4131793064
 revocation-check none
!
!
crypto pki certificate chain TP-self-signed-4131793064
 certificate self-signed 01
  30820247 308201B0 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 34313331 37393330 3634301E 170D3135 30333033 30363130
  33345A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D34 31333137
  39333036 3430819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100C488 53D3FA6C 0159CF28 463F5962 6901976F 053AD3D2 776668EA 980E8B75
  C8291FE3 A550AF73 58EEB093 8F721FEB 119BF52B 4ED1F018 7AD0A990 3B218D1D
  007D6E68 1BB8B5D1 ED997412 9FB6F2C2 D9C23339 7BC2555C 71FFF7B9 89A2AF98
  CB458935 1F7B3D73 31A52AEC C50BC6DB FE027B1F BF94D7D1 47A30BEC 3CC67F9C
  82790203 010001A3 6F306D30 0F060355 1D130101 FF040530 030101FF 301A0603
  551D1104 13301182 0F554335 34302E63 6973636F 2E636F6D 301F0603 551D2304
  18301680 1429A379 2B66CB06 79AECF48 F04CAE06 7896E62D E7301D06 03551D0E
  04160414 29A3792B 66CB0679 AECF48F0 4CAE0678 96E62DE7 300D0609 2A864886
  F70D0101 04050003 81810017 151419CA 2D0F3996 27D78D00 D099EB16 B2352B6F
  C217CE22 5DD85ECE F66AC7C0 86C14BD9 C0D0B0EC C6F561B5 5A9CE946 254201D6
  6E59FA97 1AD7C613 BF48492E F07FC624 1C5932C5 0EF717BF DEBE0408 48484B5F
  56E2F141 3C36870A 8BD64A2F E3277E48 E9CA3F01 BFD3B6F3 92E28E13 16DBA972
  7DB30CCC EDB43B6E 50C716
        quit
dot11 syslog
!
dot11 ssid cisco-data
 vlan 1
 authentication open
!
dot11 ssid cisco-voice
 vlan 100
 authentication open
!
ip source-route
ip cef
!
!
ip dhcp relay information trust-all
ip dhcp excluded-address 10.1.1.1 10.1.1.10
ip dhcp excluded-address 192.168.10.1 192.168.10.10
!
ip dhcp pool phone
   network 10.1.1.0 255.255.255.0
   default-router 10.1.1.1
   option 150 ip 10.1.1.1
!
ip dhcp pool data
   import all
   network 192.168.10.0 255.255.255.0
   default-router 192.168.10.1
!
!
!
ip domain name cisco.com
ip name-server 4.2.2.2
ip inspect WAAS flush-timeout 10
ip inspect name SDM_LOW cuseeme
ip inspect name SDM_LOW dns
ip inspect name SDM_LOW ftp
ip inspect name SDM_LOW h323
ip inspect name SDM_LOW https
ip inspect name SDM_LOW icmp
ip inspect name SDM_LOW imap
ip inspect name SDM_LOW pop3
ip inspect name SDM_LOW netshow
ip inspect name SDM_LOW rcmd
ip inspect name SDM_LOW realaudio
ip inspect name SDM_LOW rtsp
ip inspect name SDM_LOW esmtp
ip inspect name SDM_LOW sqlnet
ip inspect name SDM_LOW streamworks
ip inspect name SDM_LOW tftp
ip inspect name SDM_LOW tcp
ip inspect name SDM_LOW udp router-traffic
ip inspect name SDM_LOW vdolive
no ipv6 cef
!
multilink bundle-name authenticated
!
stcapp ccm-group 1
stcapp
!
!
!
!
voice call send-alert
voice rtp send-recv
!
voice service voip
 ip address trusted list
  ipv4 107.6.67.238
 ip address trusted call-block cause not-in-cug
 gcid
 clid substitute name
 allow-connections sip to sip
 no supplementary-service sip moved-temporarily
 no supplementary-service sip refer
 sip
  e911
  transport switch udp tcp
  asserted-id ppi
  localhost dns:mydomain.com
  no update-callerid
  midcall-signaling passthru
  no call service stop
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g729r8
!
!
!
!
voice translation-rule 1
 rule 1 /7185045765/ /601/
!
voice translation-rule 2
 rule 1 /^911$/ /911/
 rule 2 /^9\(.*\)/ /\1/
!
voice translation-rule 3
 rule 1 /^.*/ /7185045765/
!
voice translation-rule 4
 rule 1 /601/ /7185045765/
 rule 2 /^9\(.*\)/ /\1/
!
voice translation-rule 1000
 rule 1 /.*/ //
!
!
voice translation-profile CUE_AA
 translate called 1
!
voice translation-profile CUE_Voicemail/AutoAttendant
 translate called 1
!
voice translation-profile PSTN_CallForwarding
 translate redirect-target 4
 translate redirect-called 4
!
voice translation-profile PSTN_Outgoing
 translate calling 3
 translate called 2
 translate redirect-target 4
 translate redirect-called 4
!
voice translation-profile nondialable
 translate called 1000
!
!
voice-card 0
!
fax interface-type fax-mail
!
!
license udi pid UC540W-FXO-K9 sn FHK135071WU
archive
 log config
  logging enable
  logging size 600
  hidekeys
username cisco privilege 15 secret 5 $1$FsEO$ImvVoio3ICdmv313NEdoe1
!
!
ip tftp source-interface Loopback0
!
!
!
bridge irb
!
!
!
!
interface Loopback0
 description $FW_INSIDE$
 ip address 10.1.10.2 255.255.255.252
 ip access-group 101 in
 ip nat inside
 ip virtual-reassembly in
!
interface FastEthernet0/0
 description $FW_OUTSIDE$
 ip address 192.168.1.199 255.255.255.0
 ip access-group 104 in
 ip nat outside
 ip inspect SDM_LOW out
 ip virtual-reassembly in
 load-interval 30
 duplex auto
 speed auto
!
interface Integrated-Service-Engine0/0
 ip unnumbered Loopback0
 ip nat inside
 ip virtual-reassembly in
 service-module ip address 10.1.10.1 255.255.255.252
 service-module ip default-gateway 10.1.10.2
!
interface FastEthernet0/1/0
 switchport voice vlan 100
 macro description cisco-phone
 spanning-tree portfast
!
interface FastEthernet0/1/1
 switchport voice vlan 100
 macro description cisco-phone
 spanning-tree portfast
!
interface FastEthernet0/1/2
 switchport voice vlan 100
 macro description cisco-phone
 spanning-tree portfast
!
interface FastEthernet0/1/3
 switchport voice vlan 100
 macro description cisco-phone
 spanning-tree portfast
!
interface FastEthernet0/1/4
 switchport voice vlan 100
 macro description cisco-phone
 spanning-tree portfast
!
interface FastEthernet0/1/5
 switchport voice vlan 100
 macro description cisco-phone
 spanning-tree portfast
!
interface FastEthernet0/1/6
 switchport voice vlan 100
 macro description cisco-phone
 spanning-tree portfast
!
interface FastEthernet0/1/7
 switchport voice vlan 100
 macro description cisco-phone
 spanning-tree portfast
!
interface FastEthernet0/1/8
 switchport mode trunk
 switchport voice vlan 100
 macro description cisco-switch
!
interface Dot11Radio0/5/0
 no ip address
 !
 ssid cisco-data
 !
 ssid cisco-voice
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
 antenna receive right
 antenna transmit right
!
interface Dot11Radio0/5/0.1
 encapsulation dot1Q 1 native
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Dot11Radio0/5/0.100
 encapsulation dot1Q 100
 bridge-group 100
 bridge-group 100 subscriber-loop-control
 bridge-group 100 spanning-disabled
 bridge-group 100 block-unknown-source
 no bridge-group 100 source-learning
 no bridge-group 100 unicast-flooding
!
interface Vlan1
 no ip address
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface Vlan100
 no ip address
 bridge-group 100
 bridge-group 100 spanning-disabled
!
interface BVI1
 description $FW_INSIDE$
 ip address 192.168.10.1 255.255.255.0
 ip access-group 102 in
 ip nat inside
 ip virtual-reassembly in
!
interface BVI100
 description $FW_INSIDE$
 ip address 10.1.1.1 255.255.255.0
 ip access-group 103 in
 ip nat inside
 ip virtual-reassembly in
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
ip http path flash:/gui
ip dns server
ip nat inside source list 1 interface FastEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip route 10.1.10.1 255.255.255.255 Integrated-Service-Engine0/0
!
logging esm config
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 10.1.1.0 0.0.0.255
access-list 1 permit 192.168.10.0 0.0.0.255
access-list 1 permit 10.1.10.0 0.0.0.3
access-list 100 remark auto generated by SDM firewall configuration
access-list 100 remark SDM_ACL Category=1
access-list 100 deny   ip 192.168.10.0 0.0.0.255 any
access-list 100 deny   ip host 255.255.255.255 any
access-list 100 deny   ip 127.0.0.0 0.255.255.255 any
access-list 100 permit ip any any
access-list 101 remark auto generated by SDM firewall configuration
access-list 101 remark SDM_ACL Category=1
access-list 101 permit tcp 10.1.1.0 0.0.0.255 eq 2000 any
access-list 101 permit udp 10.1.1.0 0.0.0.255 eq 2000 any
access-list 101 deny   ip 192.168.10.0 0.0.0.255 any
access-list 101 deny   ip 10.1.1.0 0.0.0.255 any
access-list 101 deny   ip host 255.255.255.255 any
access-list 101 deny   ip 127.0.0.0 0.255.255.255 any
access-list 101 permit ip any any
access-list 102 remark auto generated by SDM firewall configuration
access-list 102 remark SDM_ACL Category=1
access-list 102 deny   ip 10.1.10.0 0.0.0.3 any
access-list 102 deny   ip 10.1.1.0 0.0.0.255 any
access-list 102 deny   ip host 255.255.255.255 any
access-list 102 deny   ip 127.0.0.0 0.255.255.255 any
access-list 102 permit ip any any
access-list 103 remark auto generated by SDM firewall configuration
access-list 103 remark SDM_ACL Category=1
access-list 103 permit tcp 10.1.10.0 0.0.0.3 any eq 2000
access-list 103 permit udp 10.1.10.0 0.0.0.3 any eq 2000
access-list 103 permit udp any 10.1.10.0 0.0.0.3 range 16384 32767
access-list 103 permit udp 10.1.10.0 0.0.0.3 range 16384 32767 any
access-list 103 deny   ip 192.168.10.0 0.0.0.255 any
access-list 103 deny   ip host 255.255.255.255 any
access-list 103 deny   ip 127.0.0.0 0.255.255.255 any
access-list 103 permit ip any any
access-list 104 remark auto generated by SDM firewall configuration
access-list 104 remark SDM_ACL Category=1
access-list 104 deny   ip 10.1.10.0 0.0.0.3 any
access-list 104 deny   ip 192.168.10.0 0.0.0.255 any
access-list 104 deny   ip 10.1.1.0 0.0.0.255 any
access-list 104 permit udp any eq bootps any eq bootpc
access-list 104 permit icmp any any echo-reply
access-list 104 permit icmp any any time-exceeded
access-list 104 permit icmp any any unreachable
access-list 104 deny   ip 10.0.0.0 0.255.255.255 any
access-list 104 deny   ip 172.16.0.0 0.15.255.255 any
access-list 104 deny   ip 192.168.0.0 0.0.255.255 any
access-list 104 deny   ip 127.0.0.0 0.255.255.255 any
access-list 104 deny   ip host 255.255.255.255 any
access-list 104 deny   ip any any
!
!
!
!
snmp-server community public RO
tftp-server flash:/phones/6901_6911/SCCP6911.9-0-2-0.loads alias SCCP6911.9-0-2-0.loads
tftp-server flash:/phones/6901_6911/SCCP6901.9-0-2-0.loads alias SCCP6901.9-0-2-0.loads
tftp-server flash:/phones/6901_6911/KNL6911SCCP.9-0-2-0.zz.sgn alias KNL6911SCCP.9-0-2-0.zz.sgn
tftp-server flash:/phones/6901_6911/KNL6901SCCP.9-0-2-0.zz.sgn alias KNL6901SCCP.9-0-2-0.zz.sgn
tftp-server flash:/phones/6901_6911/BFS6911SCCP.9-0-2-0.zz.sgn alias BFS6911SCCP.9-0-2-0.zz.sgn
tftp-server flash:/phones/6901_6911/APP6911SCCP.9-0-2-0.zz.sgn alias APP6911SCCP.9-0-2-0.zz.sgn
tftp-server flash:/phones/6901_6911/APP6901SCCP.9-0-2-0.zz.sgn alias APP6901SCCP.9-0-2-0.zz.sgn
tftp-server flash:/phones/69xx/SCCP69xx.8-5-4-0.loads alias SCCP69xx.8-5-4-0.loads
tftp-server flash:/phones/69xx/BOOT69xx.0-0-0-14.zz alias BOOT69xx.0-0-0-14.zz
tftp-server flash:/phones/69xx/DSP69xx.0-0-0-3.zz alias DSP69xx.0-0-0-3.zz
tftp-server flash:/phones/69xx/SCCP69xx.8-5-4-0.zz alias SCCP69xx.8-5-4-0.zz
tftp-server flash:/phones/521_524/cp524g-8-1-17.bin alias cp524g-8-1-17.bin
tftp-server flash:/phones/525/spa525g-7-4-8.bin alias spa525g-7-4-8.bin
tftp-server flash:/phones/50x-30x/spa50x-30x-7-4-8a.bin alias spa50x-30x-7-4-8a.bin
tftp-server flash:/phones/7906_7911/apps11.8-5-4TH1-6.sbn alias apps11.8-5-4TH1-6.sbn
tftp-server flash:/phones/7906_7911/cnu11.8-5-4TH1-6.sbn alias cnu11.8-5-4TH1-6.sbn
tftp-server flash:/phones/7906_7911/cvm11sccp.8-5-4TH1-6.sbn alias cvm11sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7906_7911/dsp11.8-5-4TH1-6.sbn alias dsp11.8-5-4TH1-6.sbn
tftp-server flash:/phones/7906_7911/jar11sccp.8-5-4TH1-6.sbn alias jar11sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7906_7911/SCCP11.8-5-4S.loads alias SCCP11.8-5-4S.loads
tftp-server flash:/phones/7906_7911/term06.default.loads alias term06.default.loads
tftp-server flash:/phones/7906_7911/term11.default.loads alias term11.default.loads
tftp-server flash:/phones/7914/S00105000400.sbn alias S00105000400.sbn
tftp-server flash:/phones/7915/B015-1-0-4.SBN alias B015-1-0-4.SBN
tftp-server flash:/phones/7916/B016-1-0-4.SBN alias B016-1-0-4.SBN
tftp-server flash:/phones/7921/APPS-1.3.4SR1.SBN alias APPS-1.3.4SR1.SBN
tftp-server flash:/phones/7921/CP7921G-1.3.4SR1.LOADS alias CP7921G-1.3.4SR1.LOADS
tftp-server flash:/phones/7921/GUI-1.3.4SR1.SBN alias GUI-1.3.4SR1.SBN
tftp-server flash:/phones/7921/MISC-1.3.4SR1.SBN alias MISC-1.3.4SR1.SBN
tftp-server flash:/phones/7921/SYS-1.3.4SR1.SBN alias SYS-1.3.4SR1.SBN
tftp-server flash:/phones/7921/TNUX-1.3.4SR1.SBN alias TNUX-1.3.4SR1.SBN
tftp-server flash:/phones/7921/WLAN-1.3.4SR1.SBN alias WLAN-1.3.4SR1.SBN
tftp-server flash:/phones/7925/APPSH-1.3.4SR1.SBN alias APPSH-1.3.4SR1.SBN
tftp-server flash:/phones/7925/CP7925G-1.3.4SR1.LOADS alias CP7925G-1.3.4SR1.LOADS
tftp-server flash:/phones/7925/GUIH-1.3.4SR1.SBN alias GUIH-1.3.4SR1.SBN
tftp-server flash:/phones/7925/MISCH-1.3.4SR1.SBN alias MISCH-1.3.4SR1.SBN
tftp-server flash:/phones/7925/SYSH-1.3.4SR1.SBN alias SYSH-1.3.4SR1.SBN
tftp-server flash:/phones/7925/TNUXH-1.3.4SR1.SBN alias TNUXH-1.3.4SR1.SBN
tftp-server flash:/phones/7925/WLANH-1.3.4SR1.SBN alias WLANH-1.3.4SR1.SBN
tftp-server flash:/phones/7931/apps31.8-5-4TH1-6.sbn alias apps31.8-5-4TH1-6.sbn
tftp-server flash:/phones/7931/cnu31.8-5-4TH1-6.sbn alias cnu31.8-5-4TH1-6.sbn
tftp-server flash:/phones/7931/cvm31sccp.8-5-4TH1-6.sbn alias cvm31sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7931/dsp31.8-5-4TH1-6.sbn alias dsp31.8-5-4TH1-6.sbn
tftp-server flash:/phones/7931/jar31sccp.8-5-4TH1-6.sbn alias jar31sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7931/SCCP31.8-5-4S.loads alias SCCP31.8-5-4S.loads
tftp-server flash:/phones/7931/term31.default.loads alias term31.default.loads
tftp-server flash:/phones/7936/cmterm_7936.3-3-20-0.bin alias cmterm_7936.3-3-20-0.bin
tftp-server flash:/phones/7937/apps37sccp.1-3-4-0.bin alias apps37sccp.1-3-4-0.bin
tftp-server flash:/phones/7940_7960/P00308010200.bin alias P00308010200.bin
tftp-server flash:/phones/7940_7960/P00308010200.loads alias P00308010200.loads
tftp-server flash:/phones/7940_7960/P00308010200.sb2 alias P00308010200.sb2
tftp-server flash:/phones/7940_7960/P00308010200.sbn alias P00308010200.sbn
tftp-server flash:/phones/7941_7961/apps41.8-5-4TH1-6.sbn alias apps41.8-5-4TH1-6.sbn
tftp-server flash:/phones/7941_7961/cnu41.8-5-4TH1-6.sbn alias cnu41.8-5-4TH1-6.sbn
tftp-server flash:/phones/7941_7961/cvm41sccp.8-5-4TH1-6.sbn alias cvm41sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7941_7961/dsp41.8-5-4TH1-6.sbn alias dsp41.8-5-4TH1-6.sbn
tftp-server flash:/phones/7941_7961/jar41sccp.8-5-4TH1-6.sbn alias jar41sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7941_7961/SCCP41.8-5-4S.loads alias SCCP41.8-5-4S.loads
tftp-server flash:/phones/7941_7961/term41.default.loads alias term41.default.loads
tftp-server flash:/phones/7941_7961/term61.default.loads alias term61.default.loads
tftp-server flash:/phones/7942_7962/apps42.8-5-4TH1-6.sbn alias apps42.8-5-4TH1-6.sbn
tftp-server flash:/phones/7942_7962/cnu42.8-5-4TH1-6.sbn alias cnu42.8-5-4TH1-6.sbn
tftp-server flash:/phones/7942_7962/cvm42sccp.8-5-4TH1-6.sbn alias cvm42sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7942_7962/dsp42.8-5-4TH1-6.sbn alias dsp42.8-5-4TH1-6.sbn
tftp-server flash:/phones/7942_7962/jar42sccp.8-5-4TH1-6.sbn alias jar42sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7942_7962/SCCP42.8-5-4S.loads alias SCCP42.8-5-4S.loads
tftp-server flash:/phones/7942_7962/term42.default.loads alias term42.default.loads
tftp-server flash:/phones/7942_7962/term62.default.loads alias term62.default.loads
tftp-server flash:/phones/7945_7965/apps45.8-5-4TH1-6.sbn alias apps45.8-5-4TH1-6.sbn
tftp-server flash:/phones/7945_7965/cnu45.8-5-4TH1-6.sbn alias cnu45.8-5-4TH1-6.sbn
tftp-server flash:/phones/7945_7965/cvm45sccp.8-5-4TH1-6.sbn alias cvm45sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7945_7965/dsp45.8-5-4TH1-6.sbn alias dsp45.8-5-4TH1-6.sbn
tftp-server flash:/phones/7945_7965/jar45sccp.8-5-4TH1-6.sbn alias jar45sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7945_7965/SCCP45.8-5-4S.loads alias SCCP45.8-5-4S.loads
tftp-server flash:/phones/7945_7965/term45.default.loads alias term45.default.loads
tftp-server flash:/phones/7945_7965/term65.default.loads alias term65.default.loads
tftp-server flash:/phones/7970_7971/apps70.8-5-4TH1-6.sbn alias apps70.8-5-4TH1-6.sbn
tftp-server flash:/phones/7970_7971/cnu70.8-5-4TH1-6.sbn alias cnu70.8-5-4TH1-6.sbn
tftp-server flash:/phones/7970_7971/cvm70sccp.8-5-4TH1-6.sbn alias cvm70sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7970_7971/dsp70.8-5-4TH1-6.sbn alias dsp70.8-5-4TH1-6.sbn
tftp-server flash:/phones/7970_7971/jar70sccp.8-5-4TH1-6.sbn alias jar70sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7970_7971/SCCP70.8-5-4S.loads alias SCCP70.8-5-4S.loads
tftp-server flash:/phones/7970_7971/term70.default.loads alias term70.default.loads
tftp-server flash:/phones/7970_7971/term71.default.loads alias term71.default.loads
tftp-server flash:/phones/7975/apps75.8-5-4TH1-6.sbn alias apps75.8-5-4TH1-6.sbn
tftp-server flash:/phones/7975/cnu75.8-5-4TH1-6.sbn alias cnu75.8-5-4TH1-6.sbn
tftp-server flash:/phones/7975/cvm75sccp.8-5-4TH1-6.sbn alias cvm75sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7975/dsp75.8-5-4TH1-6.sbn alias dsp75.8-5-4TH1-6.sbn
tftp-server flash:/phones/7975/jar75sccp.8-5-4TH1-6.sbn alias jar75sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7975/SCCP75.8-5-4S.loads alias SCCP75.8-5-4S.loads
tftp-server flash:/phones/7975/term75.default.loads alias term75.default.loads
tftp-server flash:/ringtones/Analog1.raw alias Analog1.raw
tftp-server flash:/ringtones/Analog2.raw alias Analog2.raw
tftp-server flash:/ringtones/AreYouThere.raw alias AreYouThere.raw
tftp-server flash:/ringtones/DistinctiveRingList.xml alias DistinctiveRingList.xml
tftp-server flash:/ringtones/RingList.xml alias RingList.xml
tftp-server flash:/ringtones/AreYouThereF.raw alias AreYouThereF.raw
tftp-server flash:/ringtones/Bass.raw alias Bass.raw
tftp-server flash:/ringtones/CallBack.raw alias CallBack.raw
tftp-server flash:/ringtones/Chime.raw alias Chime.raw
tftp-server flash:/ringtones/Classic1.raw alias Classic1.raw
tftp-server flash:/ringtones/Classic2.raw alias Classic2.raw
tftp-server flash:/ringtones/ClockShop.raw alias ClockShop.raw
tftp-server flash:/ringtones/Drums1.raw alias Drums1.raw
tftp-server flash:/ringtones/Drums2.raw alias Drums2.raw
tftp-server flash:/ringtones/FilmScore.raw alias FilmScore.raw
tftp-server flash:/ringtones/HarpSynth.raw alias HarpSynth.raw
tftp-server flash:/ringtones/Jamaica.raw alias Jamaica.raw
tftp-server flash:/ringtones/KotoEffect.raw alias KotoEffect.raw
tftp-server flash:/ringtones/MusicBox.raw alias MusicBox.raw
tftp-server flash:/ringtones/Piano1.raw alias Piano1.raw
tftp-server flash:/ringtones/Piano2.raw alias Piano2.raw
tftp-server flash:/ringtones/Pop.raw alias Pop.raw
tftp-server flash:/ringtones/Pulse1.raw alias Pulse1.raw
tftp-server flash:/ringtones/Ring1.raw alias Ring1.raw
tftp-server flash:/ringtones/Ring2.raw alias Ring2.raw
tftp-server flash:/ringtones/Ring3.raw alias Ring3.raw
tftp-server flash:/ringtones/Ring4.raw alias Ring4.raw
tftp-server flash:/ringtones/Ring5.raw alias Ring5.raw
tftp-server flash:/ringtones/Ring6.raw alias Ring6.raw
tftp-server flash:/ringtones/Ring7.raw alias Ring7.raw
tftp-server flash:/ringtones/Sax1.raw alias Sax1.raw
tftp-server flash:/ringtones/Sax2.raw alias Sax2.raw
tftp-server flash:/ringtones/Vibe.raw alias Vibe.raw
tftp-server flash:/Desktops/CampusNight.png
tftp-server flash:/Desktops/TN-CampusNight.png
tftp-server flash:/Desktops/CiscoFountain.png
tftp-server flash:/Desktops/TN-CiscoFountain.png
tftp-server flash:/Desktops/CiscoLogo.png
tftp-server flash:/Desktops/TN-CiscoLogo.png
tftp-server flash:/Desktops/Fountain.png
tftp-server flash:/Desktops/TN-Fountain.png
tftp-server flash:/Desktops/MorroRock.png
tftp-server flash:/Desktops/TN-MorroRock.png
tftp-server flash:/Desktops/NantucketFlowers.png
tftp-server flash:/Desktops/TN-NantucketFlowers.png
tftp-server flash:Desktops/320x212x16/List.xml
tftp-server flash:Desktops/320x212x12/List.xml
tftp-server flash:Desktops/320x216x16/List.xml
tftp-server flash:/bacdprompts/en_bacd_allagentsbusy.au alias en_bacd_allagentsbusy.au
tftp-server flash:/bacdprompts/en_bacd_disconnect.au alias en_bacd_disconnect.au
tftp-server flash:/bacdprompts/en_bacd_enter_dest.au alias en_bacd_enter_dest.au
tftp-server flash:/bacdprompts/en_bacd_invalidoption.au alias en_bacd_invalidoption.au
tftp-server flash:/bacdprompts/en_bacd_music_on_hold.au alias en_bacd_music_on_hold.au
tftp-server flash:/bacdprompts/en_bacd_options_menu.au alias en_bacd_options_menu.au
tftp-server flash:/bacdprompts/en_bacd_welcome.au alias en_bacd_welcome.au
tftp-server flash:/bacdprompts/en_bacd_xferto_operator.au alias en_bacd_xferto_operator.au
radius-server attribute 31 send nas-port-detail
!
!
control-plane
!
bridge 1 route ip
bridge 100 route ip
!
voice-port 0/0/0
 timeouts ringing infinity
 caller-id enable
!
voice-port 0/0/1
 timeouts ringing infinity
 caller-id enable
!
voice-port 0/0/2
 timeouts ringing infinity
 caller-id enable
!
voice-port 0/0/3
 timeouts ringing infinity
 caller-id enable
!
voice-port 0/1/0
 connection plar 201
 caller-id enable
!
voice-port 0/1/1
 connection plar 202
 caller-id enable
!
voice-port 0/1/2
 connection plar 203
 caller-id enable
!
voice-port 0/1/3
 connection plar 204
 caller-id enable
!
voice-port 0/4/0
 auto-cut-through
 signal immediate
 input gain auto-control -15
 description Music On Hold Port
!
sccp local Loopback0
sccp ccm 10.1.1.1 identifier 1 version 3.1
sccp
!
sccp ccm group 1
 associate ccm 1 priority 1
!
dial-peer voice 1 pots
 service stcapp
 port 0/0/0
!
dial-peer voice 2 pots
 service stcapp
 port 0/0/1
!
dial-peer voice 3 pots
 service stcapp
 port 0/0/2
!
dial-peer voice 4 pots
 service stcapp
 port 0/0/3
!
dial-peer voice 5 pots
 description ** MOH Port **
 destination-pattern ABC
 port 0/4/0
 no sip-register
!
dial-peer voice 50 pots
 destination-pattern 9T
 port 0/1/0
 no sip-register
!
dial-peer voice 51 pots
 destination-pattern 9T
 port 0/1/1
 no sip-register
!
dial-peer voice 52 pots
 destination-pattern 9T
 port 0/1/2
 no sip-register
!
dial-peer voice 53 pots
 destination-pattern 9T
 port 0/1/3
 no sip-register
!
dial-peer voice 2002 voip
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9[2-9]..[2-9]......
 session protocol sipv2
 session target ipv4:107.6.67.238
 no voice-class sip early-offer forced
 dtmf-relay rtp-nte cisco-rtp sip-kpml sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 2003 voip
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 91[2-9]..[2-9]......
 session protocol sipv2
 session target ipv4:107.6.67.238
 no voice-class sip early-offer forced
 dtmf-relay rtp-nte cisco-rtp sip-kpml sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 2004 voip
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 911
 session protocol sipv2
 session target ipv4:107.6.67.238
 no voice-class sip early-offer forced
 dtmf-relay rtp-nte cisco-rtp sip-kpml sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 2005 voip
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9911
 session protocol sipv2
 session target ipv4:107.6.67.238
 no voice-class sip early-offer forced
 dtmf-relay rtp-nte cisco-rtp sip-kpml sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 2006 voip
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9[2-9]11
 session protocol sipv2
 session target ipv4:107.6.67.238
 no voice-class sip early-offer forced
 dtmf-relay rtp-nte cisco-rtp sip-kpml sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 2007 voip
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9011T
 session protocol sipv2
 session target ipv4:107.6.67.238
 no voice-class sip early-offer forced
 dtmf-relay rtp-nte cisco-rtp sip-kpml sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 2008 voip
 translation-profile incoming CUE_AA
 session protocol sipv2
 session target ipv4:107.6.67.238
 incoming called-number .%
 dtmf-relay cisco-rtp rtp-nte
 codec g711ulaw
!
!
no dial-peer outbound status-check pots
sip-ua
 credentials username xxxxx password 7 xxxxx realm newyork4.voip.ms
 authentication username xxxxx password 7 xxxxx realm newyork4.voip.ms
 registrar 1 dns:newyork4.voip.ms expires 300
!
!
!
telephony-service
 video
 fxo hook-flash
 max-ephones 40
 max-dn 300
 ip source-address 10.1.1.1 port 2000
 auto assign 1 to 1 type bri
 calling-number initiator
 service phone videoCapability 1
 service phone ehookenable 1
 service dnis overlay
 service dnis dir-lookup
 service dss
 timeouts interdigit 5
 system message UC540
 load 7914 S00105000400
 load 7915-12 B015-1-0-4
 load 7915-24 B015-1-0-4
 load 7916-12 B016-1-0-4
 load 7916-24 B016-1-0-4
 load 7906 SCCP11.8-5-4S
 load 7911 SCCP11.8-5-4S
 load 7921 CP7921G-1.3.4SR1
 load 7925 CP7925G-1.3.4SR1
 load 7931 SCCP31.8-5-4S
 load 7936 cmterm_7936.3-3-20-0
 load 7937 apps37sccp.1-3-4-0
 load 7960-7940 P00308010200
 load 7941 SCCP41.8-5-4S
 load 7941GE SCCP41.8-5-4S
 load 7942 SCCP42.8-5-4S
 load 7945 SCCP45.8-5-4S
 load 7961 SCCP41.8-5-4S
 load 7961GE SCCP41.8-5-4S
 load 7962 SCCP42.8-5-4S
 load 7965 SCCP45.8-5-4S
 load 7970 SCCP70.8-5-4S
 load 7971 SCCP70.8-5-4S
 load 7975 SCCP75.8-5-4S
 load 521G-524G cp524g-8-1-17
 load 525G spa525g-7-4-8
 load 501G spa50x-30x-7-4-8a
 load 502G spa50x-30x-7-4-8a
 load 504G spa50x-30x-7-4-8a
 load 508G spa50x-30x-7-4-8a
 load 509G spa50x-30x-7-4-8a
 load 525G2 spa525g-7-4-8
 load 301 spa50x-30x-7-4-8a
 load 303 spa50x-30x-7-4-8a
 load 6921 SCCP69xx.8-5-4-0
 load 6941 SCCP69xx.8-5-4-0
 load 6961 SCCP69xx.8-5-4-0
 load 6901 SCCP6901.9-0-2-0
 load 6911 SCCP6911.9-0-2-0
 time-zone 5
 keepalive 30 auxiliary 4
 max-conferences 8 gain -6
 call-forward pattern .T
 call-forward system redirecting-expanded
 moh flash:/media/music-on-hold.au
 multicast moh 239.10.16.16 port 2000
 web admin system name cisco secret 5 $1$Pl7I$Ia39YyGN1BQrTM3rnXZlq1
 dn-webedit
 time-webedit
 transfer-system full-consult dss
 transfer-pattern 9.T
 transfer-pattern .T
 secondary-dialtone 9
 night-service day Sun 17:00 09:00
 night-service day Mon 17:00 09:00
 night-service day Tue 17:00 09:00
 night-service day Wed 17:00 09:00
 night-service day Thu 17:00 09:00
 night-service day Fri 17:00 09:00
 night-service day Sat 17:00 09:00
 fac standard
 create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-template  15
 button-layout 7931 2
!
!
ephone-dn  9
 number BCD no-reg primary
 description MoH
 moh out-call ABC
!
!
ephone-dn  61  dual-line
 number 601 no-reg primary
!
!
ephone  1
 device-security-mode none
 mac-address 699E.1286.0000
 max-calls-per-button 2
 type anl
!
!
!
ephone  2
 device-security-mode none
 mac-address 699E.1286.0001
 max-calls-per-button 2
 type anl
!
!
!
ephone  3
 device-security-mode none
 mac-address 699E.1286.0002
 max-calls-per-button 2
 type anl
!
!
!
ephone  4
 device-security-mode none
 mac-address 699E.1286.0003
 max-calls-per-button 2
 type anl
!
!
!
ephone  6
 device-security-mode none
 mac-address 0007.0E56.EABF
 type 7961
 button  1:61
!
!
banner login ^CUC500 Base Config - Manufacturing 8.2.0 ^C
!
line con 0
 no modem enable
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
line vty 0 4
 transport preferred none
 transport input all
line vty 5 100
 transport preferred none
 transport input all
!
ntp master
end

UC540#
UC540#
UC540#
UC540#debu
UC540#debug vo
UC540#debug voip di
UC540#debug voip dialpeer de
UC540#debug voip dialpeer ? 
  all       Enable all debugs
  default   Enable default debugs
  detail    detail debug
  error     major call and software errors debug
  function  function debug
  inout     inout debug
  <cr>

UC540#debug voip dialpeer det
UC540#debug voip dialpeer detail
voip dialpeer detail debugging is on
UC540#
000210: Mar  3 06:41:17.930: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
   Dial String=7185045765, Expanded String=7185045765, Calling Number=7185045765T
   Timeout=TRUE, Is Incoming=FALSE, Peer Info Type=DIALPEER_INFO_SPEECH
000211: Mar  3 06:41:17.930: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
   Result=-1
UC540#
UC540#
000212: Mar  3 06:41:42.647: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
   Dial String=7185045765, Expanded String=7185045765, Calling Number=7185045765T
   Timeout=TRUE, Is Incoming=FALSE, Peer Info Type=DIALPEER_INFO_SPEECH
000213: Mar  3 06:41:42.647: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
   Result=-1
UC540#
UC540#    

Ok, I found something interesting. In my Verizon Fios router there is a "SIP ALG" option, when it's enable. I can receive incoming call (finally) but can't make outgoing call. When it's disable, I can make outgoing call but can't receive incoming call.

I tried to use TCP as SIP session transport instead of UDP but there's no help.

Does anyone experience the same issue I have, is it a solution or workaround for that? 

What is "SIP ALG" and how it work?