Showing results for 
Search instead for 
Did you mean: 

SPA2102 Firmware Upgrade Fails?


I have been unable to update the firmware to version 5-2-12 (it currently has software version 3.3.6).  I go through the steps, getting the IP using ****110# and entering it, and I immediately get a response "Upgrade Failed:Can't connect to SPA".  I do have it connected, as I can access it using  On the Provisioning page, Firmware Upgrade is set to Yes and Upgrade Rule is blank.  I have tried to upgrade using three different computers, an XP, a Vista, and a 7, with the same result.

Any ideas on what the problem is?

5 Replies 5

Frequent Contributor
Frequent Contributor

Have you tried the other firmware versions available on  5.2.3 or 5.2.5? 

If those also fail, you'll need to run debug log to see what's going on.  Info on doing that at

I tried 5.2.10 and 5.2.3, without success.  The response I get has changed slightly to "Upgrade Failed:No response from SPA".

I have syslog running, and the file is growing rapidly with entries every few seconds of 10 to 15 lines.  I can't make much sense of them, but there did not appear to be anything relevant after attempts to upgrade the firmware.

What should I be looking for in the syslog file?  Any other suggestions?


Would following the steps outlined in this blog tutorial help clarify where the problem lies?

Thank you Jeff!!  I finally succeeded in updating the firmware.  Your blog said to use ****210# to get the required IP address, which gives back  , and that is what worked.  The firmware upgrade program directs you to use ****110# but that IP would not work for me.

The upgrade would still not work even with this IP address with my Vista machine and with Windows Firewall shut off as well as all the real-time shields in Avast shut off.  As a last resort I tried a fourth computer, an old Windows 2000 system that had not been running in about 6 years.  It did the trick - possibly due to less security on it.

Thanks again to both of you.  I hope that I do not have to upgrade the firmware again, as I'm not sure whether the old computer is up to it.

I had the same issue, turns out it was my anti-virus software that was interfering with the process.  Whether I used the IP address that is provided when you do **** 110#, or 210#, in both cases it failed.  Once I disabled my anti-virus, I was able to complete the firmware upgrade using the 110# IP address.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers