cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
77940
Views
5
Helpful
10
Replies

AnyConnect failing on MacOS 10.16 (11 or Big Sur)

Getting this failure a few seconds after connecting to our vpn. Has worked in previous versions of MacOS.

"The VPN client agent's DNS component experienced an unexpected error. The VPN connection has been disconnected. Please restart your computer or device, then try again. 

I did that twice, still get the same error.

1 ACCEPTED SOLUTION

Accepted Solutions
Ruslan Ivanov
Cisco Employee

10 REPLIES 10
jasone011
Beginner

I ran into this also.

 

My work around:

Install 4.3 (Not supported, but just go ahead and run it)

Then install (upgrade to) 4.7 

 

This works, no longer getting the error.

 

Hope this helps.

This workaround does not work for me. I've also tried different versions, including a 4.9 version I found and that fails as well (during installation). Any other ideas?

The latest AnyConnect Client version 4.9.0.02028 (anyconnect-macos-4.9.02028) fixed the problem for me. You should give it a try.


@hisaac wrote:

Here's the workaround that worked for me:

  1. Wipe and reinstall Big Sur*
  2. Once you get computer setup and booted, restart computer into recovery mode
  3. Disable SIP by running csrutil disable in Terminal
  4. Restart computer into normal mode (not recovery mode)
  5. Open Terminal, and run sudo touch /Library/DriverExtensions
  6. Install AnyConnect
  7. Approve extensions in System Preferences when prompted, and then restart.
  8. VPN should be working once you boot back in!

*Step 1 may or may not be necessary. I know of others who have not needed to wipe and reinstall, but I needed to do it to fix the issue on my machine.


Thanks very much for sharing. Disabling SIP (step 3) did it for me. I did not have to re-install the OS, just the app. I tried re-enabling it afterwards and broke it again. Had to repeat the process. So had to leave SIP disabled for now until a newer release is supported. Thanks again.

It worked for me too. I didn't wipe my machine, so I begun on step 2, but really worked! Thank you!

Thank you very much for the guide. but, as soon as I have VPN Cisco launched, it starts to update itself and after that it shows up error again that it can not connect to VPN and failed. 

As of the newer betas, the steps provided above should no longer be necessary. I've tested on the recently released beta 6, and installation worked as expected.

Ruslan Ivanov
Cisco Employee

I just talked to support and they pointed me to the community to get the latest version of AnyConnect (anyconnect-macos-4.9.04043-predeploy-k9.dmg)... yeah, they wouldn't help get an updated version from the website, but they suggested I ask someone here for it.