Showing results for 
Search instead for 
Did you mean: 

Anyconnect install problem


                  We are seeing an install problem with the AnyConnect Secure Mobility Client under Windows 7. The installer stalls after a minute or so then reports:

There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected.

There has been no other install issue on these machines and we have reinstalled Windows 7 to insure that the Installer is robust.

Please advise.

D Miller

16 Replies 16

Marvin Rhoads
Hall of Fame Community Legend Hall of Fame Community Legend
Hall of Fame Community Legend

How are you deploying? Pre-deployment using the installer in the ISO file (anyconnect-win-3.1.01065-pre-deploy-k9.iso) or via a pkg file (anyconnect-win-3.1.01065-k9.pkg) from the ASA?

I've used both successfully on Windows 7 clients.

Just running the downloadable exe on a local machine. Any thoughts on a workaround?


Marvin Rhoads
Hall of Fame Community Legend Hall of Fame Community Legend
Hall of Fame Community Legend

Which file are you using specifically? The current AnyConnect pre-deploy file for VPN clients is not an .exe - it is an .msi file:


...which is extracted from the .iso (anyconnect-win-3.1.01065-pre-deploy-k9.iso) available for download from here.

Yes, sorry. We have that MSI file - it also hangs up right after reporting "installing services"  then backs out and quits. Same message as with the earlier 3.0. Very frustrating.

Please let me know if you have any other suggestions.



Hi Dennis,

Do you disable any FW / AV during this test?

Are you doing it as an Administrator?

How many computers experience the issue? Same configuration?

What if you try through the WebVPN portal?

Please try the silent installation:

"msiexec /i specific_AnyConnect.msi /norestart /quiet /lvx* install-log.txt"

Let us know.



Please rate any helpful posts

I am also having this same issue since upgrading from XP to Win7 and the quiet install isn't working.

anyconnect-win-3.0.5080-web-deploy-k9.exe is the stand alone I download after the web-based install fails.

Experiencing the same issue here. Running Windows 7 x64 and am an administrator. I have checked the registry for the RunOnce key and confirmed it is there. I have also tried running the installer silently with the same result.

Trying to install 3.0.5080 msi.

Same problem here on Windows 8 with anyconnect-win-3.1.02026-pre-deploy-k9.msi.

I ran "msiexec /i anyconnect-win-3.1.02026-pre-deploy-k9.msi /norestart /quiet /lvx* install-log.txt"

The results can be found here:

Any help is appreciated.

I am having same issue. Please find attached log file. Any help on this would be highly appreciated


I ran into a similar issue installing anyconnect 2.5 a while back and installing it with a NOISNTALLACTIVEX=1 at a CMD line resolved it.  Perhaps this will work for 3.0 as well

msiexec /i anyconnect-win-x.x.x-pre-deploy-k9.msi NOINSTALLACTIVEX=1


Has anyone resolved this issue.. seems i can install 2.5 versions but every newer vers 3.0 and up Fails at the same Point.


Hi All,

Even i get the same error messge. kindly suggest and help.

Team - I have been having the same issue of not being able to install on Windows 7. It gives the same install error. Any final resolution? Thank you