Showing results for 
Search instead for 
Did you mean: 

Anyconnect re-install on Windows 10 Hanging

Level 1
Level 1

I am posting this as a solution as I saw many registry related solutions that did not work but this approach did.  This is two parts A) Getting a reinstll to work on Windows 10.  B) Getting the Windows 10 install to work. 


-User upgraded to windows 10 without uninstalling Anyconnect first.

-Uninstall anyconnect after upgrade reports no error

-Reinstall will not complete and will post error to event log:

Product: Cisco AnyConnect Secure Mobility Client -- Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.  Action VACon64_ndis6_Install, location: C:\Program Files (x86)\Cisco\Cisco AnyConnect Secure Mobility Client\VACon64.exe, command: -install "C:\Program Files (x86)\Cisco\Cisco AnyConnect Secure Mobility Client\\vpnva-6.inf" VPNVA 


PART A:  Getting the re-install to work

Issue and solution (In this case):

There is a directory that contains driver libraries.  If they are present the installer uses old ones and the service will not register and will roll back the installation.  Delete the registry store (using pnputil NOT through the file system directly).


Resolution Steps (Assuming you are trying to install the Windows 10 compatible versions of anyconnect issued after 7/22/2015)

1) See if this is your problem

a) Uninstall Anyconnect

b) Navigate to >> Windows\System32\DriverStore\FileRepository  see if you have a directory named vpnva-6.inf_amd64_....

If this directory has any file older than 7/22/2015 then this is causing your install to fail.

c) Find the OEM###.INF file associated with this directory by looking in C:\Windows\inf\

Search for Anyconnect  you will find a section that reads

{Plug and Play Service: Device Install for ROOT\NET\0000}
     ndv:           Driver INF Path: C:\WINDOWS\INF\oem24.inf
     ndv:           Driver Node Name: vpnva-6.inf:573bd3b1d858e0ac:Cisco.ndi.NTamd64:3.1.6019.0:vpnva
     ndv:           Driver Store Path: C:\WINDOWS\System32\DriverStore\FileRepository\vpnva-6.inf_amd64_f4ee011be27e2804\vpnva-6.inf

Note the "oem24.inf" file in this case

Delete this driver store:

i) Open a cmd box as Administrator

ii)  For safety you can double check you have the right oem file by piping the following output to a text file and reviewing the entry for oem24.inf (or whatever your file is).  The entry in the text file you create should say that it is from Cisco and that the driver with oem##.inf is a network adapter.

pnputil -e > c:\driver_data.txt

iii) Delete the driver store (after you verified you have the right oem file).

pnputil -d oem24.inf

you should get "Driver package delete successfully"

Your installation will now complete (if this was the big issue.  I already tried all the registry related issues before this in other responses).

Part B: Getting the installation to work  (this section is courtesy of andrew oracle on technet)

1) Upgraded to latest version of AnyConnect (3.1.05182) from Cisco
2) Changed registry entry HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\vpnva\DisplayName string to “Cisco AnyConnect VPN Virtual Miniport Adapter for Windows x64″
3) Navigate to Cisco Install folder
4) Right-click vpnagent.exe and select properties
5) Navigate to the compatibility tab
6) Click "Change Settings for All Users" (the vpnagent.exe runs as a service under the LocalSystem context)
7) Change compatibility mode to Windows 8
8) Click OK
9) Click OK
10) Right-click vpnui.exe and select properties
11) Navigate to the compatibility tab
12) Click "Change Settings for All Users"
13) Change compatibility mode to Windows 8
14) Click OK
15) Click OK
16) Restart "Cisco AnyConnect Secure Mobility Agent for Windows" service

I am now able to connect to VPN without issue. Huzzah!

  • Proposed as answer by Andrew Oracle Thursday, October 02, 2014 3:04 PM


I was finally back in business!


28 Replies 28

Level 1
Level 1


As an additional note when the pnputil -d completes successfully your bad driver directory should be gone.

Hi there,

for me the solution was to remove the Kaspersky NDIS driver from the networkcard, after that all was working fine.




I theory that's great...  but...  I followed the Part A instructions carefully, and finally used command prompt (admin) and "net user administrator /active:yes" to make pnputil -d oem##.inf work.  The response was that it completed successfully.

I don't think so.  The particular oem72.inf (in my case 72) is gone but the system-controlled directory is still there.  The AnyConnect installer still hangs at the end, then rolls back, and now I can't even redo this procedure because the utility of course says that there's no such driver anymore.

Would you perhaps have any other ideas?  Any chance to remove the system access control from that directory and manually delete it now?



Level 1
Level 1



thank u for the great guide.


I have exactly the problems/symptoms u did mention.


Unfornunately when i try to use pnputil to remove the correct oem (oem44.inf in my case) i get the message that the driver package was deleted succesfully. But the bad driver directory is still in my system32 folder and the install is still stuck at the last part.

I did start cmd as admin.

Do you have any idea why this won't work for me?

Hello Madness,


I know the operating system does not like folks deleting from the DriverStore directories and security will back at you a lot.

I would double check the oem##.inf file.  If you use Cisco Webex or other products (ie. Cisco IP Communicator)  you will see very similar looking driver entries which is why it's important to check the 


I found using pnputil cleaned up the registry and directory in DriverStore tree.  If it had failed I would have tried manually deleting the driver entries and supporting registry keys (while growling about the Cisco intern that must have been assigned to create the installation and forgot these).  That would be my best guess.  Good luck.

Level 1
Level 1

The problems seems to be solely related to the upgrade process. I tried everything in this thread with no avail. Fortunately there was an easier path for me - I simply rolled back to Windows Restore Point before any of the Cisco Clients were installed earlier in the day and then installed only latest one. It worked like magic. Clearly this approach won't work for everybody.

Level 1
Level 1


I had anyconnect installed and working on windows 8.1, and after updating to windows 10, the first time (last week) I tried to log in to my VPN, anyconnect tried to update to 4.1.06020.

There was an install procedure, which towards the end failed with an error of:

"There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. ". 


The installer then rolls back- unfortunately for me the first attempt didn't roll back to my working version, but left me with out any working version.


I'm just an end user, trying to connect to a university. The university technical staff gave me a work around T2pt, but I would like to get anyconnect working if it doesn't take an undue amount of effort.


I followed the instruction above but nothing changed.

I've uninstalled any prior versions, deleted registry entries,  deleted folders from Cisco prior to trying to reinstall, and even tried to install Sonicwall (one post I came across suggested Anyconnect was missing something or other causing it to fail) etc. nothing seems to work.

The log file where the failure occurs tells me "Timed out waiting for device post-install to complete."

 From my searching, windows 10 seemed to cause plenty of problems for people (last year), but the version I have - 4.1.06020. doesn't seem to overcome the issue.

A solution would be appreciated.

I tried to post a new discussion, but was spam filtered, so am trying here.

The directions above worked fine for me.  Are you sure you removed the offending oem.inf driver store completely? E.g. is the directory gone after you ran pnputil successfully with Admin rights?

Yes, verified, again today.  used "pnputil -d oem##.inf" and both the file and the directory are removed, but the install fails. Everything was done with admin rights.

from the file the issue seems to be


ndv: Waiting for device post-install to complete. 22:06:43.447
!!! ndv: Timed out waiting for device post-install to complete. 22:10:43.462
ump: {Plug and Play Service: Device Install exit(000005b4)}
!!! ndv: Device install failed for device.
!!! ndv: Error 1460: This operation returned because the timeout period expired.

I, unfortunately, can't roll back, but am , perhaps foolishly, surprised this is such an issue. I don't have anything fancy going on with my system and... 


Level 1
Level 1

Hi there.  I have this exact problem so thank you for posting directions on how to get things working again.

I found the offending oem file but under the command prompt I am not able to delete the driver package using pnputil.  I get the following error "Deleting the driver package failed :access is denied".

This is my home computer that I have admin rights on so not sure why this error is occurring.  Does anyone know how I can get the appropriate access in Windows 10??

Guidance appreciated.

Got it.  Used Command Prompt (Admin) and "net user administrator /active:yes" to make pnputil -d oem##.inf work.  Worked like a charm and the install went fine.  All is now working the way it should.

Thanks again!

I've got the same issue as the one you describe but there is no file older than 22/07/2015 in my folder (there are three files from this very date and one from 2016)...

Level 1
Level 1

Just adding a kudos - this worked for me as of July 19, 2016 running a fully patched/updated version of Windows 10 (ver 10.0.10586). I was running version 3.1.07021 of AnyConnect and figured it was time to update to version 3.1.14018. Boy did I regret it afterwords. 

Until I found this post - thank you johnmotley!

I did not need to go any further than the removing of the proper inf driver and I went through steps 1 and 2 - but in step 2 I just deleted the entire registry folder:


Rebooted, re-ran the install for 3.1.14018 (using the .msi file) and all is well again, finally.

Had issues with the vpn adapter so I uninstalled Anyconnect.... and then I couldn't reinstall it.

Can't tell if it was entirely this that solved it for me, or what exactly did it, because after 3-4 hours I've tried a lot of different solutions on the internet.. Deleting temp-folders.. running different microsoft clean-up tools.. repairing msi-installer etc.

However this was the last thing I had to try before it worked. Like dnibbelink writes,

1. Update the drivers, (Part A)

2. Delete the registry folder,

3. Restart system,

4. Run installer (anyconnect-win-3.1.14018-web-deploy-k9.exe),

5. Run Anyconnect and "for some reason" everything worked.

I'm on a fully updated windows 10, version 1607(build 14393.222)

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: