You should verify with your ISP that you do have a Static IP Address, if not you will need to purchase one through the ISP.
Basic configuration of the ASA 5505 should look similiar to this:
interface Vlan1
nameif inside
security-level 100
ip address 192.168.0.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 24.x.x.x 255.255.255.248
!
interface Ethernet0/0
switchport access vlan 2
!
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 24.x.x.x 1
First and foremost you need to contact your ISP and verify that you do have a static IP address.
This is stripped down and your configuration will need changed to suit your needs. If you are new to configuring the ASA, I would recommend using the ASDM. The Startup Wizard will quickly get you connected to the internet.