cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
349
Views
0
Helpful
3
Replies
Highlighted
Beginner

WSA S390 AsyncOS upgrades keep failing

Hi All,

 

We have had updates pending on two of our S390 appliances since the middle of last year, this count has now gone up to three.

The updates available are:


AsynsOS 11.8.0 build 453 upgrade for Web, 2019-12-17, release available for General Deployment
AsynsOS 11.7.1 build 020 upgrade for Web, 2019-11-27, release available for Maintenance Deployment
AsynsOS 11.7.1 build 006 upgrade for Web, 2019-10-12, release available for Maintenance Deployment

 

We are currently stuck on 11.7.0-418 as all of these available updates keep failing.

I have attempted to install all three of these updates via both GUI and CLI, a combination of downloading via GUI and and completing the install via CLI but nothing seems to work.

Every time I attempt the update it comes up with "zcat: can't stat: .gz: No such file or directory. Do you wish to proceed with the upgrade?"
At that point I select Y, it continues on and then reports that an error has been encountered, and asks if I wish to clear it. I select Y and it reports that the update has succeeded. So I reboot but its still showing the old version with the previous updates still available.

 

Has anyone see this before? Is it a known issue or is it just us, on both appliances?

Thanks in advance.

Everyone's tags (4)
3 REPLIES 3
Highlighted
VIP Mentor

Re: WSA S390 AsyncOS upgrades keep failing

very little we have access on WSA to diagnosis, suggest to raise a TAC case so they can log in back end via tunnel and fix your issue.

BB
*** Rate All Helpful Responses ***
Highlighted
Beginner

Re: WSA S390 AsyncOS upgrades keep failing

Hi, thanks for the suggestion but this isn't an option.

We very stupidly signed up for PSS support with a Cisco partner believing that the support the third party offered was backed up by Cisco...this was not the case. So we raised it with the PSS party and they cannot fix it so we have no further options as our contract does not expire until July.

Is there any advice anyone can give fixing this ourselves?

Highlighted
Cisco Employee

Re: WSA S390 AsyncOS upgrades keep failing

Hello  BeckyBoo123,

 

I have seen this error multiple times and its cosmetic. You just had to reboot the box and it would have worked . Since you have ran the upgrade so many times.  Please try to reboot the box gracefully using "reboot" command.

After the box is up, Try to upgrade the device once again via CLI. run the "upgrade" command. choose which Async OS you want and run the upgrade. Make sure you save the config with password unmasked before you do this. Also please dont let the ssh session timeout. If it does, you will have to run the upgrade again and if it still doesn't work. Please let us know.

 

Regards

Shikha Grover

PS: Please don't forget to rate and select as validated answer if this answered your question