Showing results for 
Search instead for 
Did you mean: 

WAP371 Slooooow

Matthew Peterman


I just got an WAP371 yesterday. I am using the SB-PWR-INJ2 to power it over PoE. I updated the firmware to the latest version I am experiencing terribly slow performance with the device. It is supposed to be replacing a N450 access point. With the N450 AP I have no troubles getting about 20MBps (160mbps) over wireless when in line-of-sight of the AP. With this new AP, even though the signal is strong, the RSSI is good and the transmit rate is good, I am experiancing horribly slow connectivity rates. On AC wireless connected to a MacBook Air I have not passed 25mbps (3.1MBps) even thought the Air is connecting to the AP just fine with acceptable levels. What gives here? I was expecting at least  50% increase in performance with AC clients, not a 80% decrease! 

Any ideas what to do?

Screen shot is attached. 

70 Replies 70

The serial number of our device is CCQ18191WAN .  As I've stated, I just need to know if there are recommendations.  From what I see here, I'm not the only one experiencing slowness with the WAP 371s.  Please let me know.  Thanks!

The recommendation is to call in and open a case. Which you can.

I have doubled checked the serial number and you are still within warranty and can call in for support.

What the engineer saw when he initially looked your info up is that some of the fields are blank for you product and that causes the device to show as out of warranty. Please call in again and if you have any issues again, please direct that engineer to contact either RMA Manager for clarification or to contact me. Most Small Business Engineers know both of us and should know exactly how to reach us. Most of them work on the same floor as us.

Back to your issue. There is a beta firmware as you have seen mentioned in this thread. I know that there are some people that it has resolved their issue and a few that are still working through it. But the first step is to get you a case logged in to get the beta to you. You can reference CSCuq93941: WAP371: low throughput on tagged VLANs, to the engineer you end up working with.


I am experiencing the same problem with 6 units on two differents sites.

Apparently someone had experienced some improvements by using the following settings:

  • Disable Bonjour
  • Disable bandwith utilisation
  • Setting static channel on both frequency
  • Using WAP2 only
  • And changing DTIM period to 1

I tried them, with no luck.

I tried to open a case, but no one called me back as was promised by the small business technical support team in France. This was over a week ago.

I saw that the reference CSCuq93941 was updated on the 30rd of April and the status was supposed to be fixed. However I can't download any updated firmware.

Could you please explain how to get the beta or send me a link with the procedure I have to follow.

Many thanks in advance for your help.

I received the beta firmware but it only made a slight improvement - 4 to 8mbit instead of 0 to 1.5mbit, as opposed to over 100mbit when untagged.

Coupled with lots of connection drop-out issues and some strange problems with certain IP's being unreachable, yet working fine on 3 other brands of WAP, I decided enough was enough and Cisco support have agreed to refund what I paid for them.

On paper they are great devices, but they aren't fit for sale at the moment.  

I have learnt the hard way that Cisco Small Business != Cisco.



I noticed the following:

On the firmware the wifi connection is stable for 1-2 days. Then the WiFi connection speed slows down and clients have difficulty to connect and stay connected: connection is lost after a few seconds to a minute.

On the firmware the device is stable for up to a month. Then the same problem with connectivity appears.

Reboot solves the issue (for the specified amount of time).

Of course, rebooting the device regularly is not our preferred solution. Some reviews link the WAP371 to an identical Linksys hardware. I have noticed this behaviour also on a Cisco/Linksys E4200 router on which the WiFi slows down after a month in a similar fashion.

Appreciate if the upcoming firmware releases can be tested for long-term stability.


I have the same Problem, first Time AP Performance is ok but after 6-8 Hours Performance is very very Poor

WAP371 - Firmware

is there a Beta Firmware Public?


I have see articel CSCuq93941

May 14, 2015 the Problem was fixed!!!!!    Not find a Firmware?


Has this issue been fixed in the latest firmware (

Is it stable and working well?

No it's always disaster.

And I disable 5GHz because I'm in PoE.


I'm very surprise than Cisco do nothing.

With firmware, the issue with slow traffic on tagged VLANS was addressed.

Stephane if you're having issues with the WAP371, I could not find a case where you had asked for any help with a WAP371, or other threads here in the Support Forums.

I did find some on the UC500 series devices though. I would welcome the opportunity to assist you with any issues that you are having. 

If you prefer you can also call in and speak directly to an Engineer and let them assist.

Eric Moyers
.:|:.:|:. CISCO | Cisco Presales Technical Support | Wireless Subject Matter Expert

Please rate helpful Posts and Let others know when your Question has been answered.

Hello Eric,

You're right, I don't post a message.

(I don't know if I have a support contract for this little WAP).


Praticly all my PC lost wifi periodicly and sometime they must wait 1 or 10 minutes for have network again.


Each time I receive this email from AP:

Aug  7 2015 13:53:20   3        hostapd[1273]           trying to update accounting statistics, station 78:d7:5f:a3:27:95 not found 
Aug  7 2015 13:53:20   3        hostapd[1273]           trying to deauthenticate to station 78:d7:5f:a3:27:95, but not authenticated 
Aug  7 2015 13:55:26   3        hostapd[1273]           trying to update accounting statistics, station 78:d7:5f:a3:27:95 not found 
Aug  7 2015 13:55:26   3        hostapd[1273]           trying to deauthenticate to station 78:d7:5f:a3:27:95, but not authenticated 
Aug  7 2015 13:57:01   3        hostapd[1273]           trying to update accounting statistics, station 78:d7:5f:a3:27:95 not found 
Aug  7 2015 13:57:01   3        hostapd[1273]           trying to deauthenticate to station 78:d7:5f:a3:27:95, but not authenticated



The latest firmware are the 4th I test.


Thank you.



WIth Small Business Products WAP371 included you do not have to have a support contract. You get free 1 yr phone support from time of purchase. If you have bought within the last year I would give our Support Engineers a call and open a ticket.


One thing that you could try here is under Wireless -> Networks go to Security, disable WPA-TKIP and then check MFP: Not Required

I have just recently discovered with help from another customer that having this marked as capable or Required can cause issues similar to this.

In the US you can call 1-866-606-1866 or check this link out:

Eric Moyers
.:|:.:|:. CISCO | Cisco Presales Technical Support | Wireless Subject Matter Expert

Please rate helpful Posts and Let others know when your Question has been answered.



WPA-TKIP are already disabled but MFP was on "Capable".

I configure it in "Not Required".


Also before I see on another topic and configure 86400 for Broadcast Key Refresh and disable TSPEC mode.


thank you.

Please update me in a couple of days and let me know if this helps.

Have a great weekend.

Eric Moyers

Just received a WAP371 today. Updated firmware to and tried all recommended settings in this forum: terrible latancy. Average ping time was about 750ms.


Downgraded the firmware to Ping times 1ms with the occasional but rare spike. Configured settings to defaults and still got great ping times and throughput.

Hello Eric,

I'm come back to office.

I think I open a case because I receive always email (the mac address change in mails) :


Log Message from AP 
TIME                Priority  Process Id                Message 
Aug 24 2015 11:12:40   3        hostapd[1273]           trying to update accounting statistics, station 1c:7b:21:ca:d7:07 not found 
Aug 24 2015 11:12:40   3        hostapd[1273]           trying to deauthenticate to station 1c:7b:21:ca:d7:07, but not authenticated 


Thank you.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: