cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
32749
Views
0
Helpful
5
Replies

WAP4410N Firmware

Norrie603
Level 1
Level 1

I have two WAP4410N V01 models, firmware set to 2.0.0.12, and one WAP4410N V02 model, firmware 2.0.4.2. I know FW 2.0.5.3 is released, but may only be relevant to my V02.

I am presently having major issues with 1xiPad2, 1xiPad3, 1xiPod touch (4th Gen), all of which are constantly crashing and needing to be reset. While I am certainly not ruling out bugs with iOS 6.0.1, the symptoms have the hallmark of a WiFi connection problem. It's like the connection is latching up, causing the iDevice to freeze.

Currently ALL my networked kit, including some 16xSonos boxes, is powered OFF. Only my Virgin Media (Netgear) SuperDud (oops! meant to say SuperHub), which is running in Stand-Alone Cable Modem mode is connected to my Cisco RVS4000 Router and on to a V01 model AP. Still this intermittency is a major, major issue for me. When my network was all powered ON, all wired devices functioned just fine, only WiFi connected iThingys had a problem. I have an Apple TV box (wired), and I think it was OK as it streamed HDTV 100% without breaks. But iPad Mirroring to the TV only stayed on for a few minutes before the iPad image dissolved thru to the ATV Settings General screen. I think this is the iPad rather than the ATV box that has the problem. So pretty convinced it's a WiFi bug.

I am a little confused by the release notes for the 2.0.5.3 firmware. Please confirm exactly which revision I should be using on BOTH my V01 and V02 versions? And at least I will know that's correct.

If you have previously encountered similar problems with iDevices when used in conjunction with WAP4410N APs, and can make any constructive suggestions, then I would certainly welcome your input.

Norrie            

5 Replies 5

jurodri3
Level 1
Level 1

Hello Norrie603,

On this case I would recommend you to update the firmware of those devices.

The latest available are: 2.0.4.2 for WAP4410N V1 and 2.0.5.3 for WAP4410N V2.

You could download this firmwares on the next link:

http://www.cisco.com/cisco/software/release.html?mdfid=282414137&release=2.0.3.3&relind=AVAILABLE&softwareid=282463166&rellifecycle=&reltype=all

Diego Rodriguez

Cisco network engineer

Thank you

Hello Diego Rodriguez

Thank you for confirming firmware revisions. I have now found by experiment that if I use only my V02 model AP, with v2.0.4.2 FW, all my iDevices work perfectly as they should. No crashes! I then went ahead and upgraded it to v2.0.5.3, and of course all is still OK. So my  two V01 models with v2.0.0.12 FW are now confirmed as being the cause of my instability.

I note from the latest WAP4410N Release Notes that the v2.0.4.2 upgrade fixed "... TKIP/AES encrytption...", which myself and a colleague here believe to be the root of this problem. And now you say that this firmware revision is also appropriate for the V01 model.

Why then, in these same Release Notes page 1 of May 14 2012, does it state "Firmware version 2.0.0.12 works with all hardware versions of WAP4410N"? This implies that versions 2.0.1.0 onward apply only to the V02, ruling out 2.0.4.2 for the V01! I am confused.

Also the link you provided is for v2.0.3.3, although I am very familiar with the upgrade process for these boxes having upgraded quite a few times in recent years. So can easily get 2.0.4.2 tomorrow.

If what you say is correct, then as well as my V02 model which is now fine, I should also be able to "fix" my two V01s by going to 2.0.4.2 as you recommend. This will give me the coverage I want throughout this property without further expense. Good news indeed. Please confirm.

This then leaves me with one last issue. My RVS4000 router cannot process incoming data from my 60Mbps service fast enough. With IPS enabled it throttles the rate down to about 21Mbps down, while with IPS disabled I can get above 45Mbps from some servers. I understand from reading on the forum that the processor in the RVS4000 is struggling.

Obviously I would prefer to get the maximum performance from my broadband supplier. Can you recommend what alternative router I should be looking at? One possibility may be an SRP 541W c/w wireless built in, but this would entail some shelf layout and wiring changes. Not impossible but tricky to implement here.This box would replace the {RVS4000+WAP4410N} combo here in my Computer Room. Please comment.

Actioned the v2.0.4.2 FW upgrade as per your instructions. All the while streaming video from the V02 to my iPad3. Once the upgrade was completed, I switched off the V02 and streaming continued without a break.

But (there always has to be a "but")... when I went in to check the V01's settings, entries are missing all over the place, and any attempt to select buttons, check boxes, enter IPs etc and then Save are met with the screen reverting back to its "wrong" state. I have tried a Restore from my V01 Backup config file, rebooting, even switching power off and rebooting, to no avail.

So, right now, and barring a miracle, my conclusion is that yes, while the V01 with the encryption tweak done CAN handle my iDevices OK, it is an administrative nightmare. I could not live with a situation where entries cannot be verified or altered at will. I therefore believe my interpretation of the Release Notes was correct in that v2.0.0.12 is the last revision that is suitable for the V01. I think you may be wrong! It looks like I am back to at least one V02 purchase, and possibly an SRP 541W. The latter has lots of features not required such as VoIP Telephony etc, but basically it seems to do what I would need it to do in place of the {RVS4000+WAP4410N} here in my Computer Room.

I am now going to revert the V01 model back to v2.0.0.12, and fully expect each setup screen to be fully populated again with the correct data. I would be very interested to hear your reaction to my results.

Followup results...

In fact the 2.0.0.12 firmware did not reload quite as expected, and the WAP4410N did not run properly.

As my colleague succinctly put it, the V01 is now "partially bricked" anyway, so nothing to lose. While trying to recover (un-brick) it after restoring it to v2.0.0.12 status, its tab screens were incorrect at the first time of booting. Missing or incorrect entries all over the place. If however it was powered down and left powered down for at least ten minutes, then next time it was powered up (booted) it came back up just fine, and with all entries back as they should be. Sounds like a corrupted memory or memory retention issue to me.

OK -- would this dodge also work for v2.0.4.2? Upgraded the AP again, at the end of which it automatically reboots. Virtually all tab screen entries were missing or just plain wrong. Having previously backed up the WAP4410N.cfg file, I next did a restore operation. It rebooted, but did not change anything. Power down, leave off for ~10 minutes, and then reboot. All settings are now as they ought to be. Except in the Advanced Wireless Settings tab, where the Country/Region is oddly shown as 'Germany', not 'UK' as it should be. Fixed this, save and reboot again. As if by magic my V01 is now running v2.0.4.2, and all tabs show the same entries as before all this shenanigans when they were running v2.0.0.12.

The final result is that STV Player (our local TV station on demand service) is now streaming 100% with no breaks or buffering issues. My V02 model, with its v2.0.5.3 firmware, is powered down at the moment, so it absolutely has to be the WAP4410N-1 V01 that is finally delivering the goods.

Flushed with this success, I am now going to repeat this sequence on my 2nd V01 model, WAP4410N-2. Fingers crossed...

Some 15 minutes later:- Did not work first time, but persistent recycling with a long power down period eventually got the same result as before. That is, all OK except for wrong country. Now fixed, result!

So all three WAP4410Ns are now running fine. Despite what the Release Notes imply, you must be correct in that 2.0.4.2 WILL RUN on the V01 model!

This result opens up two options to fix my "RVS4000 data bottleneck" problem.

1) Buy a brand new combined router/access point such as the Cisco SRP541W. Because of its size, and horizontal desktop styling with antennae to the rear, this will need a shelf modification and some wiring changes, although it's not exactly difficult to do. This would leave one V01 as a spare.

2) Leave the three APs exactly as they are now, and opt for an upright faster router with integral 4-port Gigabit switch. This would be a straight plug-in replacement for the RVS4000, and require no real effort. Not sure if Cisco has a suitable model yet, also Netgear may now become an option. With the Netgear VMDG480 SuperHub sitting vertically at one end of the shelf, a matching Netgear router at the other would look quite pleasing to the eye. Would prefer to stick with Cisco Small Business Products though. Anyone care to make any suggestions?

Some time later, I can now confirm that my three WAP4410Ns are running just fine, and no more intermittency from our iDevices. Given no constructive help here, I just ordered up an RV042G to replace my RVS4000 to fix my data throughput rate problem.