cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
26102
Views
15
Helpful
5
Replies

AP1852 Cannot join WLC (AP1852 )

Yordi Mahieu
Beginner
Beginner

I have 6 brand new AP1852 ( all in LAP mode )

1 AP changed to Mobility express (WLC ) --> ap-type mobility-express tftp://<ip-tftp-server>/AIR-AP1850-K9-8.2.100.0.tar  (newest firmware)

This WLC (and AP ) is ok .. set basic parameters (Web interface very very poor !!!! ) use CLi for SNMP V3, RADIUS , ...

this WLC user ntp server and time zone (Amsterdam, Berlin, Rome, Vienna ) GMT +1:00 ) and summer time.

The AP one this WLC controller is working fine.

Then I tryed to add a new AP (LAP ) same device , software = 8.1.131.0 .

Device will discover WLC (CAPWAP broadcast ) ... but it wil not dowload (or compleet) image ..

only thing that i can notis = the time diverence ...  AP = GMT exaple 09:24:23 and WLC = Timezone corected (and local time) 11:24:23 ..

This is a smart log of the discovery of the WLC ... I have DHCP option to set the Time zone (works great for Cisco switches) but these AP and WLC will not use it ... )

Discovery Request sent to 255.255.255.255 with discovery type set to
[*04/13/2016 08:48:06.3999] CAPWAP State: Init.
[*04/13/2016 08:48:06.3999]
[*04/13/2016 08:48:06.3999] CAPWAP State: Discovery.
[*04/13/2016 08:48:06.3999]
[*04/13/2016 08:48:07.3996] Discovery Response from 10.12.0.11

******I think here AP uses his own NTP server (cisco) to corect the time, only wrong time zone ! *******


[*04/13/2016 09:06:35.0399] device capwap0 entered promiscuous mode
[*04/13/2016 09:06:35.0799] device capwap1 entered promiscuous mode
[*04/13/2016 09:06:43.4674] Selected MWAR 'apc-11' 10.12.0.11 (index 0).
[*04/13/2016 09:06:43.4674] Ap mgr count=1
[*04/13/2016 09:06:43.4674] Go join a capwap controller.
[*04/13/2016 09:06:43.4674] Choosing AP Mgr with index 0, IP = 10.12.0.11, load = 1..
[*04/13/2016 09:06:43.4674] Synchronizing time with AC time: 1460538395
[*04/13/2016 09:06:35.0000] CAPWAP State: DTLS Setup.
[*04/13/2016 09:06:35.0000]
[*04/13/2016 09:06:35.0599] Dtls Session Established with the AC 10.12.0.11, port= 5246
[*04/13/2016 09:06:35.0599] CAPWAP State: Join.
[*04/13/2016 09:06:35.0599]
[*04/13/2016 09:06:35.0699] PATH_MTU_PAYLOAD: encodelen = 273
[*04/13/2016 09:06:35.0699] PATH_MTU_PAYLOAD: slotId = 0
[*04/13/2016 09:06:35.0699] PATH_MTU_PAYLOAD: slotId = 0 pktlen 1485 capwap_size 1360 met->encode
[*04/13/2016 09:06:35.0699] PATH_MTU_PAYLOAD: slotId = 0 len 1485(1071)
[*04/13/2016 09:06:35.0699] Sending Join Request Path MTU payload, Length 1360
[*04/13/2016 09:06:35.0699]
[*04/13/2016 09:06:35.0899] Join Response from 10.12.0.11
[*04/13/2016 09:06:35.0899] AC accepted join request with result code: 0
[*04/13/2016 09:06:35.0899]
[*04/13/2016 09:06:35.0899] PMTU : Setting MTU to : 1485
[*04/13/2016 09:06:35.0899]
[*04/13/2016 09:06:35.0899] Starting Post Join timer
[*04/13/2016 09:06:35.0899] CAPWAP State: Image Data.
[*04/13/2016 09:06:35.0899]

***** AP see new firmware on the WLC ******************
[*04/13/2016 09:06:35.0899] AP current image version 8.1.131.0
[*04/13/2016 09:06:35.0899] Controller current image version 8.2.100.0
[*04/13/2016 09:06:35.0899] Version does not match.
[*04/13/2016 09:06:35.0899] AP backup image version 0.0.0.0
[*04/13/2016 09:06:35.1199] do PRECHECK, part1 is active part
[*04/13/2016 09:06:35.1399] Stopping Post Join Timer and Starting HeartBeat Timer
[*04/13/2016 09:06:35.1399] Image Data Request sent to 10.12.0.11
[*04/13/2016 09:06:35.1399] Image Data Response from 10.12.0.11
[*04/13/2016 09:06:35.1399]
[*04/13/2016 09:06:35.1399] AC accepted join request with result code: 0
[*04/13/2016 09:06:35.1399]
[*04/13/2016 09:06:35.1399] Starting image download.............
[*04/13/2016 09:08:29.0444] Invalid event 50 & state 10 combination.
[*04/13/2016 09:08:29.0444] SM handler: Failed to process timer message. Event 50, state 10
[*04/13/2016 09:08:29.0444] Failed to handle timer message.
[*04/13/2016 09:09:23.6873] Discarding msg type 9 in CAPWAP state: 10.
[*04/13/2016 09:09:23.7073] Discarding msg type 9 in CAPWAP state: 10.
[*04/13/2016 09:12:23.6910] Discarding msg type 9 in CAPWAP state: 10.
[*04/13/2016 09:12:23.7110] Discarding msg type 9 in CAPWAP state: 10.
[*04/13/2016 09:15:23.6948] Discarding msg type 9 in CAPWAP state: 10.
[*04/13/2016 09:15:23.7148] Discarding msg type 9 in CAPWAP state: 10.
[*04/13/2016 09:18:23.6885] Discarding msg type 9 in CAPWAP state: 10.
[*04/13/2016 09:18:23.7085] Discarding msg type 9 in CAPWAP state: 10.
[*04/13/2016 09:21:23.6923] Discarding msg type 9 in CAPWAP state: 10.
[*04/13/2016 09:21:23.7223] Discarding msg type 9 in CAPWAP state: 10.
[*04/13/2016 09:24:23.6960] Discarding msg type 9 in CAPWAP state: 10.
[*04/13/2016 09:24:23.7160] Discarding msg type 9 in CAPWAP state: 10.
[*04/13/2016 09:27:23.6898] Discarding msg type 9 in CAPWAP state: 10.
[*04/13/2016 09:27:23.7098] Discarding msg type 9 in CAPWAP state: 10.

***** AP stays like this ....******

The 2 devices are connected to the same POE+ Cisco Switch, same untaged Vlan, no firewall or ACL precent ....

I could upgrade this AP to Mobility expres like the 1ste one, but i would preffer the have a ZERO TOUCH AP deployment !!!!

1 Accepted Solution

Accepted Solutions

Sandeep Choudhary
VIP Mentor VIP Mentor
VIP Mentor

Please paste the output of these commands..

from WLC: sh sysinfo

From AP: sh version

Regards

Dont forget to rate helpful posts

View solution in original post

5 Replies 5

Sandeep Choudhary
VIP Mentor VIP Mentor
VIP Mentor

Please paste the output of these commands..

from WLC: sh sysinfo

From AP: sh version

Regards

Dont forget to rate helpful posts

After searching i have found that the image must be in a folder on a tftp server ... it is not downloading it from the controller,

after making the image available the software update wenth smooth..

thanks for the replay ..

That was an error with the version of firmware, i could fix it that way:

The same version in ME and AP

I upgrade the AP with this command:

archive download-sw /reload tftp://<<ip_tftp_server>>/<<image>>.tar

now it works just fine

Cheers

I am a similar issue, I had converted my 1852AP to a CME, and didn't care for the limited interface compared to the 2504 controller, I ended up picking up a controller, the information to demote said to login, which I did get to enable mode which I did and set the NAME#ap-type capwap, so when it rebooted it started to look at the 2504 which is set as a master for an image, which the instructions said if the image is different it will pull an image from the new controller, then I would see it show up in the 2504 under my AP's, and downloading, normally when I first provision they take a while, but this would show.. the a1852i was different than the 2540, while this eventually load?