Showing results for 
Search instead for 
Did you mean: 

Apple TV does not work with 877W

Hi all,

I am using an 877W as my DSL router and trying to use Apple TV or other Apple Bonjour services over Wireless. It is simply not working although I tried several IGMP configurations. I've seen some references to 877W issues but they were all about bridging between wired and wireless. In my case though everything is on wireless (PC with iTunes, Apple TV and and iPhone to be more specific). I wanted to ask once more as I've also seen references to people having this setup working ok.

interface Dot11Radio0

ip address

ip nat inside

ip virtual-reassembly

load-interval 30

encryption mode ciphers aes-ccm

ssid Princes

speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0

channel 2472

station-role root


I tried with igmp snooping on and off with no luck, also it didn't helped to add as a static group to the interface.

If you have apple stuff working on your 8xxW environment I appreciate if you can share your configuration, any other ideas are more than welcome.

Many thanks,


Viten Patel
Cisco Employee

I am not sure about this but u can try enabling multicast on the router:

ip multicast-routing

also you can try disabling igmp snooping and try configuring a multicast mode for the interface,

ip pim sparse-dense-mode

Hi Viten,

Tried this without luck. Also why should I need multicast-routing? Again, it is same layer 2 subnet. I am not trying to pass traffic between wired and wireless.

Anyhow, thanks for your response.


When dealing with the Apple TV's, even though it has wireless, to be able to use it, that device has to be wired. We worked with an Apple engineer on a project and was told this, once we wired the Apple TV the other Apple devices on the same subnet was able to communicate to the Apple TV.

Sent from Cisco Technical Support iPhone App

*** Please rate helpful posts ***

I have 3 apple tvs all on wifi and they work fine. Not I am using a WLC 4402 and multicast is configured. But it does work ..

"Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin

Interesting... We could not get the devices to find the Apple TV's when these were on the wireless. Apple told us that the protocol does not run on the wireless but on the wired side. We were using 5508's on, but they didn't think that made a difference.


Scott Fella

Sent from my iPhone

*** Please rate helpful posts ***

I've had a total of 5 Apple TV's (3 1st gen, 2 2nd gen) running on Cisco wireless since 4.2 days with no problems. Enabling multicast as well as broadcast forwarding seems to work for my setups.

You guys are going to make me buy one just to do some testing.


Scott Fella

Sent from my iPhone

*** Please rate helpful posts ***

Hi Blakekrone,

Thanks for your answer.

What does 4.2 refers to ? Apple TV software ? Are you running on 877 or similar routing based platform? If yes would you mind sharing your configuration so that I can try to spot what I might be doing wrong.

In regard to multicase/broadcase forwarding, once again, everything is on the same subnet and same physical layer (wireless). Is there a way of further enabling multicast / broadcast forwarding on dot11radio interface?

Thanks a alot,


See attached it does work.

Sent from Cisco Technical Support iPad App

"Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin

Hi Scott,

Thanks for your answer. I am quite certain that the issue is Cisco (or rather 877) specific, as soon as I replace 877 with a cheap ADSL router everything starts working perfectly although Apple TV is still on wireless. Almost seems like 877 not forwarding certain type of traffic between wireless devices (no idea what that might be).

Many thanks,


Hi Cagri,

Hope you've found an answer to your problem already, if not I had similar issues trying to get mine to work.

I did manage to get it to work in the end, I've added an article to my blog which goes over what I had to do to get it working.

Basically, configured correct multicast-routing groups, IGMP v3, pim dense-mode on both the radio and BVI interfaces and it started working.



Content for Community-Ad