Showing results for 
Search instead for 
Did you mean: 
Austin Godbey

APs joined wrong Controller...

Just plugged in 5 3602i APs and instead of joining the controller for this building they joing a controller for a different building. Not sure what to look for on the controllers or what to post...but why would this happen? How can I get them off the wrong controller and onto the right controller?


Rasika Nayanajith
VIP Mentor

Hi Austin,

You can configure HA (Primary, Secondary, Tertiary) for your AP which will pointing APs to correct WLCs as per your preference.

It can be done on AP settings (High Availability tab) as shown below




**** Pls rate all useful responses ****

I changed this on one of the APs on the wrong controller. Didn't change anything. It's management controller is still one at a different site.

I'm not understanding why the APs auto-joined a controller in a different vlan...

Do you have L3 reachability from your AP to all the controllers ?

After applying this configuration did you reboot the AP ? If not reboot the AP & see. As long as you have rechability that AP should go to the primary WLC you have configured.

Refer these post to better understand AP Registraion & Failover process bit more in detail.





**** Pls rate all useful responses ****

HI Austin,

A couple other things is to make sure you don't have master controller enabled on the WLC  with the other building. Change the primary WLC on the AP(As rasika explained) to the WLC which you want to join and either wait a couple minutes or just reboot the AP.

Also change this on WLC. Go to the primary controller > Wireless > Access Points > Global Configuration


Dont forget to rate helpful posts

Just to add.... Since you already have WLC's and AP's that are up, most likely you also have option 43 or DNS configured which is pointing to that WLC that these new AP's are joining.  Like Raskia mentioned, if you change the high availability, the AP should join that WLC you pointed to.  The hostname is case sensitive!!!! If the AP fails to join the WLC, then maybe the WLC time is off or something is blocking udp 5246 and udp 5247. 

The best thing you can do is put the AP on the same vlan as the WLC management, the AP needs to get a dhcp address or you need to configure a static address, but if the AP is on the same vlan, it should find the WLC and join using layer 2 broadcast. Once the AP joins, you can move that AP to another vlan since the AP already knows of the WLC. 



Help out other by using the rating system and marking answered questions as "Answered"

*** Please rate helpful posts ***
Content for Community-Ad

This widget could not be displayed.