10-22-2012 06:44 AM - edited 07-03-2021 10:53 PM
I am having a problem getting DHCP to work for interface BVI1. I have tried everything I can think of and now am asking for the smarter peoples help. DHCP works great for the clients but BVI1 will not get a DHCP address no matter what I try. Below is a copy of the config for the AP and the port.
AP
Current configuration : 2754 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Library-103
!
logging rate-limit console 9
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
!
aaa session-id common
!
!
ip dhcp-server 155.31.18.69
dot11 syslog
dot11 vlan-name Wireless vlan 3402
!
dot11 ssid Eaglenet_CiscoTest
vlan 3402
authentication open
guest-mode
mbssid guest-mode
!
!
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
ssid Eaglenet_CiscoTest
!
station-role root access-point
!
interface Dot11Radio0.9
encapsulation dot1Q 9 native
no ip route-cache
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio0.3402
encapsulation dot1Q 3402
no ip route-cache
bridge-group 254
bridge-group 254 subscriber-loop-control
bridge-group 254 block-unknown-source
no bridge-group 254 source-learning
no bridge-group 254 unicast-flooding
bridge-group 254 spanning-disabled
interface Dot11Radio1
no ip address
no ip route-cache
!
ssid Eaglenet_CiscoTest
!
station-role root access-point
!
interface Dot11Radio1.9
encapsulation dot1Q 9 native
no ip route-cache
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio1.3402
encapsulation dot1Q 3402
no ip route-cache
bridge-group 254
bridge-group 254 subscriber-loop-control
bridge-group 254 block-unknown-source
no bridge-group 254 source-learning
no bridge-group 254 unicast-flooding
bridge-group 254 spanning-disabled
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0.9
encapsulation dot1Q 9 native
no ip route-cache
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
!
interface FastEthernet0.3402
encapsulation dot1Q 3402
no ip route-cache
bridge-group 254
no bridge-group 254 source-learning
bridge-group 254 spanning-disabled
!
interface BVI1
ip address dhcp
no ip route-cache
!
ip default-gateway 155.31.9.254
ip http server
ip http authentication aaa
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
snmp-server community Cisco_Wireless RO
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
!
end
Switch
interface GigabitEthernet1/0/47
description Meraki WAP
switchport access vlan 9
switchport trunk encapsulation dot1q
switchport trunk native vlan 9
switchport trunk allowed vlan 7,9,29,3402
switchport mode trunk
switchport nonegotiate
priority-queue out
mls qos trust dscp
Solved! Go to Solution.
10-24-2012 07:31 AM
gah, sorry didn't read the entire OP to see that.
Take a look at your global switch config, look for a 'vlan dot1q tag native' command. if that is enabled do a
no vlan dot1q tag native and test again.
HTH,
Steve
------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered
10-24-2012 05:23 AM
Anybody?
10-24-2012 05:57 AM
Hi Dustin,
I like your term "Smarter People" :-) Dont assume im smart since im answering this :-)
When you say clients get ip do you mean wireless clients or LAN client? What is acting as DHCP server here? Try connecting a laptop to same switch port and see if you are able to get an ip address on the laptop from DHCP server.
Also modify the switch port configuration as follows.
Switch Config
interface GigabitEthernet1/0/47
description Meraki WAP
switchport trunk encapsulation dot1q
switchport trunk native vlan 9
switchport mode trunk
speed 100
duplex full
Also I hope that you have ip helper address configured on the L3 interface of Vlan 9 as below
int vlan 9
ip helper-address x.x.x.x (your dhcp server address)
Regards
Najaf
10-24-2012 06:10 AM
The wireless clients get the correct IP from the dhcp server(This is a different ip range from our lan) Since the port is setup as a trunk port I cannot get an IP from a laptop of I make the port an access port the bvi gets an IP but the wireless doesn't work as one would expect. We only use ip helpers on our router and no where else. All my lan clients get an ip except the bvi on the trunk port.
10-24-2012 06:12 AM
Our dhcp server is a separate box. Also if I specify a manual IP on the bvi I cannot ping nor can I get to the web interface for the ap
10-24-2012 06:25 AM
Hi Dustin,
Do you mean to say when you configure the switch port to vlan 9, you are able to get a valid ip address on laptop? Or you are getting ip address only when it is set to vlan 3402?
From your this statement "Also if I specify a manual IP on the bvi I cannot ping nor can I get to the web interface for the ap" we can eliminate any possible DHCP configuration issue.
What manual ip address/subnet mask are you assigning on BVI? isd the BVI interface coming up when you assign manual ip address? Also which is this "ip default-gateway 155.31.9.254"?
Regards
Najaf
10-24-2012 06:33 AM
If I use access vlan 9 I can get an ip.
I tried putting a default gateway of 155.31.9.254 Which is correct
Also i was specifying an ip of 155.31.9.240 255.255.255.0 on the bvi when i do this i still cant ping or web access the ap under both dhcp it was saying the bvi was up
10-24-2012 06:58 AM
Hi Dustin,
This sounds strange ;-(
With manully assigned ip address of 155.31.9.240 255.255.255.0 and switch port confgured with vlan 9, you where not able to ping or web access the AP? Or did u had switch port as trunk when you tried manually setting up the ip?
By the by did u try reconfiguring the switch port as i have suggested on the above post?
Regards
Najaf
10-24-2012 06:59 AM
your switchport config should be similar to the below
interface < what ever it is >
switchport trunk encapsulation dot1q < may not be needed if the switch is newer >
switchport mode trunk
switchport trunk native vlan 9
switchport trunk allowed vlan 9,3402
HTH,
Steve
------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered
10-24-2012 07:24 AM
Najaf,
The switch port was as a trunk with the manual IP. When the switch port as access I can get dhcp just fine.
I'm not in the office today so I can't try your config until tomorrow.
Steve,
That is how I had my switch port configured and it still wasn't working with dhcp or static except I had a couple extra vlans on the trunk
10-24-2012 07:31 AM
gah, sorry didn't read the entire OP to see that.
Take a look at your global switch config, look for a 'vlan dot1q tag native' command. if that is enabled do a
no vlan dot1q tag native and test again.
HTH,
Steve
------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered
10-25-2012 05:39 AM
Stephen we do not have that command on our switch that I could find
Najaf that command for the ip-helper on the switch did not help still not getting DHCP but I am still getting DHCP for my wireless clients
10-25-2012 05:59 AM
Hi Dustin,
Can you provide the switch config please? Also is there any requirment for you to have the BVI interface on vlan 9 itself? Can it not be on vlan 3402? You may have to fine tune native vlan configuration for you to get ip for bvi from vlan 3420.
Regards
Najaf
10-25-2012 06:08 AM
I am including the full running config for the switch. The BVI can not be on 3402 becuase this is a different IP range (10.x.x.x vs 155.x.x.x) than our normal useage and is technically part of a different network and would be very complicated to be able to get to it from our current subnets (it's a complicated setup) The AP is plugged into port 1/0/47
Please note IP routing was turned on for testing purposes for a different project but it shouldn't be affecting this project.
Current configuration : 21448 bytes
!
! Last configuration change at 08:46:50 EDT Thu Oct 25 2012 by netadmin
! NVRAM config last updated at 11:54:02 EDT Thu Oct 11 2012 by sondenad
!
version 12.2
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service linenumber
service sequence-numbers
service unsupported-transceiver
!
hostname ITLab-Stack
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 notifications
no logging console
!
!
aaa new-model
!
!
aaa authentication login default local group tacacs+
aaa authentication login no-tacacs local
aaa authentication enable default group tacacs+ enable
aaa authorization console
aaa authorization config-commands
aaa authorization exec default group tacacs+ if-authenticated local
aaa authorization commands 1 default if-authenticated
aaa authorization commands 15 default local group tacacs+
!
!
!
aaa session-id common
clock timezone EST -5
clock summer-time EDT recurring
switch 1 provision ws-c3750g-48ps
system mtu routing 1500
vtp domain IT
vtp mode transparent
no ip source-route
ip routing
ip domain-name *****
ip name-server 155.31.18.69
!
!
ip dhcp snooping vlan 19
no ip dhcp snooping information option
no ip dhcp snooping verify mac-address
ip dhcp snooping
!
mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2 1
mls qos srr-queue input cos-map queue 1 threshold 3 0
mls qos srr-queue input cos-map queue 2 threshold 1 2
mls qos srr-queue input cos-map queue 2 threshold 2 4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3 3 5
mls qos srr-queue input dscp-map queue 1 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3 0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3 32
mls qos srr-queue input dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2 33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2 49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2 57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3 5
mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 2 4
mls qos srr-queue output cos-map queue 4 threshold 2 1
mls qos srr-queue output cos-map queue 4 threshold 3 0
mls qos srr-queue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1 8
mls qos srr-queue output dscp-map queue 4 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
!
vlan internal allocation policy ascending
vlan dot1q tag native
!
vlan 5-6
!
vlan 7
name sub-7
!
vlan 8
name sub-8
!
vlan 9
name sub-9
!
vlan 19
name sub-19
!
vlan 29
name resnet-29
!
vlan 700
!
vlan 2019
name VOIP-19
!
vlan 3402
name EagleNet-10.33.102.00
lldp run
!
!
!
interface Port-channel1
description GEC ITSouth-Stack
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 7,9,19,29,2019,3402
switchport mode trunk
switchport nonegotiate
ip dhcp snooping trust
!
interface GigabitEthernet1/0/1
switchport access vlan 7
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/2
switchport access vlan 7
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/3
switchport access vlan 7
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/4
switchport access vlan 7
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/5
description Desktop Switch
switchport access vlan 7
switchport mode access
priority-queue out
mls qos trust dscp
!
interface GigabitEthernet1/0/6
switchport access vlan 7
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/7
switchport access vlan 7
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/8
switchport access vlan 7
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/9
switchport access vlan 7
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/10
switchport access vlan 7
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/11
switchport access vlan 7
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/12
switchport access vlan 7
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/13
switchport access vlan 7
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/14
switchport access vlan 7
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/15
switchport access vlan 7
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/16
description 165-X
switchport access vlan 7
switchport mode access
priority-queue out
mls qos trust dscp
!
interface GigabitEthernet1/0/17
description 165-W
switchport access vlan 7
switchport mode access
priority-queue out
mls qos trust dscp
!
interface GigabitEthernet1/0/18
description 165-U
switchport access vlan 19
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/19
description 165-V
switchport access vlan 19
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/20
switchport access vlan 19
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/21
switchport access vlan 19
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/22
switchport access vlan 6
switchport mode dot1q-tunnel
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
!
interface GigabitEthernet1/0/23
switchport access vlan 19
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 5
switchport mode trunk
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp tlv server-location
no cdp tlv app
!
interface GigabitEthernet1/0/24
switchport access vlan 5
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/25
switchport access vlan 19
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/26
switchport access vlan 19
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/27
switchport access vlan 6
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
!
interface GigabitEthernet1/0/28
switchport access vlan 19
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/29
switchport access vlan 19
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/30
switchport access vlan 19
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/31
switchport access vlan 19
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/32
switchport access vlan 19
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
!
interface GigabitEthernet1/0/33
switchport access vlan 19
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/34
switchport access vlan 19
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/35
description Nettech Phone
switchport access vlan 19
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
!
interface GigabitEthernet1/0/36
description 165-F
switchport access vlan 9
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/37
switchport access vlan 700
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
!
interface GigabitEthernet1/0/38
description 165-E
switchport access vlan 7
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
!
interface GigabitEthernet1/0/39
switchport access vlan 7
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp tlv server-location
no cdp tlv app
!
interface GigabitEthernet1/0/40
switchport access vlan 9
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
!
interface GigabitEthernet1/0/41
switchport access vlan 19
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/42
switchport access vlan 9
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/43
switchport access vlan 9
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 7,9,19,29,2019,3402
switchport mode access
switchport nonegotiate
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
spanning-tree portfast
!
interface GigabitEthernet1/0/44
switchport access vlan 29
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
!
interface GigabitEthernet1/0/45
switchport access vlan 29
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/46
switchport access vlan 29
switchport trunk encapsulation dot1q
switchport trunk native vlan 118
switchport mode access
switchport voice vlan 2019
power inline consumption 7700
priority-queue out
mls qos trust dscp
no cdp enable
no cdp tlv server-location
no cdp tlv app
spanning-tree portfast
!
interface GigabitEthernet1/0/47
description Meraki WAP
switchport access vlan 9
switchport trunk encapsulation dot1q
switchport trunk native vlan 9
switchport trunk allowed vlan 1,7,9,29,3402
switchport mode trunk
!
interface GigabitEthernet1/0/48
description Meraki WAP
switchport access vlan 7
switchport trunk encapsulation dot1q
switchport trunk native vlan 7
switchport mode trunk
switchport nonegotiate
priority-queue out
mls qos trust dscp
!
interface GigabitEthernet1/0/49
description Trunk ITLab-Stack
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 6,7,9,19,29,2019,3402
switchport mode trunk
switchport nonegotiate
priority-queue out
mls qos trust dscp
!
interface GigabitEthernet1/0/50
description Trunk ITLab-Stack
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 7,9,19,29,2019,3402
switchport mode trunk
switchport nonegotiate
priority-queue out
mls qos trust dscp
ip dhcp snooping trust
!
interface GigabitEthernet1/0/51
description GEC ITSouth-Stack
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 7,9,19,29,2019,3402
switchport mode trunk
switchport nonegotiate
priority-queue out
mls qos trust dscp
channel-group 1 mode active
ip dhcp snooping trust
!
interface GigabitEthernet1/0/52
description GEC ITSouth-Stack
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 7,9,19,29,2019,3402
switchport mode trunk
switchport nonegotiate
priority-queue out
mls qos trust dscp
channel-group 1 mode active
ip dhcp snooping trust
!
interface Vlan1
no ip address
shutdown
!
interface Vlan6
ip address 192.168.72.254 255.255.255.0
!
interface Vlan7
no ip address
!
interface Vlan9
description sub-9
ip address 155.31.9.251 255.255.255.0
!
interface Vlan700
ip address 192.168.70.254 255.255.255.0
!
ip default-gateway 155.31.9.254
ip classless
ip route 0.0.0.0 0.0.0.0 155.31.9.254
ip route 192.168.71.0 255.255.255.0 192.168.72.253
no ip http server
ip http secure-server
!
ip sla enable reaction-alerts
logging trap notifications
logging 155.31.254.60
access-list 8 permit 155.31.10.76
access-list 9 permit 155.31.254.60
snmp-server engineID local 0000000254
snmp-server group CirrusGroup v3 auth write CirrusView
snmp-server group CirrusGroup v3 priv write CirrusView
snmp-server view CirrusView iso included
snmp-server community **** RO 8
snmp-server community ****** RW 9
snmp-server community ****** RO 9
snmp-server location IT Buildings
snmp-server contact *******
snmp-server enable traps tty
snmp-server enable traps license
snmp-server enable traps stpx root-inconsistency loop-inconsistency
snmp mib community-map erauprivate254 engineid 8000000903000023343AB081
snmp mib community-map eraupublic254 engineid 8000000903000023343AB081
tacacs-server host 155.31.254.61
tacacs-server directed-request
tacacs-server key 7 002A40113008080E
!
!
line con 0
password 7 080664411A0D
line vty 0 4
password 7 123E2D18011F
line vty 5 15
password 7 123E2D18011F
!
ntp clock-period 36029048
ntp server 155.31.18.69
end
10-25-2012 08:40 AM
Hi Dustin,
In the last post Steve mentione you to remove "vlan dot1q tag native" from the global config but you have written back saying that you couldn't find anything like that. But above switch config shows that "vlan dot1q tag native" indeed there on the global config as below
spanning-tree extend system-id
!
vlan internal allocation policy ascending
vlan dot1q tag native
!
vlan 5-6
Could you please type "no vlan dot1q tag native" and give a try?
Also let me share what i think the of the problem(i may be wrong here)which is happening here. As you know by default native vlan traffic are send untagged on the trunk link. Assume that you don't have vlan dot1q tag native on the global configuration of switch.
Your switch port is currently configured as below
interface GigabitEthernet1/0/47
description Meraki WAP
switchport access vlan 9
switchport trunk encapsulation dot1q
switchport trunk native vlan 9
switchport trunk allowed vlan 1,7,9,29,3402
switchport mode trunk
Here you have native vlan 9 and traffic for this vlan will not be tagged by default.On the AP's as well you have vlan 9 as native vlan as per your configuration below
interface Dot11Radio0.9
encapsulation dot1Q 9 native
or
interface Dot11Radio1.9
encapsulation dot1Q 9 native
or
interface FastEthernet0.9
encapsulation dot1Q 9 native
When the dhcp response packet comes to this trunk interface it would ideally send vlan 9 packet over the trunk link to AP as untagged packet due to the command switchport trunk native vlan 9 and your AP happily except this packet because it also has vlan 9 as native vlan.
But since you have a line which says vlan dot1q tag native on your switch global configuration what it does is that it instruct the switch to tag the native vlan traffic. So when switch send the traffic out to the AP over the trunk interface it tags the vlan 9 traffic and the AP reject this packet and hence your BVI interface is not picking up a dhcp ip address.
Once you remove vlan dot1q tag native line (user no vlan dot1q tag native to remove this line) from the switch configuration the switch trunk port will send the vlan 9 traffic untagged to the AP and AP would accept it.
Hope this helps.
Regards
Najaf
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide