cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2264
Views
30
Helpful
8
Replies

Cisco 2504 and the Apple Remote App, AppleTV vs iTunes.

Drachiri
Beginner
Beginner

Here is my issue, I currently have a 2504 with 3 access points.  Now, I enabled multicast on it so that Apple TV and Airplay work fine, my printer communicates via Bonjour, so it that respect everything seems good.  I can Airplay all day long to my hearts content.  First, I couldn't use the Remote app to control Apple Tv or iTunes on the computer.  I found the bug report about mDNS snooping causing this to fail.  So I turned it off, now the Remote app controls my iTunes app on my computer, but the Apple TV still doesn't see the iPhone as a pair-able device.   Has anyone experienced this?   I am running 7.6.130.0 on the 2504.   The appletv and iphones are latest os'es.

Thanks.

8 Replies 8

Scott Fella
Hall of Fame Guru Hall of Fame Guru
Hall of Fame Guru

I have ran into the same issue in my home lab. The remote app use to work I think on v7.4 and then everything broke. I know that mDNS is not supported on v8.1, but they brought it back into support on v8.2. Maybe give that code a try and see, but I wouldn't hold my breath.  I can run my Meraki and Aruba wireless and things work, so I don't know what to say... Basically I gave up on that piece. You can see if you can maybe manually add the service, but you need to figure that out and maybe use a bonjour browser on your iPhone to discover that service. 

-Scott 

*** Please rate helpful posts ***

-Scott
*** Please rate helpful posts ***

Has this issue been sorted now?

I too, use the remote app a fair bit, and the family uses Airplay a lot.

Thanks

Actually, I tried upgrading to 8.2 and it didn't fix it.   Actually, 8.2 has long standing bug from previous releases that cause some entries in the rogue screen to be blank...annoying as heck.  So i went back to 7.6.130.0.  The solution for me was either put the APs in the management plan or fix the multicast.  So I setup multicast on my Mikrotik router, after that it worked.

Ok, thanks.

Excuse my ignorance, (as i don't have the products yet) but is there no way of setting up Multicast on the controller?

Only reason i ask is that on my current AP which runs virtual, there is an option to disable broadcast filtering in the web ui.

:)

You can setup multicast on the controller, but multicast has to be enabled on the network side also to work.  There are a bunch of guides and blogs in regards to bonjour:

http://www.cisco.com/c/en/us/td/docs/wireless/controller/technotes/8-0/WLAN-Bonjour-DG.html

https://www.packet6.com/configuring-bonjour-cisco-wlc/

-Scott

*** Please rate helpful posts ***

-Scott
*** Please rate helpful posts ***

VallivueJoe
Beginner
Beginner

I am posting because I have noticed a lot of people with this problem and no solution posted.

 

I have this working on 8.2.151.0 on a 5520 WLC. 

 

Under WLAN

  • Select the WLAN and go to the Advance Tab.
  • Make sure mDNS Snooping Enabled.
  • IMake sure mDNS Profile set is set to default-mdns-profile. (Or the profile you use)

 

Under Controller - mDNS - General

I Added a Service to the Database.

  • Select Service: Other
  • Service Name: AppleTVRemoteApp
  • Service String: _mediaremotetv._tcp.local.    (Copy and paste this, or type it exactly as it appears including the ending period.)
  • Query Status: Checked
  • Click on Add

Under Controller - mDNS - Profiles

Select default-mdns-profile (Or the Profile that you use)

Under Services Name Use the drop down box to select AppleTVRemoteApp, then click Add

 

You can test this to see that it's working.

 

 

Under Controller - mDNS - General

Click on the hyperlink for AppleTVRemoteApp

If everything is working you will start seeing your apple TVs appear under Service Provider Information Heading.

 

If you ever need to find a mDNS service string they are easy to capture by using Wireshark. That's how I found the _mediaremotetv._tcp.local. string.

 

Very useful, thanks !!!! Step by step and works perfectly.

*** SOLVED ***

Thanks - I tried that but I didn't see anything populating under the Service Provider area and the remote app didn't see any Apple devices or services either, so I looked around for some of the newer Service Strings and added the following using the same method you described.  IT WORKED!  The Apple Remote App immediately saw my Apple iTunes Service and Apple TVs and the Service Provider area on the controller's web interface started populating the mDNS General section for those services.  (Cisco 2504 running 8.0.152.0)

 

I added these 2 entries to the Master Service Database:

 

Apple Home Sharing

Service Name:  iTunesHomeSharing

Service String:  _home-sharing._tcp.local.

 

 

Apple TV Remote for IOS

Service Name:  AppleTVRemoteApp_IOS

Service String:  _touch-able._tcp.local.

 

Hope this helps!

 

Brantz

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers