cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
742
Views
0
Helpful
5
Replies

Cisco 3602e CAPWAP will not join vWLC

mpierce28
Level 1
Level 1

I am having a rather troubling issue.  I had an access point that was connected to my virtual wireless lan controller.  It worked fine in the testing environment, but then I tried to roll the environment over to production.  This meant connecting the AP to the primary Wireless Lan Controller.  The original lan controller would have become the primary but I could not get the management interface moved over to the VLAN I wanted it on. 

(Not sure why that did not work, but regardless I had to reinstall the controller and enter 3 as the VLAN during the initial config to get it to take.)

So now I am trying to connect the AP to a new controller and the old controller is gone.  No matter what I try it will not connect.  My controller says that there is not an entry in the database.  The times on the 2 devices do not match up, and the certificate fails during the initialization process.  I cannot set the time on the AP because I cannot connect to it.  So I just set the wrong time on my controller so they would match, but no luck there either.  I cannot connect via the console port on any speed or setting for flow control.  I cannot telnet or SSH.  I can access the web interface but I have no options to change anything.  I am told that running a write erase command on the AP will reset it so I can connect it to the new controller, but I cannot access this device to run that command.  Is there a fault in the console port on this device?  Is there any other way to force this device to join the new controller?  I already tried setting it as the master controller and removing the arp cache.  No idea how to remove the MAC cache.  I get the error that the AP is not found in the temporary database.  Is there any way I can add it manually?  It fails on the certificate, can I disable the use of certificates/authentication of any kind at least until I can wipe this AP?

5 Replies 5

Leo Laohoo
Hall of Fame
Hall of Fame

Post the following output:

1.  WLC:  sh sysinfo;

2.  WLC:  sh time;

3.  AP:  sh version;

4.  AP:  sh ip interface brief; and

5.  AP:  sh inventory

mpierce28
Level 1
Level 1

Just wanted to note that I was able to gain access to my AP finally.  The console cable I was using was bad.  Now I have a different issue.  Apparently the IOS is corrupt and wont boot.  I tried changing the os to a different version within the flash folder, which got the device to boot, but then it rebooted right back into the other IOS and failed when I restarted the AP.  I entered the set boot command with the image name of the working IOS but that did not seem to do anything.  I then deleted the faulty IOS and now the boot process just cycles even when manually tell it to boot from the one that worked.  Is there a location on the device that keeps an archive of the IOS?  I would like to just erase my flash folder and start over with a new IOS. 

If no archive then is there a location where I can download the IOS for this?  I want to try to avoid Cisco smartnet... I feel troubled paying thousands for something that I already own.

Apparently the IOS is corrupt and wont boot.

This is no big issue.

Push the autonomous IOS back into the AP using this:  Using a TFTP Server to Return to a Previous Release

Once the AP boots up in autonomous IOS, copy the controller-based RCV IOS into the AP.

So go to the Cisco website and download two IOS:  The autonomous IOS and the CAPWAP IOS (RCV).

Thanks I will give it a shot, but this is what I was afraid of.  I bought the device but no service contract so i do not think they will give me access to software.  I am pretty sure that they want me to buy smart net, which I heard is thousands of dollars per year.  Not sure if my company will go for that.  I may just return the device and buy another one with a non corrupt OS. 

I am pretty sure that they want me to buy smart net, which I heard is thousands of dollars per year. 

I have no idea where you got this information, but this is not the case.

Get a list of a number of authorized reseller and ask all of them to submit a quote for SmartNET which will include the ability to download firmware for your controller and APs.

Make sure you ask about three to four of them. 

Review Cisco Networking for a $25 gift card