12-07-2015 08:46 AM - edited 07-05-2021 04:21 AM
I'm hoping my question has an easy answer, so here it is:
We've got 3 Aironet 2600 Access points set up as access points with a radius server. Encryption is aes-ccm, authentication is open+EAP and key management is wpa, no VLAN. As of now, we are only getting 54Mbps on the 2.4 and 5 GHz radios. I wanted to take advantage of the MCS rates, so I enabled World Mode Multi-domain operation (Dot11d, US, indoor) and then tried to enable the MCS rates. I'm doing this via the web interface since this is the only way I know how to modify the config. The issue is that I cannot apply the MCS rate changes. When I hit apply, nothing happens. Any other change I make applies to the wap without issue (e.g. WMM was fine). I thought it might have been a browser issue, so I went on an old server 2000 box with IE6 installed. This made no difference. The same happened when I ran it off Firefox 2 (another supported browser).
Does anyone know why the MCS rates will not apply? I'm guessing I'll need to provide more info, but any and all help is much appreciated.
Solved! Go to Solution.
12-08-2015 02:49 AM
Hi,
Enable mcs data rate as per this document:
interface Dot11Radio0 or dot11radio1
no ip address
no ip route-cache
!
ssid myssid
!
speed basic-1.0 2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0 m0. m1. m2. m3. m4. m8. m9. m10. m11. m12. m13. m14. m15.
http://www.cisco.com/c/dam/en/us/td/docs/wireless/access_point/15_2_4_JB/configuration/guide/scg15_2_4_JB3a.pdf
Regards
Dont forget to rate ehlpful posts
12-07-2015 11:20 AM
WLAN Security Setting should be WPA2 policy with AES encryption (do not enable WPA).
In addition to this settting you required to enable WMM (either Allow or Required under WLAN > QoS setting) in order to get 802.11n/802.11ac (or MCS) data rates.
HTH
Rasika
*** Pls rate all useful responses ***
12-08-2015 02:49 AM
Thanks for the quick response, Manannalage. It looks like I have WMM enabled for both radios under QoS. AES CCMP is enabled as the cipher under encryption modes, but where would I set the WPA2 policy? When I'm looking at my config, I see authentication key-management wpa version 2. Is that not where i should be looking? Here's my current config:
!
! Last configuration change at 11:03:54 -0500 Mon Dec 7 2015 by user
! NVRAM config last updated at 11:03:54 -0500 Mon Dec 7 2015 by user
! NVRAM config last updated at 11:03:54 -0500 Mon Dec 7 2015 by user
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname mywap
!
logging rate-limit console 9
!
aaa new-model
!
!
aaa group server radius rad_eap
server x.x.x.x auth-port 1812 acct-port 1813
!
aaa group server radius rad_mac
!
aaa group server radius rad_acct
!
aaa group server radius rad_admin
server x.x.x.x auth-port 1812 acct-port 1813
!
aaa group server tacacs+ tac_admin
!
aaa group server radius rad_pmip
!
aaa group server radius dummy
!
aaa group server radius rad_eap1
server x.x.x.x auth-port 1812 acct-port 1813
!
aaa group server radius rad_eap2
server x.x.x.x auth-port 1812 acct-port 1813
!
aaa authentication login default local
aaa authentication login eap_methods group rad_eap
aaa authentication login mac_methods local
aaa authentication login eap_methods2 group rad_eap2
aaa authorization exec default local
aaa accounting network acct_methods start-stop group rad_acct
!
!
!
!
!
aaa session-id common
clock timezone -0500 -5 0
clock summer-time -0400 recurring
no ip routing
!
!
dot11 syslog
!
dot11 ssid Wireless
authentication open eap eap_methods2
authentication key-management wpa version 2
guest-mode
!
dot11 network-map
dot11 arp-cache optional
crypto pki token default removal timeout 0
!
!
username myuser privilege 15 password 7 101D08140C101D18
username myuser2 password 7 00364002170B13545F7019
!
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
encryption mode ciphers aes-ccm
!
ssid myssid
!
antenna gain 0
stbc
speed basic-1.0 basic-2.0 basic-5.5 basic-11.0 basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
station-role root
world-mode dot11d country-code US indoor
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio1
no ip address
no ip route-cache
!
encryption mode ciphers aes-ccm
!
ssid my ssid
!
antenna gain 0
dfs band 3 block
stbc
speed basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
channel width 40-above
channel dfs
station-role root
world-mode dot11d country-code US indoor
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface GigabitEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
bridge-group 1
bridge-group 1 spanning-disabled
no bridge-group 1 source-learning
!
interface BVI1
ip address x.x.x.x x.x.x.x
no ip route-cache
!
ip default-gateway x.x.x.x
ip http server
ip http authentication aaa
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
ip radius source-interface BVI1
radius-server attribute 32 include-in-access-req format %h
radius-server host 10.100.1.51 auth-port 1812 acct-port 1813 key 7
radius-server vsa send accounting
!
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
transport input all
!
sntp server x.x.x.x
sntp broadcast client
end
12-08-2015 02:49 AM
Hi,
Enable mcs data rate as per this document:
interface Dot11Radio0 or dot11radio1
no ip address
no ip route-cache
!
ssid myssid
!
speed basic-1.0 2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0 m0. m1. m2. m3. m4. m8. m9. m10. m11. m12. m13. m14. m15.
http://www.cisco.com/c/dam/en/us/td/docs/wireless/access_point/15_2_4_JB/configuration/guide/scg15_2_4_JB3a.pdf
Regards
Dont forget to rate ehlpful posts
12-08-2015 07:45 AM
Thanks, Sandeep.
When I try to apply those settings in the web interface (hit apply), nothing happens. If i try to telnet into the wap and set them as you have linked and show me here, it appears to be working but when I show the config, it is still set to basic rates only.
Am I missing something else in my config above that would prevent the MCS rates from enabling properly?
12-08-2015 11:09 AM
Config is correct except zour basic rates under interface configuration.
GUI of autonomous AP is normally very slow so better to use cLI to configure it.
*** If still fails to get 802.11n rates then try to create a open ssid and check it.
Regards
Dont forget to rate helpful posts
12-08-2015 11:12 AM
Looks good now, Sandeep. Thank you for the quick and helpful assistance.
02-02-2018 03:40 PM
hello, how was this resolved? i am having the same issues with a 2602 AP. i am unable to get N speeds and have tried enabling MCS but i am unable to 'apply' changes using the GUI. i am also unable to apply WMM. i try to hit Dot11d and indoor, but it asks me for a country code, but nothing comes up in the dropdown? apologies but i am not familiar with CLI too much and have been trying to figure this out using the GUI. many thanks in advance!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide