cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
28339
Views
56
Helpful
20
Replies

Client Stuck in IP learn state cisco 9800 WLC

ittechk4u1
Beginner
Beginner

Hello Experts,

 

I am testing Cisco 9800 series WLC with software version 17.3.3, 9115 AP is in local mode.

 

Issue: When I am using external DHCP server , also added the ip helper address command on upstream switch then all clients stuck in IP learn state.

 

If I use internal DHCP server then it working.

 

What could be the issue ?

 

Thanks

 

 

 

 

 

2 Accepted Solutions

Accepted Solutions

did you try to upgrade the software to 17.6 and try again

View solution in original post

I think you can go confirm the below;

Make sure that the Layer 2 vlans are create

!

vlan 180-195,172

!

If there is any SVI's for user VLAN's delete them, unless you need mdns or dhcp relay you really dont need any SVI's for user vlans.In the upstream switch configure the IP helper address under the interface.

!

Most importantly as @JPavonM mentioned please check the PCAP, if the upstream switch is IOS-XE you can run it in the switch itself, if not you may have to use SPAN. Alternatively you can use PCAP feature in 9800 (not AP PCAP).

!
Also make sure that no DHCP server IP address is configured under the policy profile. And use the VLAN ID is configured under the policy profile.

 

View solution in original post

20 Replies 20

Is the WLC you are testing is a physical WLC or virtual? Did you check whether the DHCP discover messages are received by the upstream switch? You may do a PCAP or a debug if possible to check. Also post the upstream switchport config to the WLC (do not use any native VLANs)

Its a physical WLC and no native vlan configured.

 

Here is the config:

 

 

interface Port-channel3
description *** WLAN2 ***
switchport trunk allowed vlan 180-195,172
switchport mode trunk
ip dhcp snooping trust
!
interface GigabitEthernet1/0/4
description *** WLAN2,  Port0 ***
switchport trunk allowed vlan 180-195,172
switchport mode trunk
channel-group 3 mode active
ip dhcp snooping trust
!
interface GigabitEthernet2/0/4
description *** WLAN2, Port1 ***
switchport trunk allowed vlan 180-195,172
switchport mode trunk
channel-group 3 mode active
ip dhcp snooping trust

 

Thanks !

 

Did you try disabling IP DHCP snooping for the Wireless VLAN's. (not adding ip dhcp snooping trust, remove VLAN's from ip dhcp snooping) Also if you have ARP inspection disable that as well for the wireless VLANs. Also check on the switch logs and if possible run a debug or PCAP to see DHCP discover packets from the client is hitting the Gateway.

disabled both (DHCP snooping & ARP inspection)...still same issue

marce1000
VIP
VIP

 

 - You may have some radioactive-trace (client debugging) . which you can let analyze with : 

                       https://cway.cisco.com/tools/WirelessDebugAnalyzer/

 M.



-- ' 'Good body every evening' ' this sentence was once spotted on a logo at the entrance of a Weight Watchers Club !

Sandeep Choudhary
VIP Alumni
VIP Alumni

Disable IPv4 DHCP Required and try again!

 

 

Yes I did try but still not successful.

I tested in my lab and it worked for me .

 

Please do these and test again:

1. Uncheck the box for IPv4 DHCP Required

2. Enter the correct DHCP server IP Address

 

if still not working then save the config and reboot WLC.

 

 

 

 

NO its not working. 

where did you do these at?

JPavonM
VIP
VIP
  1. Is there any firewall that may be filtering DHCP traffic?
  2. Do you have SVIs created on WLC for those VLANs where you want DHCP to be received? Are you setting DHCP source interface?
  3. Have you tried a monitor session to capture UDP traffic in Po3 and check if all DORA process is there, or al least Discoveries and Offers?
  4. Can you try to bounce the radio interface to check if this is solved? I mention this because on 17.3.2 there is a bug (CSCvw18047) which is supposed to be fixed in 17.3.3 and that is the observed behaviour, and the workaround to solve it.

HTH
-Jesus
*** Please rate helpful responses ***

did you try to upgrade the software to 17.6 and try again

I think you can go confirm the below;

Make sure that the Layer 2 vlans are create

!

vlan 180-195,172

!

If there is any SVI's for user VLAN's delete them, unless you need mdns or dhcp relay you really dont need any SVI's for user vlans.In the upstream switch configure the IP helper address under the interface.

!

Most importantly as @JPavonM mentioned please check the PCAP, if the upstream switch is IOS-XE you can run it in the switch itself, if not you may have to use SPAN. Alternatively you can use PCAP feature in 9800 (not AP PCAP).

!
Also make sure that no DHCP server IP address is configured under the policy profile. And use the VLAN ID is configured under the policy profile.

 

ok I will try this and let you know.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: