Showing results for 
Search instead for 
Did you mean: 

Client Stuck in IP learn state cisco 9800 WLC


Hello Experts,


I am testing Cisco 9800 series WLC with software version 17.3.3, 9115 AP is in local mode.


Issue: When I am using external DHCP server , also added the ip helper address command on upstream switch then all clients stuck in IP learn state.


If I use internal DHCP server then it working.


What could be the issue ?








20 Replies 20

So finally these changes did the trick:



1. Upgrade to 17.6.1 version

2. Removed SVI form WLC

3. IP helper command  is on upstream Switch.


Thanks all for your help.

Glad to help and thanks for posting the workaround.

This was very helpful! Thank you for sharing. I'm running 17.3.4c and have spent hours troubleshooting. The solution for me was to remove the dhcp server address from the wlan policy. 

let me try this

1. Yes its there but client is getting IP when they connect with old WLC"2504"/AP but not with 9800 series.

    I also created dhcp scope on switch itself for testing where WLC is connected....still not working.

2. yes i did and also using the source interface

3. no I did not try..., FYI: If I use internal DHCP server then its working but not with External.

4. Tried still not working


any other ideas ?


Hello all,

A beginner to the group but not in years of service.

My issue was so simple I overlooked the obvious. In the WLC GUI I had the vlan added, but when I SSH'ed to the WLC CLI that vlan was not a part of the port-channel. Simple and easy.

Hope this helps.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers