cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1407
Views
5
Helpful
7
Replies

configure to broadcast 2 ssid on the same radio interface

Ed Lo
Level 1
Level 1

Hi,

I'm trying to put 2 ssid on the same radio interface but each time it keeps telling me that no vlan are configured in MBSSID mode. What do I need to do? I've tried google in the hopes of finding something but, I had no luck with it.

thank you

7 Replies 7

Hello

Can you post you existing config please?

res
Paul


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Current configuration : 3016 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ap
!
enable secret 5 $1$nD9N$8fK4tS4Yb8k7rTYyosEU2/
!
no aaa new-model
!
!
dot11 syslog
!
dot11 ssid batman
guest-mode
!
!
!
!
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
shutdown
!
ssid batman
!
antenna gain 0
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio1
no ip address
no ip route-cache
shutdown
antenna gain 0
dfs band 3 block
channel dfs
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface GigabitEthernet0
description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router
no ip address
no ip route-cache
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
!
interface BVI1
ip address dhcp client-id GigabitEthernet0
no ip route-cache
!
ip http server
no ip http secure-server
ip http help-path 
!
line con 0
privilege level 15
login local
no activation-character
line vty 0 4
login local
!
cns dhcp
end

Hi

Pls check you config with below sample config & see if anything is missing. In my example I have assigned those two SSIDs into two different vlans

hostname AP-01
!
dot11 ssid <SSID1>
vlan 10
authentication open
authentication key-management wpa version 2
mbssid guest-mode
wpa-psk ascii <SSID1_PASSWORD>
!
dot11 ssid <SSID2>
vlan 20
authentication open
authentication key-management wpa version 2
mbssid guest-mode
wpa-psk ascii <SSID2_PASSWORD>
!
interface Dot11Radio0
encryption vlan 10 mode ciphers aes-ccm
encryption vlan 20 mode ciphers aes-ccm
mbssid
ssid SSID1
ssid SSID2
no shut
!
interface Dot11Radio1
channel width 40-above
encryption vlan 10 mode ciphers aes-ccm
encryption vlan 20 mode ciphers aes-ccm
mbssid
ssid SSID1
ssid SSID2
no shut
!
interface Dot11Radio0.10
encapsulation dot1Q 10
bridge-group 10
!
interface Dot11Radio0.20
encapsulation dot1Q 20
bridge-group 20
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
bridge-group 1
!
interface Dot11Radio1.10
encapsulation dot1Q 10
bridge-group 10
!
interface Dot11Radio1.20
encapsulation dot1Q 20
bridge-group 20
!
interface Dot11Radio1.1
encapsulation dot1Q 1 native
bridge-group 1
!
interface GigabitEthernet0.10
encapsulation dot1Q 10
bridge-group 10
!
interface GigabitEthernet0.20
encapsulation dot1Q 20
bridge-group 20
!
interface GigabitEthernet0.1
encapsulation dot1Q 1 native
bridge-group 1
!
interface BVI1
ip address 192.168.1.2 255.255.255.0
ip default-gateway 192.168.1.1
!
end

HTH

Rasika

*** Pls rate all useful responses ***

Thank you this helps.

Do the vlans have to be configured before doing this? I've struggled a bit at finding how to configure a vlan.

How you connect this AP to rest of your network ?

Is it connect to a Cisco switch or is it connect to unmanaged switch ?

Do you want those two SSID in two different vlans ? or same vlan ?

If you can provide  answers to above and give us your existing config (show run  output form AP CLI) removing passwords/sensitive info, we can have a look and suggest how you can achieve what you want.

HTH

Rasika

It's not connected to a switch and different vlan would be preferable. As i said in the post i can only get it to broadcast the current ssid any attempts I've had to add another only result in errors. It will result in saying "no vlan are configured in MBSSID mode" and the radio does not start up.

The following is the current config:


Current configuration : 3016 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ap
!
enable secret 5 $1$nD9N$8fK4tS4Yb8k7rTYyosEU2/
!
no aaa new-model
!
!
dot11 syslog
!
dot11 ssid batman
guest-mode
!
!
!
!
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
shutdown
!
ssid batman
!
antenna gain 0
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio1
no ip address
no ip route-cache
shutdown
antenna gain 0
dfs band 3 block
channel dfs
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface GigabitEthernet0
description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router
no ip address
no ip route-cache
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
!
interface BVI1
ip address dhcp client-id GigabitEthernet0
no ip route-cache
!
ip http server
no ip http secure-server
ip http help-path
!
line con 0
privilege level 15
login local
no activation-character
line vty 0 4
login local
!
cns dhcp
end

if you erase your existing config and apply sample configuration I have given in the first response that should work (SSID name & password modify accordingly)

In my example vlan 10 and vlan 20 assign for those two SSIDs. You need to define those vlans gateway on your switch where this AP connects. In that scenario, AP connect switchport config should be like below.

interface GigabitEthernetx/x
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,10,20
switchport mode trunk

AP management on vlan 1 (in my example 192.168.1.0/24 is assigned for that)

HTH

Rasika

Review Cisco Networking for a $25 gift card