Showing results for 
Search instead for 
Did you mean: 

convert LAP to AP

Level 1
Level 1


am tryin to convert a 1242LAP to 1242AP but am not very clear with the process.

i am tryin to follow a document from cisco but i don understand something about it.

i give my pc address

connect the LAP to the laptop using ethernet

remove the power from the LAP

put the power back while holding the mode button.

the part that i don understand is,how do i get to access the LAP from the laptop.i just dont understand this part,the document talks about accessin the LAP via gui or CLI but it does not specify how.Can somebody clarify this part.

below is the link to the document am using.

13 Replies 13

Cisco Employee
Cisco Employee

here's an easy way to do it... let the AP join your controller and then, from the controller, use this:

config ap tftp-downgrade

If you don't have the LAP on a controller and you want to do it via your laptop, then what you need to do is this:

Using a TFTP Server to Return to a Previous Release

Follow these steps to revert from LWAPP mode to autonomous mode by loading a Cisco IOS release using a TFTP server:


Step 1 The PC on which your TFTP server software runs must be configured with a static IP address in the range of to

Step 2 Make sure that the PC contains the access point image file (such as c1200-k9w7-tar.122-15.JA.tar for a 1200 series access point) in the TFTP server folder and that the TFTP server is activated.

Step 3 Rename the access point image file in the TFTP server folder to c1200-k9w7-tar.default for a 1200 series access point.

Step 4 Connect the PC to the access point using a Category 5 (CAT5) Ethernet cable.

Step 5 Disconnect power from the access point.

Step 6 Press and hold the MODE button while you reconnect power to the access point.

Step 7 Hold the MODE button until the status LED turns red (approximately 20 to 30 seconds), and release the MODE button.

Step 8 Wait until the access point reboots as indicated by all LEDs turning green followed by the Status LED blinking green.

Step 9 After the access point reboots, reconfigure the access point using the GUI or the CLI.

Once this is done, then connect to the AP using the Cisco console cable. You have to configure the AP before you can use the GUI. Once you have an IP set on the AP for management, then you will be able to telnet or web into the AP.

Hope this helps.

*** Please rate helpful posts ***

Just a question on the AP image file.. since 12.2 is outdated and well, I can't find it. Could any image file be used? say 12.3-8?



Yes... just change the .tar to .default as mentioned on the notes. Should look like this:


*** Please rate helpful posts ***

Or change the name to c1200-k9w7-tar.default

Can't remember off hand, but if you are also consoled in while you hole the mode for 30+ seconds, then you will see what filename the AP is trying to get from the tftp server.

*** Please rate helpful posts ***

hi fella,

i have done all the steps but am not able to configure an IP address on the LAP,i have tried all the commands that i thought would help me but i still failed.

what command should i use.

First you must verify that the conversion worked. Usually when I perform this conversion from lwapp to IOS, I will have my laptop ethernet connected to the ap and also I would have a console cable attached to the ap so I can see if the conversion failed or not. If you can enter the show lwapp ip config command, then the ap is still lwapp. The ap most likely failed during the conversion. Try to do the conversion and copy the output from the console so I can see it.

*** Please rate helpful posts ***

hi fella,

there is the ouput form the Ap as i do the coversion.

This is what I would do:

1. Download a new version of IOS for the 1242 AP's

2. Rename the IOS to c1240-k9w7-tar.default

3. Download and install 3CDeamon

4. Connect your laptop to a switch along with the ap. it looks like the ap is negotiating at 100 half.

5. Configure your ethernet ip as /

6. Start 3CDeamon and make sure you configure the root directory with the c1240-k9w7-tar.default in the root

7. Hold the reset and power cycle the ap. Hold the reset for at least 60 sec.

8. Take a look at the output

Here is your output and where it failed:

image_recovery: Download default IOS tar image tftp://

examining image...tftp:// connection timed out

*** Please rate helpful posts ***

hi fella,

this is what i get now,but the firewaal in my pc is disabled and there are no hidden files on there any setting i have to do on the 3CDeamon

image_recovery: Download default IOS tar image tftp://

examining image...tftp:// access denied

You have to configure where the root directory is. This is where your files will be located.

*** Please rate helpful posts ***

Marius Ilie
Level 1
Level 1

Hi everybody,

Since when can you convert a LAP into an AP? From what I know the HW is different and the LAPs only work with a WLC. The only way to convert a LAP into an AP is for the LAP to have been an AP converted to LAP which case you'll have to load an iOS on it.

See Cisco help for more info, the following should help if you have a AP converted to LAP:




Hardware is the same, it's the boot up code that determines if it's a LAP or autonomous. You were always able to convert back and fourth no matter what model you actually purchased. You just need to be able to download the proper code. It's the country code that is hardware dependent. 



*** Please rate helpful posts ***
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card