cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1106
Views
0
Helpful
9
Replies

How many wireless management interface can be created in Cisco 3650 ?

lswong001
Level 1
Level 1

Hi Guys,

 

I have one question regarding to Cisco 3650 with WLC features.

 

I have 2 units of Cisco 3650 (stacking) and 16 Access Points. Can I group the Access Points in 2 groups like 10 units to Group 1 (vlan 10) and 6 units to Group 2 (vlan 20) ?

 

Thanks.

9 Replies 9

Ric Beeching
Level 7
Level 7

Hi,
When using converged access (I think that's what you are referring to), all APs must be on the same VLAN as the wireless management interface of that switch and must also be directly connected to work. You can only create one wireless management interface per logical stack.

 

What design aim are you trying to achieve with an AP split?

Thanks,
Ric

-----------------------------
Please rate helpful / correct posts

Hi Ric,

 

Thanks for your answer & sharing.

The aim for the AP split is to publish certain SSID in certain group of AP.

 

The group of AP is located in different building.

 

Thanks.

Oh right, absolutely then. So just confirming, are you using converged access with the WLC integrated on the switch? I ask as that is not really developed by Cisco anymore and is not recommended but some customers still use it.

For your APs, it doesn't matter what subnet their control traffic is on, you can just split them into AP Groups on the controller/switch and apply the requires SSIDs to those AP Groups.

Ric
-----------------------------
Please rate helpful / correct posts

yes. using converged access with the WLC integrated on the switch.

 

========= configuration in Cisco 3650 ==============

 

wireless mobility controller
wireless management interface Vlan10
wireless management interface Vlan20

!
interface Vlan10
description Wifi_Management_Group1 Interface
ip address 10.10.0.2 255.255.255.0
!
interface Vlan20
description Wifi_Management_Group2 Interface
ip address 10.20.0.2 255.255.255.0
!

interface range GigabitEthernet1/0/1 - 10
description CAPWAP AP Group 1
switchport access vlan 10
switchport mode access
!


interface range GigabitEthernet1/0/11 - 16
description CAPWAP AP Group 2
switchport access vlan 20
switchport mode access
!

=================================================

 

It is workable ?

No you must out all APs on same wireless management interface and then create two logical AP Groups on the WLC to split your SSIDS. This example will put all APs on VLAN10 (assuming you have DHCP for it) and create SSID1 and SSID2 with a 50:50 AP Split.

Is there a reason that you are using .2 in the 10.10.0.0 range for VLAN10? Ideally that would be .1 if your switch is the gateway for that VLAN. I've put .1 in the example below but feel free to alter.

#Enable MC Function
conf t
wireless mobility controller
exit
(Switch may require a reload)


#Enable licensing
license right-to-use activate apcount <# of APs/licenses>

#If using multiple switches you want to create a mobility switch peer group but I'll skip that bit for now.
#Configure SVI for wireless management

conf t
interface Vlan10
description Wifi_Management_Group1 Interface
ip address 10.10.0.1 255.255.255.0
!
interface range GigabitEthernet1/0/1 - 16
description CAPWAP AP
switchport access vlan 10
switchport mode access
!
#Configure management interface/vlan
wireless management interface Vlan10
exit
#All directly connected APs should now join the WLC
!
#Create 2 SSIDs
conf t
wlan SSID1 1 SSID1
no shut
exit
wlan SSID2 2 SSID2
no shut
exit

#Create 2 AP Groups and assign APs to them
ap group APG1
wlan SSID1
exit
exit
ap group APG2
wlan SSID2
exit
exit
ap name <name of AP> ap-groupname APG1
!Repeat with all APG1 APs
ap name <name of AP> ap-groupname APG2
!Repeat with all APG2 APs
end


-----------------------------
Please rate helpful / correct posts

Hi Ric,

 

Thanks for your sharing and explanation.

 

Last question from me.

Some of the APs connection did not connect to Cisco 3650 directly, 

 

Cisco 3650 (stack) -> Cisco 2960X -> AP

 

- I will trunk the wifi management vlan from 3650 to 2960X.

- do i need to configure anything in 2960x ? like convert to Mobility Control mode ? etc ...

 

Thanks.

No problem,

The 2960X cannot do converged access to all you can do is setup a trunk between the two and try. Officially from TAC/Cisco, all APs must be directly connected to the switch so you may find they do not work when trunked through this way but you can always try.

What model of AP do you have? If one is Mobility Express capable (2802/3802) you could use that instead of the converged access and APs can be connected cross-switch with that method.

Ric

-----------------------------
Please rate helpful / correct posts

Hi Ric,

 

Thanks again on your information.

 

The AP that we will use is AIR-AP1832I-Q-K9.

We will try the connection to 2960X during the implementation and update here the output.

 

Thanks.

Ok well if that doesn't work for you then I suggest the following. This isn't a perfect solution as you need to effectively create two different networks (one for each AP set) as mobility express currently does not support multiple AP Groups on one ME AP.

1) Delete all wireless mobility config as applied above (no wireless mobility controller should also disable it)
2) Configure the two VLANs as you originally described; one for each AP Set/Group.
3) Convert two 1832 APs to Mobility Express mode, with one on VLAN10 and one on VLAN11, and configure using this guide:
https://www.cisco.com/c/en/us/td/docs/wireless/controller/technotes/8-5/b_cisco_mobility_express_8_5/b_cisco_mobility_express_8_5_chapter_01.html

4) Configure your required APs to join each ME (put them in same VLAN 10 or 11) and they will broadcast the required SSIDs once once joined.

Ric
-----------------------------
Please rate helpful / correct posts
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card